ISP 2.2.35 - Awstats - Keine Auswahl möglich

#1
Moin zusammen...

ich bin grad dabei zu Updaten...

nach einigen Fehlern und einer leeren ISP Datenbank...

läuft nun alles... jedoch vermisse ich die angepriesene Funktion der Auswahl des Statistik-Tools...

Ich habe lediglich eine "Checkbox" für Webalizer...

jedoch keine spur von Awstats...

Wie kanns sein?

Version ist 2.2.35


LG mini... :confused:
 
Zuletzt bearbeitet:
#3
tja,

wie gesagt getan...

wieder das Setup gestartet, wurde wieder als "Upgrade" erkannt...

er Compiliert fröhlich... so ca. 5-10 min...

dann rödelt er... und dann kommen zum krönenden abschluss
"Mysql Fetch Errors" ... tja dann geht mal im Mysql DB ordner schauen...
und siehe da... die Komplette ISP Db ist leer...

Code:
Alle Voraussetzungen erfuellt.
Here we go...

Connected successfully to db db_ispconfig
sh: PphGfreD65g: command not found
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using  password: YES)
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using  password: YES)

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL  result resource in /src/install_ispconfig/install.php on line 828

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL  result resource in /src/install_ispconfig/install.php on line 833

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL  result resource in /src/install_ispconfig/install.php on line 843

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL  result resource in /src/install_ispconfig/install.php on line 860

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL  result resource in /src/install_ispconfig/install.php on line 1175
Neustart einiger Dienste...
 * Stopping Postfix Mail Transport Agent  postfix                                                                            postfix: warning: inet_protocols: IPv6 support is disabled: Address  family not supported by protocol
postfix: warning: inet_protocols: configuring for IPv4 support only
                                                                                                                     [ OK ]
 * Starting Postfix Mail Transport Agent  postfix                                                                            postfix: warning: inet_protocols: IPv6 support is disabled: Address  family not supported by protocol
postfix: warning: inet_protocols: configuring for IPv4 support only
                                                                                                                     [ OK ]
 * Stopping ftp server  proftpd                                                                                       [ OK ]
 * Starting ftp server  proftpd                                                                                               - warning: handling possibly truncated configuration data at line 154  of '/etc/proftpd/proftpd.conf'
 - setting default address to 127.0.0.1
                                                                                                                     [ OK ]
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not  running
ISPConfig system stopped!
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL  result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!ISPConfig system is now up and running!
Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert.  Falls Sie Quota nachinstalliert haben, fuehren Sie noch die in der  Installationsanleitung beschriebenen Schritte durch. Ansonsten ist Ihr  System jetzt ohne Reboot einsatzbereit.
Somit geht dann garnichts mehr...

Was kann man da nun tun...

LG mini
 
Zuletzt bearbeitet:

Till

Administrator
#4
Hast Du irgendwelche Sonderzeicehn im mysql root Passwort? Wenn ja, dann ändere das, da es sonst vorkommen kann dass die Shell Scripte das aöls Befehl interpretieren. Außerdem kannst Du nur updaten, wenn Du nichts an der Struktur der datenbank manuell geändert hast.
 
#5
Also das Passwort enthält denk ich mal solche zeichen... dann wird das gleich geändert... An der Struktur hab ich nie was geändert...

mal sehen...

LG
 

Till

Administrator
#7
Statistiken werden einmal pro Nacht erstellt. Versuch nicht die scripte manuell aufzurufen, das bring die Statistik durcheinander.
 
#9
Zur info, es hat funktioniert... :)

Es lag also an den Fehler im Vorfeld...

1. Punkt 22 - Perfect Server Setup
"replace getline in parseline"

2. ein root Passwort mit Sonder und Steuerzeichen... (MySQL: Fetch Error)

nachdem beides berichtigt wurde, klappte das Updaten einwandfrei!

Die Statistik ist nun auswählbar und funktioniert...

LG mini
 

Werbung

Top