ISP Config geht nicht richtig!

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von michaham, 9. Okt. 2008.

  1. michaham

    michaham New Member

    Guten Tag!

    Ich bekomme nur eine index.html angezeigt die in /var/www/html liegt.

    Alles was in den Ordnern von ISP-Config (web1, etc...) liegt, wird nicht angezeigt...

    Wenn ich http://host.example.at/user/testuser eingebe wird nur "page not found" angezeigt!

    (testuser = username angelegt unter webs im Admin-Bereich)

    Wenn ich aber eine php Seite unter /var/www/html laden will, wird mir nur der Inhalt in Textform angezeigt...

    kann mir jemand Tipps geben?

    danke
    michaham
     
  2. Till

    Till Administrator

    Vermutlich ist beim Web nicht die richtige IP ausgewählt. Wenn Dein Server hinter einem router steht, musst Du die interne IP auswählen.
     
  3. michaham

    michaham New Member

    Hallo!

    Ich habe das über dyndns.com gehostet und ist auch erreichbar...

    Es wird mir aber die /var/www/html Seite angezeigt!

    mfg
    michaham
     
  4. Till

    Till Administrator

    Genau und deshlab habe ich das oben geschrieben. Du hast in dyndns eine DNS A-Record für Deine Domain angelegt, die auf die externe IP Deines Routers verweist und Du must dann bei der Website in ISPConfig die interne IP auswählen, auf die Du port 80 von Deinem Router aus umgeleitet hast.
     
  5. michaham

    michaham New Member

    Die IP des Servers ist aber die IP des Routers...wird automatisch zugewiesen vom Router.....
     
  6. Till

    Till Administrator

    Die IP des Servers kann nicht die IP des Routers sein, da jedes Gerät in einem Netzwerk eine eindeutige IP haben muss.
     
  7. michaham

    michaham New Member

    Ich glaub das ist der ddclient für Linux....muss ich mir ansehen...
     

Diese Seite empfehlen