ISP-Config Installation [DNS]

#1
Hallo Liebe Community,

und zwar folgende Frage:

wenn ich ISP-Config lt. der Dok. im Internet installiere, wie richte ich das von Grund auf ein wenn ich eine Domain ns1.test.com und ns2.test.com mit den ips 80.120.120.12 als ns1 und 80.120.120.12 als ns2 habe?

Wie stelle ich das korrekt ein, das ich bei einem Nameserver Check alles korrekt zurück gegeben wird? Wo muss ich diese 2 Master IP's NS1 und NS2 im ISP-Config konfigurieren?

Vielen Dank!

glg mAx
 
#3
Re:

Hallo Till,

vielen dank für deine Antwort.


Meine Frage aber:
ich habe eine Domain registriert, und diese mittels Glue Records auf ns1.meinedomain.com und auf ns2.meinedomain.com eingerichtet.

ns1.meinedomain.com ist die eine ip vom server
ns2.meinedomain.com ist die zweite ip vom server

Wie richte ich das genau ein?

Vielen Dank!

glg mAx
 

Till

Administrator
#4
Du richtest einfach primäre dns records ein wie im obigen Howto beschrieben. Die secondarys sind nicht notwendig, da Du ja keinen secondary server hast.
 
#5
Re

Hallo Till,

danke für Deine Antwort..

Naja aber ich möchte diesen Server verwenden um Domains zu registrieren,
deswegen benötige ich ns1 und ns2 mit jeweils einer anderen IP bzw. eines anderen Subnetzes...

Wenn ich auf CheckDNS gehe, und das Durchchecken lasse, schreibt er diese Fehler...

Was mach ich den falsch?

Kannst Du mir helfen? Ich habe ein 4er Subnetz, verwende davon 2 ip Adressen.

Klar habe ich keinen sek. Server, aber ich verwende NS1 und NS2 am selben Server!
Ich kann nur Domains registrieren wenn es einen ns1 und ns2 gibt der jeweils eine abweichende IP-Adresse hat!

Die Konfiguration benötige ich wie gesagt nur zum Domains registrieren mit dem ISPConfig System.

Vielen Dank!

glg mAx
 
Zuletzt bearbeitet:

Till

Administrator
#6
Naja aber ich möchte diesen Server verwenden um Domains zu registrieren,
deswegen benötige ich ns1 und ns2 mit jeweils einer anderen IP bzw. eines anderen Subnetzes...
Das ist ganz klar, wozu betreibt man auch sonst einen nameserver ;)

Schau bitte nochmal in das Howto, es ist dort alles exakt beschrieben. Mach genau das, was dort auf der 1. Seite steht, nur halt für die Domain gamemind-blog.com und natürlich unter Verwendung der Nameserver Adressen, für die Du bereits glue records angelegt hast.

Der Fehler den Du bei Checkdns erhältsts, resultiert daraus dass Du den SOA, also primary record, nicht wie im Howto beschrieben angelegt hast.
 
#7
Re

Hallo Till,

naja ich hab das aber 1:1 gemacht wie im HowTO... ich verstehe das nicht.

Vielleicht kannst mir helfen...!

Ich hab vor ISP-Config zu verwenden, und nicht mehr Keyweb oder SYSCp.

Ich hoffe Du kannst mir helfen!

Vielen Dank!

glg mAx
 
Zuletzt bearbeitet:

Till

Administrator
#8
Die Einstellungen sehen soweit ok aus, es ist aber kein Nameserver auf Deinen IP's erreichbar. Entweder DNS ist durch eine Firewall geblockt oder bind ist nicht gestartet. Poste bitte mal die Ausgabe von:

netstat -tap | grep named

und:

iptables -L
 
#9
Re

Vielen dank für deine Antwort!



ns1:~# netstat -tap | grep named
tcp 0 0 ns2.domain:domain *:* LISTEN 2322/named
tcp 0 0 ns1.domain:domain *:* LISTEN 2322/named
tcp 0 0 localhost:domain *:* LISTEN 2322/named
tcp 0 0 localhost:953 *:* LISTEN 2322/named
tcp6 0 0 *:domain *:* LISTEN 2322/named
tcp6 0 0 ::1%494:953 *:* LISTEN 2322/named


ns1:~# iptables -L
Chain INPUT (policy DROP)
target prot opt source destination
DROP tcp -- anywhere loopback/8
ACCEPT 0 -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT 0 -- anywhere anywhere
DROP 0 -- BASE-ADDRESS.MCAST.NET/4 anywhere
PUB_IN 0 -- anywhere anywhere
PUB_IN 0 -- anywhere anywhere
PUB_IN 0 -- anywhere anywhere
PUB_IN 0 -- anywhere anywhere
DROP 0 -- anywhere anywhere
Chain FORWARD (policy DROP)
target prot opt source destination
ACCEPT 0 -- anywhere anywhere state RELATED,ESTABLISHED
DROP 0 -- anywhere anywhere
Chain OUTPUT (policy ACCEPT)
target prot opt source destination
PUB_OUT 0 -- anywhere anywhere
PUB_OUT 0 -- anywhere anywhere
PUB_OUT 0 -- anywhere anywhere
PUB_OUT 0 -- anywhere anywhere
Chain INT_IN (0 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere
DROP 0 -- anywhere anywhere
Chain INT_OUT (0 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere
ACCEPT 0 -- anywhere anywhere
Chain PAROLE (9 references)
target prot opt source destination
ACCEPT 0 -- anywhere anywhere
Chain PUB_IN (4 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere icmp destination-unreachable
ACCEPT icmp -- anywhere anywhere icmp echo-reply
ACCEPT icmp -- anywhere anywhere icmp time-exceeded
ACCEPT icmp -- anywhere anywhere icmp echo-request
PAROLE tcp -- anywhere anywhere tcp dpt:ftp
PAROLE tcp -- anywhere anywhere tcp dpt:ssh
PAROLE tcp -- anywhere anywhere tcp dpt:smtp
PAROLE tcp -- anywhere anywhere tcp dpt:domain
PAROLE tcp -- anywhere anywhere tcp dpt:www
PAROLE tcp -- anywhere anywhere tcp dpt:81
PAROLE tcp -- anywhere anywhere tcp dptop3
PAROLE tcp -- anywhere anywhere tcp dpt:imap2
PAROLE tcp -- anywhere anywhere tcp dpt:https
ACCEPT udp -- anywhere anywhere udp dpt:domain
DROP icmp -- anywhere anywhere
DROP 0 -- anywhere anywhere
Chain PUB_OUT (4 references)
target prot opt source destination
ACCEPT 0 -- anywhere anywhere

Vielen Dank!!

glg mAx
 
Zuletzt bearbeitet:

Till

Administrator
#10
Ok, named laäuft und mit den Firewall Einstellungen sollte es auch gehen.

1) Hast Du vielleicht noch eine 2. Firewall vor dem Rechner, z.B. auf einem Router oder bei Deinem Provider?
2) Steht der Server in einem Rechenzentrum oder hängt er lokal an einer DSL oder Standleitung?
3) Ruf auf dem Server bitte mal den Folgenden Befehl auf uns poste die Audgabe:

dig @localhost domain.com
 
#11
Re

Hallo Till,

Vielen dank für Deine Unterstützung!



Nein keine Firewall. Nur die Firewall die Standardmässig bei ISP-Config.de Dabei ist.

Server steht bei Hetzner als dedicated!

Ausgabe von dem Befehl:

ns1:/# dig @localhost domain.com
; <<>> DiG 9.3.4-P1.1 <<>> @localhost domain.com
; (1 server found)
;; global options: printcmd
;; connection timed out; no servers could be reached

Vielen Dank!

glg mAx
 
Zuletzt bearbeitet:

Till

Administrator
#12
Da lokal ein named läuft, er aber nicht erreicht werden kann, hat sich möglicherweise der named. daemon aufgehängt. Mach bitte mal folgendes:

1) named mit dem script in /etc/init.d stoppen.
2) aufrufen:

killall named

3) Mit:

netstat -tap | grep named

nachsehen, ob wirklich kein named mehr läuft.
4) named neu starten.

Zusatzfrage: Welche Linuxdistribution verwendest Du?
 
#13
Hallo Till,

Vielen dank für Deine Antwort!

Ich verwende Debian Etch (aktuellste) und habe folgende Befehl ausgeführt:
killall named
named

Und tatsächlich... mit dem checkdns.net alle perfekt OK....

Dann hatte sich also nur der named aufgehängt?
Wieso? Kann man dagegen was unternehmen?

Oder ist das nur der Fall nach der Grundinstallation?

Vielen Dank!

glg mAx
 
#15
Re

Hallo Till,

leider zu früh gefreut. nach einem reboot von der maschine ist wieder das gleiche problem wahrzunhemen...

was kann ich tun, damit der immer fix gestartet bleibt?


Vielen Dank!

glg mAx
 
#17
Re

Hallo Till,

vielen dank!

Ich hab das System noch einmal neu installiert!


Funktioniert perfekt.

Nur eine Frage:
Das mit dem Mail Dir's muss ich den Haken setzen?
Wozu ist der? Geht das E-Mailing sonst nicht?

Vielen Dank!

glg mAx
 

Till

Administrator
#18
Es gibt verschiedene Arten, Emails auf einem Server zu speichern. Mbox bedeutet, dass die Mails alle in einer großen datei liegen. Maildir bedeutet, dass jede Mail als einzelne Datei in einem Verzeichnis gespeichert wird.

Die Art der mailspeicherung hängt vom pop3 und Imap Daemon ab. Für Courier und Dovecot nimmt man Maildir, für andere mbox.

Maildir ist aber das modernere und sichere Verfahren, daher musst Du es aktivieren enn im perfect Setup wird Courier eingesetzt.
 
#19
Re

Hi Till d.h. ich muss vom HowTO auf der Seite http://www.howtoforge.com/perfect_setup_debian_etch_p5

Wo steht:
*Please note: You do not have to do this if you intend to use ISPConfig on your system as ISPConfig does the necessary configuration using procmail recipes. But please go sure to enable Maildir under Management -> Server -> Settings -> EMail in the ISPConfig web interface.

Jetzt trotzdem das ich Maildir verwende darf ich diesen Schritt nicht ausführen, sondern muss am ende der Installation in den Servereigenschaften einfach nur den Haken unter E-Mail mit "Maildir" setzen?

Eine Frage hätte ich da noch. Da ich eine Grundinstallation von Hetzner verwende, und ich dann den Hostname umbenenne in ns1.domain.com und anschließend ein hostname -F /etc/hostname ausführe, kann ich mittels apt-get update nichts mehr updaten. Also so gut wie keine Auflösung funktioniert mehr. Und ich weis nicht warum. Setze ich nur ns1 in die /etc/hostname dann funktioniert wieder alles blendent!

die hosts Datei habe ich angepasst. als resolv.conf sind standardmässig die hetzner Nameserver eingetragen!

Vielleicht kannst Du mir hier auch helfen?

Vielen Dank!

glg mAx
 
Zuletzt bearbeitet:

Till

Administrator
#20
Jetzt trotzdem das ich Maildir verwende darf ich diesen Schritt nicht ausführen, sondern muss am ende der Installation in den Servereigenschaften einfach nur den Haken unter E-Mail mit "Maildir" setzen?
Du darfst ihn schon ausführen, es ist aber egal, da die Emails durch procmail ausgeliefert werden und nicht durch postfix.

Eine Frage hätte ich da noch. Da ich eine Grundinstallation von Hetzner verwende, und ich dann den Hostname umbenenne in ns1.domain.com und anschließend ein hostname -F /etc/hostname ausführe, kann ich mittels apt-get update nichts mehr updaten. Also so gut wie keine Auflösung funktioniert mehr. Und ich weis nicht warum. Setze ich nur ns1 in die /etc/hostname dann funktioniert wieder alles blendent!
Kann ich Dir so auch nicht sagen, der Name ns1.domain.com wird ja im DNS richtig aufgelöst, wenn das dann auch noch Deine IP ist, sollte das soweit ok sein.

Was Du machen solltest, ist in der resolf.conf auch noch 127.0.0.1 als ersten nameserver einzutragen, damit er erstmal den lokalen Bind Server befragt.
 

Werbung