ISP Config Nginx und "mod_rewrite"

#1
Hallo ich bin von Appache auf Nginx gewechselt klappt alles.
Nur eine sache bekomme ich nicht hin.. ich hatte früher eine .htaccsess Datei da stand u.a. folgendes drin:

Options +FollowSymLinks
RewriteEngine On


RewriteRule ^startseite$ index.php

Nun habe ich für Nginx folgendes bei der Domain unter nginx Direktiven eingetragen:

rewrite ^/startseite$ index.php last;

Leider wird mir immer die ISP Config fehlerseite angezeigt anstatt dann z.b. das Impressum.. Das ganze soll nur dazu dienen die Urls schöner zumachen. hoffe mir kann jemand helfen.

MfG
 
Zuletzt bearbeitet:
#4
Es wurde im ISP Config Adminbereich unter Domain >> Optionen >> nginx Direktiven eingetragen und steht in der vhost datei unter: etc/nginx/sites-available/meinewebsite.de.vhost


PHP:
server {
        listen *:80;
        
        
        server_name meinewebsite.de *.meinewebsite.de;

        root   /var/www/meinewebsite.de/web;
        
        
        
        index index.html index.htm index.php index.cgi index.pl index.xhtml;
        

        
        error_page 400 /error/400.html;
        error_page 401 /error/401.html;
        error_page 403 /error/403.html;
        error_page 404 /error/404.html;
        error_page 405 /error/405.html;
        error_page 500 /error/500.html;
        error_page 502 /error/502.html;
        error_page 503 /error/503.html;
        recursive_error_pages on;
        location = /error/400.html {
            internal;
        }
        location = /error/401.html {
            internal;
        }
        location = /error/403.html {
            internal;
        }
        location = /error/404.html {
            internal;
        }
        location = /error/405.html {
            internal;
        }
        location = /error/500.html {
            internal;
        }
        location = /error/502.html {
            internal;
        }
        location = /error/503.html {
            internal;
        }
        
        error_log /var/log/ispconfig/httpd/meinewebsite.de/error.log;
        access_log /var/log/ispconfig/httpd/meinewebsite.de/access.log combined;

        ## Disable .htaccess and other hidden files
        location ~ /\. {
            deny all;
            access_log off;
            log_not_found off;
        }
        
        location = /favicon.ico {
            log_not_found off;
            access_log off;
        }

        location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
        }
        
        location /stats {
            index index.html index.php;
            auth_basic "Members Only";
            auth_basic_user_file /var/www/clients/client0/web1/.htpasswd_stats;
        }

        location ^~ /awstats-icon {
            alias /usr/share/awstats/icon;
        }

        location ~ \.php$ {
            try_files $uri =404;
            include /etc/nginx/fastcgi_params;
            fastcgi_pass 127.0.0.1:9010;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_script_name;
            fastcgi_intercept_errors on;
        }
 
        rewrite ^/startseite$ index.php last;
}
 
Zuletzt bearbeitet:

Werbung