ISP Config3 FTP Problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von sugersgroer, 4. März 2011.

  1. sugersgroer

    sugersgroer New Member

    Hi,
    Habs grad mal installiert aber irgendwie scheint der FTP nicht zu laufen?!?
    Im Ftp Client erhalt ich nur die Fehlermeldung:
    Code:
    Antwort:    Can't exec "/usr/sbin/pure-ftpd": No such file or directory at /usr/sbin/pure-ftpd-wrapper line 174.
    Fehler:    Herstellen der Verbindung zum Server fehlgeschlagen
    Ich arbeite sonst mit nem andern FTP Programm daher kann ich damit nun nicht viel anfangen. Kennt das jemand und weiß da auch jemand abhilfe?
    Laut ISPconfig läuft der FTP garnich aber laut Client ja anscheinend schon nur mit nem Fehler??
    Ich danke schonmal für eure Hilfe
     
  2. Till

    Till Administrator

    Nach welchem Tutorial hast Du denn ispconfig installiert? Es scheint so als ob Du pure-ftpd über inetd oder xinetd laufen lässt anstatt standalone wie in der Installationsanleitung erläutert wird.
     
  3. sugersgroer

    sugersgroer New Member

  4. Till

    Till Administrator

    Das log sagt was anderes. Poste mal die ausgabe von:

    netstat -tap | grep ftp
     
  5. sugersgroer

    sugersgroer New Member

    Code:
    Remote: 14:13:48 [root@goliath ~]:netstat -tap |grep ftp
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      -
    
    Unterstützt ISPconfig denn nur diesen ftp clienten?
     
  6. Till

    Till Administrator

    pure-ftpd ist ein FTP Server, kein client. Du kannst jeden FTP client mit pure-ftpd verwenden. ISPConfig unterstützt nur pure-ftpd.

    Dem obigen output nach ist pureftpd nicht richtig installiert bzw läuft nicht im standalone mode.

    poste mal die Ausgabe von:

    ps aux
     
  7. sugersgroer

    sugersgroer New Member

    Ich meinte ja auch den Server ....Klar isn Client nur bei mir aufn pc :)....ich setz den einfach nochmal auf....hab kein bock da nu stundenlang son dummen fehler zu suchen...keine zeit für sowas grad....ps aux bringt übrigens garnix
     
  8. sugersgroer

    sugersgroer New Member

    hmm alles neu und in ruhe gemacht aber das gleiche problem....kanns doch net sein ...
     
  9. sugersgroer

    sugersgroer New Member

    Code:
    root@goliath:/tmp/ispconfig3_install/install# /etc/init.d/pure-ftpd-mysql start
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -H -E -O clf:/var/log/pure-ftpd/transfer.log -A -b -u 1000 -D -B
    root@goliath:/tmp/ispconfig3_install/install#
    
    das kommt beim starten und habs nochmal genau nachdem todo gemacht...wieso wird denn nur pureftp unterstützt grml
     
  10. Laubie

    Laubie Member

    installierst du da auf einem VServer?
     
  11. sugersgroer

    sugersgroer New Member

    ja isn vserver aber das sollte bei dem ftp an sich ja kein problem darstellen...es läuft auf anderen vservern ja auch
     
  12. Laubie

    Laubie Member

    je nach virtualisierungssoftware musst du dir dein ftp-server aber selber kompilieren.
    such mal hier im Forum danach, wurde schon mehrfach beschrieben.

    Grüße
    Laubie
     
  13. sugersgroer

    sugersgroer New Member

    was setzt denn server4you als virtualisierungslösung ein? Soweit ich das seh müßte das virtuzzo oder sowas sein und da das echt soweit verbreitet is sollte ispconfig damit doch kompatibel sein denk ich...
     
  14. Till

    Till Administrator

    Erstmal vorweg, mit ispconfig hat das Ganze nichts zu tun. ISPConfig ist ein Server control panel, es schreibt also Konfigurationsdateien für Dienste und legt Ordner an etc. ISPConfig hat mit Virtualisierungssoftware überhaupt keine Probleme, da es nicht mit ihnen oder dem Linux Kernel direkt interagieren muss.

    Das Problem das Du hast ist, das ein bestimmeter Dienst, hier pure-ftpd, nicht startet. Und dies liegt daran dass Dein provider in Virtuozzo eine Einstellung vorgenommen hat welche die sog. kernel capabilities abschaltet. Dies führt dazu, dass pure-ftpd in seiner Standardkonfiguration von Debian nicht starten kann.

    Es gibt dafür 2 Lösungen:

    a) Capabilities in der VM aktivieren. Diese Lösung nimmt man wenn man den VM Server selbst betreibt oder bei einem kleineren und flexiblen Hoster ist. bei Server4You wirst Du Dir mit einer solchen individuellen Forderung vernutlich die Zähne ausbeißen.

    b) Also dann zu dieser Lösung, wie Laubie bereits geschrieben hat kompiliert man den pure-ftd ganz einfach selbst und schaltet dabei die capability Funktion aus:

    http://www.howtoforge.de/howto/pureftpd-ohne-capabilities-unter-debian-lenny-selbst-bauen/

    bzw:

    http://www.faqforge.com/linux/contr...irtual-machines-without-capabilities-enabled/
     
  15. sugersgroer

    sugersgroer New Member

    Um ISPConfig nur mal zu testen is mir das allerdings viel zu viel Arbeit wenn ich ehrlich bin. Aber danke für die Antworten. Ich werd das mal im laufe des Monats weiter probieren bis dahin macht der Root aufjedenfall noch das was er soll.
    Um vorher das einfach mal bissl zu testen hat da jemand vielleicht bissl Space mit nem Acc von ISP? Dann kann ichs mal anschauen im Betrieb.
    Wenn nich muss es halt einfach noch warten im Moment hab ich im Job noch zuviel um die Ohren das ich mich damit mal echt auseinander setzen könnte.

    @ Till: Danke für die ausführliche Antwort. Bin allerdings kein Newbie etc. die kurzen knappen Antworten sind zeitlich bedingt bei mir gewesen ;) Das ISP nix mit dem Server an sich zutun hat is mir auch schon klar aber es hätte ja auch einfach ein Problem am ISP sein können was evtl. bekannt gewesen wär :)
     
  16. Laubie

    Laubie Member

Diese Seite empfehlen