ISP3 3.x Apache2 Worker

#1
Hallo,

ich würde gerne wissen wie die Unterstützung vom apache2 - worker ist?!

Soweit ich es gesehen hatte, ließ sich ja php5 als fastcgi einstellen.

Grüße
Tycho
 
#4
ich hab jetzt erstmal versucht php5 als fastcgi für einen normalen Vhost zum laufen zu bekommen.

<VirtualHost *:80>
DocumentRoot /var/clients/client0/web1/web
ServerName bla.de
ServerAdmin webmaster@bla.de
ErrorLog /var/clients/client0/web1/log/error.log

ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html

ServerAlias www.bla.de
# suexec enabled
SuexecUserGroup web1 client0

# php as fast-cgi enabled
<Directory /var/clients/client0/web1/web>
Options Indexes FollowSymLinks MultiViews +ExecCGI
AllowOverride AuthConfig Indexes Limit Options FileInfo
AddHandler fcgid-script .php
FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
Order allow,deny
allow from all
</Directory>
</VirtualHost>
so funktioniert es...

Wenn ich das Ganze über die Ispconfigoberfläche machen lasse, funktioniert es überhaupt nicht :(
 

Till

Administrator
#7
Steht in der MySQL Datenbank in der Tabelle web_domain im Feld php wirklich fast-cgi drin? Außerdem musst Du mod-php in Deiner Apache Konfiguration deaktivieren, mit a2dismod, so dass es nicht mehr geladen ist.
 
#8
ja. steht so in der datenbank drinne.
auch unter /etc/apache2/sites-available

wenn ich mod-php deaktiviere krieg ich die phptestseite zum download.
eine fehlermeldung in den logs gibt es nicht

das ispconfiginterface will dann auch nicht mehr
 
Zuletzt bearbeitet:

Till

Administrator
#9
Du kannst mal Folgendes probieren. Editiere mal die Datei:

/usr/local/ispconfig/server/conf/vhost.conf.master

Dort findest Du eine Sektion für php-fcgi. Wenn Du die durch Deine Version austauschst, müsste es eigentlich gehen, wenn Du ein neues Web anlegst oder das bestehende bearbeitest. Ich habe das mal in den Bugtracker mit aufgenommen, wäre aber nett wenn Du es bei Dir noch mal ausprobieren könntest.
 
#10
ah danke für den hinweis: ansonsten hack ich meine einstellungen rein, aber ich vermute ja dass du mit deiner config was gedacht hast ;)

funktioniert den fastcgi / cgi / suphp bei dir mit ner frischen installation?

und äh... das ispconfiginterface geht leider nicht ohne mod_php aktiviert?!
 
Zuletzt bearbeitet:

Till

Administrator
#12
Die SuPHP Implementierung ist nicht von mir sondern einem anderen Entwickler. Soweit ich weiß, hatte er mod_php garnicht installiert und soweit ich mich erinnere schreibt der Installer etwas anderen Code für das ISPConfig Interface, wenn fastcgi zum Einsatz kommt. Dü müsstest nach der Deaktivierung von mod_php also möglicherweise nochmal ein update rüber laufen lassen und auswählen, dass die Dienste neu konfiguriert werden sollen.

Ich habe bei mir hier auf dem Testsystem im Moment kein fcgi, daher kann ich Dir nicht sagen, ob nicht doch irgend was in der aktuellen Beta bei fcgi nicht geht.

Wenn aber Dein Ansatz auch bei vorhandenem mod_php geht, dann würde ich das aktuele Config Schema ggf anpassen, da es die Konfiguration flexibler macht.
 
#15
mit folgender config funktioniert das ispconfig interface auch mit fastcgi:

ich hab einen symlink von /usr/local/ispconfig/interface/web auf /var/www/ispconfig gemacht und außerdem den fastcgi starter nach /var/www/php-fcgi-scripts verschoben.

<VirtualHost _default_:8080>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/ispconfig

SuexecUserGroup ispconfig ispconfig

<Directory /var/www/ispconfig>
AddHandler fcgid-script .php
FCGIWrapper /var/www/php-fcgi-scripts/ispconfig .php
Options FollowSymLinks +ExecCGI -MultiViews -Indexes
AllowOverride None
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log
CustomLog /var/log/apache2/access.log combined
ServerSignature Off

</VirtualHost>
problematisch ist, dass suexec den document root umbedingt unter /var/www finden möchte.

Das ist auch ein problem von den angelegten virtuellen hosts.
diese werden nämlich mit beispielsweise mit: DocumentRoot /var/clients/client0/web6/web

angelegt.

Warum eigentlich? ein symlink auf /var/www ist ja vorhanden?!
 

Till

Administrator
#16
Das Problem ist, dass die Webs unterhalb von /var/clients/client0 liegen müssen, damit ein Kunde mit einem Shell User der sein Chroot auf /var/clients/client0 gesetzt hat dort auf alle seine Webs zugreifen kann. Wenn ich das andersrum mache, also den Symlink von /var/clients/client0/ auf /var/www setze, geht das nicht.
 
#19
mh, zumindest hatte ich noch keine probleme mit den ganzen symlinks. ich hab das so schon länger auf mehrern servern am laufen

suexec meckert allerdings noch mit dem ordner, wo der starter drin liegt, rum...
da hat es sich als beste Lösung ergeben:
/var/www/starter/username/
zu verwenden. Der Ordner mit dem Usernamen kriegt dann alle Userrechte...

Möchte suPHP den webroot nicht unter /var/www haben?

suexec müsste man selbst neu compilieren, damit das keine probleme macht.
 
Zuletzt bearbeitet:

Werbung

Top