ISP3 Multiserver mit XEN

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von vpns2000, 14. Nov. 2009.

  1. vpns2000

    vpns2000 Member

    Hallo,
    ich habe auf meinem Server mit Debian Lenny Xen 3 Debian hosts installiert.
    nun habe ich auf dem xen1.xxx.com ISP3 im Standard mode installiert und funktioniert auch wunderbar.
    Danach habe ich versucht den host xen2.xxx.com mit ISP3 im expert mode zu installieren. Leider scheitere ich immer wieder an der anbindung an die datenbank auf dem server xen1.xxx.com.

    wenn ich versuche die DB via telnet
    Code:
    telnet xen1.xxx.com 3306
    
    extern zu erreichen bekomme ich die fehlermeldung:
    Code:
    telnet xen1.xxx.com 3306
    Trying xxx.xxx.xxx.xxx...
    Connected to xen1.xxx.com.
    Escape character is '^]'.
    ^Host 'ADSLBussineshostxxxxxxx' is not allowed to connect to this MySQL serverConnection closed by foreign host.
    
    hat jemand eine idee worann es liegen kann!!!

    Danke
     
  2. Till

    Till Administrator

    Check bitte mal auf dem master server, ob mysql auf allen externen IP's alsucht und ob es nicht in der my.cnf auf ip 127.0.0.1 gebunden ist. Dann füge auf dem master zwei weitere mysql root User hinzu, einen für den hostnamen des slaves und einen für die IP des slaves, damit Du Dich von dort aus auch verbinden kannst.
     
  3. vpns2000

    vpns2000 Member

    Hallo Till,
    danke für deine Antwort.
    ich habe via phpMyAdmin einen user angelegt und es funkt jetzt.
    muss ich dann auch das ganze setup mit ja bestätigen oder nur die Dienste die der server ausführen soll?
    LG
     
  4. Till

    Till Administrator

    Nur die Dienste, die der Server ausführen soll und Die Du auf dem Server installiert hast.
     
  5. vpns2000

    vpns2000 Member

    Hallo Till,
    Danke für die antwort.
    nach dem ich auf allen dreien servern nach dem howto forgegengen bin bis auf quota (die kann ich nicht installieren oder nicht in die fstab eintrage) könnten alle die selben dienste ausführen.
    Ich habe aber gesehen das man unter der konfig vom master host die dienste wegklicken kann. hat das dann einen einfluss darauf?

    Ich verstehe zwar da system dahinter noch nicht aber ich werde es schon mal hinbekommen.
    Danke
     
  6. Till

    Till Administrator

    Das hat nur Einfluß auf das Interface, da zu dem Zeitpunkt die Dienste ja bereits auf dem slave konfiguriert sind.
     
  7. vpns2000

    vpns2000 Member

    Hallo
    also das heist jetzt im klartext, das ich mir vorher gedanken machen sollte welche dienste welcher host ausführen soll. Wenn ich das habe dann muss ich aber auch beim expertmode von ISP3 auch nur diese Dienste konfigurieren lassen.
    Ist das soweit auch richtig?

    LG
     
  8. Till

    Till Administrator

    Du solltest natürlich nur die benötigten Dienste auf einem Server installieren, schont ressourcen und verkleinert die Angriffsfläche für Hacker.
     
  9. vpns2000

    vpns2000 Member

    hallo,
    habe jetzt auf dem ISP3 host einen Reseller, Kunden und Domain angelegt.
    Beim DNS habe ich meinen 2ten DNS angegeben auf dem ebenfalls ISP3 installiert ist.
    Nun habe ich mich via ISP3 Web auf den DNS verbunden um dor nachzusehen ob auch da die DNS einträge gemacht wurden.
    Leider sehe ich da nur die Domain aber keine Records dazu.
    Ist das normal oder mache ich da einen Fehler???

    LG
     
  10. Till

    Till Administrator

    Wo hast Du was wie genau nachgesehen? Mit phpmyadmin? Auf slaveservern darf ja garkein ISPConfig Interface installiert sein, sonst schlägt duie Replikation fehl.
     
  11. vpns2000

    vpns2000 Member

    Hallo Till.
    also ich habe auf dem 1 Server Debian und ISP3 nach dem Howto Installiert.
    Danah habe ich 2 Wetere XenServer aufgesetzt und diese ebenfalls nach dem Debian Howto Installiert. Alle drei Server bieten die selben services an und haben alle das selbe ISP3 inkl. Interface drauf.
    Wenn ich jetzt auf server 1 einen Reseller, Kunden und Domain anlege funktioniert das solange alles auf einem Server läuft.

    Sobald ich aber sage das die Domain xxx.com auf dem server 2 der DNS Dienst und auf dem Server 3 Poastfix und co ist dann funkt nichts mehr.

    Hoffe das ich mich jetzt verständlicher ausgedrückt habe.
    LG
     
  12. Burge

    Burge Member

    Leider alles falsch.

    Dein erster Server war richtig.
    Alle anderen musst du im expert modus installieren und auch nur mit den diensten die sie machen sollen. Dahingehend musst auch nur das aus dem install tutorial verwenden was du brauchst.
     
  13. vpns2000

    vpns2000 Member

    Hallo,
    also das heist wenn ich einen DNS Server haben möchte brauche ich nur MyDNS installieren und MYSQL.
    Danach das ISP3 Installieren und bei dem Expertmode DNS auswählen und mit dem Server 1 Verbinden lasse.
    das selbe gillt dann auch für Server 3 der dann Emailserver sein soll.
    Auch da mache ich es soweit das ich nur Postfix und Co installiere und da auch wieder nur mit dem Server 1 Verbinden lassen.

    Bei den Servern 2 u. 3 soll aber kein Frontend installiert werden.
    Wie weis ich aber dann das die Daten übertragen wurden oder nicht??

    LG
     
  14. Till

    Till Administrator

    das siehst Du im Monitor des masters in der jobqueue. Alles was übertragen wurde verschwindet aus der queue.
     
  15. vpns2000

    vpns2000 Member

    hallo Till,
    kannst du mir noch sogen warum icch kein Interface Installieren darf.
    Das wäre doch einfacher wenn man nachsehen will ob alles okay ist auf dem DNS oder Mailserver??

    Gut, also werde ich alle drei server einfach löschen und von vorne beginnen.
    LG
     
    Zuletzt bearbeitet: 29. Nov. 2009
  16. Till

    Till Administrator

    Wenn Du ein Interface installierst und Dich dann dort einloggst, dann reicht das schon aus dass Änderungen in die slave DB geschrieben werden. Diese kollidieren dann bei der Replikation mit den Daten der master DB und das System hält an da es keine Daten mehr replizieren kann.

    Du brauchst auch nicht die Server löschen sondern einfach ispconfig auf den slaves mit dem uninstall.php script löschen und dann neu installieren. Auf dem master baruchst Du nichts weiter machen als die Sachen die Du auf den salves angelegt hast zu löschen.
     

Diese Seite empfehlen