ISP3 Sync Problem zwischen Master/Slave Server

Dieses Thema im Forum "Allgemein" wurde erstellt von hunter999, 23. Juni 2011.

  1. hunter999

    hunter999 New Member

    Hallo an alle.
    Nachdem mein ISPConfig 3 Server nun knapp ein Jahr lang lief ohne zu murksen musste ja wieder mal ein Problem kommen.

    Folgendes sagt mir aktuell mein System Protokoll im ISP3

    Code:
    Replication failed. Error: (client) in mysql server: (localhost) Table  'dbispconfig.client' doesn't exist # SQL: REPLACE INTO client 
    Ich habe einen Master und einen Slave Server.
    Ich habe schon auf dem Slave Server in die dbispconfig reingeschaut und sehe dort aber keine Tabelle client da gehts nur mit client_template los.

    Meine Frage, reicht es wenn ich vom Master Server die Tabelle in die DB auf dem Slave Server kopiere?

    Die Zugriffe funktionieren eigentlich habe ich gerade mit

    Code:
    mysql -h master.domain.tld -u root -p
    und auf dem Master Server mit:

    Code:
    mysql -h slave.domain.tld -u root -p
    getestet.

    Hat jemand nie Idee wo da der Fehler liegt, oder wie ich die sachen aus der Queue bekomme?
     
  2. Till

    Till Administrator

    Ja, das sollte ausreichen.
     
  3. hunter999

    hunter999 New Member

    Hallo Till,

    danke das hat geholfen.

    Sollte ich da wieder mal ein ISP Update machen, oder es lieber sein lassen?
     
  4. Till

    Till Administrator

    Ich würde Dir zu regelmäßigen Updates raten. Du musst aber das Update immer auf allen Servern die zum Cluster gehören durchführen, und vor einem Update würde ich immer ein Backup empfehlen. Hatte zwar bisher nie Probleme damit, aber man weiß ja nie :)
     
  5. hunter999

    hunter999 New Member

    Leider scheint es ein neues Problem zu geben. Seit heute Nacht kommen die folgenden Meldungen im Logfile:

     
  6. hunter999

    hunter999 New Member

    Uups ich sehe gerade das es den SQL Server abgeschossen hat.
    Die Socket und PID Datei unter /var/run/mysql gibts nicht mehr.
    Wie kann das passieren???
     
  7. Till

    Till Administrator

    Das kann viele Ursachen haben inkl. Mainboard Probleme oder wackeliger RAM. Schau mal ins syslog und die mysql logs.
     

Diese Seite empfehlen