ISPC 3.1 API

Dieses Thema im Forum "Entwicklerforum" wurde erstellt von geheimmen, 11. Nov. 2014.

  1. geheimmen

    geheimmen New Member

    Heyho,

    wird sich die API in ISPC 3.1 ändern ?
    Grund hierfür ist, dass ich vorhabe ein größeres Projekt über die ISPC API umzusetzen.

    Wenn sich die API hier in 3.1 "radikal" ändert, würde es meiner Meinung nach Sinn machen hier noch zu warten oder ?
     
  2. Till

    Till Administrator

    Die API bleibt die selbe. Es steht in 3.1 zusätzlich zum SOAP Connector noch ein JSON basiertes api zur Verfügung, die unterscheiden sich aber nicht im Funktionsumfang.
     
    geheimmen gefällt das.
  3. geheimmen

    geheimmen New Member

    Okay JSON hört sicht schon einmal nicht verkehrt an :)
    Kann man c.a abschätzen, wann die 3.1 released wird, oder dauert das ganze noch ein weilchen ?
     
  4. Till

    Till Administrator

    Ein Release Datum kann ich Dir noch nicht nennen. Aber es wird nicht mehr so lange dauern, es hängt hauptsächlich noch an der Umstellung der UI auf Bootstrap, ist ne Menge Arbeit alle html template Dateien zu ändern, auch wenn wir so viel wie möglich automatisiert haben.
     
  5. geheimmen

    geheimmen New Member

    Okay verstehe, kann man euch mit dem Bootstrap Template unter die Arme greifen ?
     
  6. Till

    Till Administrator

    Im Moment nicht wo wir noch an der automatischen Konvertierung arbeiten. Wenn die aber durch ist kannst Du gerne mithelfen die Bugs in den neuen Templates, die sich sicherlich eingeschlichen haben werden, zu finden und zu beheben. Ich denke wir werden die alten templates mit prefix in den dateinamen nch etwas im source baum belassen, dass man die Änderungen schneller abgleichen kann, wenn was nicht geht.
     
  7. geheimmen

    geheimmen New Member

    Okay, dann werde ich mich wohl noch etwas gedulden :)
     
  8. djchrisnet

    djchrisnet New Member

    Hey, gibt es hierzu inzwischen etwas neues? Ich liebe bootstrap und kann es daher kaum erwarten *fg
     
  9. ZooL

    ZooL Member

    ich habe den masterbranch installiert und der sieht noch nach Arbeit aus.
     
  10. ZooL

    ZooL Member

    Hi, bei der API 3.1dev Bekomme ich beim simplen log schon einen error.
    SOAP Error: Error Fetching http headers
    Edit: durch das Deaktivieren von SSL
    bekam ich zugang und mich erreichte folgende Error Nachricht.
    Logged successfull. Session ID:a8f8b22c4448ddae20a5d546bb1882f5
    session_does_not_exist
    The Session is expired or does not exist.
    SOAP Error: The Session is expired or does not exist.

    greetz
     
    Zuletzt bearbeitet: 29. Mai 2015
  11. Till

    Till Administrator

    das hat ja nix mit ispconfig zu tun sodern damit dass php keine selbstsignierten zertifikate mehr akzeptiert, Du musst das un soap aufruf angeben dass Du auch eigene ssl zertifikate erlauben willst.

    das kann durcahus sein, die api wurde im 3.1 branch auch noch nicht getestet.
     
  12. shadowcast

    shadowcast Member

    sites_web_domain_addMorgen,

    ich hab gestern einen Server auf ISPConfig 3.1 aktualisiert und nun Probleme mit dem Erstellen von Websites über die API.
    Der Fehler lautet:
    Code:
    https_port_error_regex
    Das vorhandene Script (hatte vorgestern mit ISPConfig 3.0 noch geklappt) führt die Funktion "client_add" sauber aus, liefert dann jedoch bei "sites_web_domain_add" genannten Fehler.

    Meine Parameter sind:
    Code:
    $params_webdomain = array(
                        'server_id'                    => 1,
                        'ip_address'                => '*',
                        'domain'                    => $url,
                        'type'                        => 'vhost',
                        'vhost_type'                => 'name',
                        'stats_type'                => '',
                        'backup_interval'            => 'daily',
                        'backup_copies'                => '3',
                        'seo_redirect'                => '',
                        'ssl_state'                    => '',
                        'ssl_locality'                => '',
                        'ssl_organisation'            => '',
                        'ssl_organisation_unit'        => '',
                        'ssl_country'                => 'DE',
                        'ssl_domain'                => $url,
                        'ssl_key'                    => '-----BEGIN RSA PRIVATE KEY-----
    -----END RSA PRIVATE KEY-----',
                        'ssl_request'                => '',
                        'ssl_cert'                    => '-----BEGIN CERTIFICATE-----
    -----END CERTIFICATE-----',
                        'ssl_bundle'                => '-----BEGIN CERTIFICATE-----
    -----END CERTIFICATE-----
    -----BEGIN CERTIFICATE-----
    -----END CERTIFICATE-----',
                        'ssl_action'                => 'save',
                        'stats_password'            => '',
                        'apache_directives'            => 'RewriteEngine on
    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R]',
                        'nginx_directives'            => '',
                        'pm'                        => 'dynamic',
                        'pm_max_children'            => '50',
                        'pm_start_servers'            => '20',
                        'pm_min_spare_servers'        => '5',
                        'pm_max_spare_servers'        => '35',
                        'pm_process_idle_timeout'    => '10',
                        'pm_max_requests'            => '0',
                        'custom_php_ini'            => '',
                        'hd_quota'                    => '1000',
                        'traffic_quota'                => '-1',
                        'cgi'                        => '',
                        'ssi'                        => '',
                        'suexec'                    => 'y',
                        'errordocs'                    => '1',
                        'subdomain'                    => 'none',
                        'php'                        => 'fast-cgi',
                        'fastcgi_php_version'        => 'PHP (FCGI) 7.0:/opt/phpfcgi-7.0/bin/php-cgi:/opt/phpfcgi.ini-7.0',
                        'ruby'                        => '',
                        'python'                    => '',
                        'ssl'                        => 'y',
                        'allow_override'            => 'all',
                        'added_by'                    => 'installer',
                        'active'                    => 'y'
                    );
     
  13. shadowcast

    shadowcast Member

    Hab den Fehler, es fehlten wohl 2 neue Felder:
    Code:
    'http_port'                    => '80',
    'https_port'                => '443',
    
     

Diese Seite empfehlen