ISPc3 mit .htaccess sichern

#1
Mahlzeit.

Ich betreibe einen Debian 5 VServer bei Hosteurope.
Darauf läuft ISPConfig 3.

SOweit läuft auch alles rund, und prima.
Da ich jedoch etwas an Verfolgungswahn leide, möchte ich das Controlpanel www.domain.de:8080 mittels .htaccess sichern.

Wenn ich jedoch im Verzeichnis /var/www/ispconfig, bzw. /usr/local/ispconfig/interface/web/ die Dateien .htaccess und .htpasswd anlege, wird trotzdem beim Zugriff auf ISPc3 kein Login abgefragt.

Was mache ich falsch?



liebe Grüße
 

Till

Administrator
#2
Aus Sichereitsgründen erlaubt ispconfig kein Überschreiben von apache Einstellungen mittels .htaccess in seinem Programmverzeichnis.

Wenn Du Änderungen an der ISPConfig vhost Konfiguration vornehmen möchtest, dann musst Du es direkt in der vhsot datei machen.
 
#3
Super, danke für den Hinweis, hat super geklappt.


Hier nochmal für alle dies genauer wissen möchten:

Um das ISPC per "htaccess" zu sichern geht man wie folgt vor:
(betrifft Debian 5 mit Apache2 auf vServer)

  • Per SSH einloggen
  • navigieren in den Pfad /etc/apache2/sites-available
  • nano ispconfig.vhost
  • </VirtualHost> suchen und darüber folgendes einfügen:
<Directory /usr/local/ispconfig/interface/web/>
AuthName "Login to the Private Area"
AuthType Basic
AuthUserFile /var/www/ispconfig/.htpasswd
Require user DEINNAME
</Directory>
  • Datei speichern und schließen
  • navigieren zu Pfad /var/www/ispconfig
  • htpasswd -c .htpasswd DEINNAME
  • 2 mal das Wunschpasswort eingeben
  • Apache neu starten per /etc/init.d/apache2 restart


Viel Spaß. :D
 
Zuletzt bearbeitet:
#6
@SyntaX: Stimmt der Pfad zur .htpasswd mit dem in der vhost.conf eingetragenen überein? Die Berechtigungen an der .htpasswd sollten passen, wenn du es wie von @Frederik beschrieben gemacht hast.

Ansonsten wie @Till schon gepostet hat mal in die Logs schauen oder die Schritte nochmals durch gehen und nichts übersehen. Auf redirect301.de findest du noch ein paar weitere Infos zum Passwortschutz, vielleicht liegt dir das ja eher.
 
#8
Das Thema ist schon etwas älter, aber dennoch interessant nur das bei dem Versuch das einzubauen bei mir garnichts passiert, ich habe alles geprüft nur erscheint keine htaccess.

Hat sich da an der vorgehensweise etwas verändert?
 

Werbung