ISPCinfig 3.0.3.3 fail2ban Fehler

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von nowayback, 26. Sep. 2011.

  1. nowayback

    nowayback Well-Known Member

    ISPConfig 3.0.3.3 fail2ban Fehler

    Moinsen,

    nach dem Serverrestart erhalte ich folgende Fehlermeldung im Fail2Ban Log:
    Wenn ich diese Regeln von Hand einfüge, scheint's zu gehen aber das müsste man dann ja nach jedem Serverrestart machen. Irgendwelche Ideen zur Lösung?

    Grüße
    nwb



    ANHANG:

    System: Debian 6
    Kernel: 2.6.32-5-amd64

    jail.local:
    filter.d/pure-ftpd.conf
    filter.d/dovecot-pop3imap.conf
     
    Zuletzt bearbeitet: 26. Sep. 2011
  2. Till

    Till Administrator

    Das Problem kann daran liegen dass fail2ban die Befehle zu schnell hintereinander ausführt, zumindest war das bei den Servern so, bei denen ich das problem bisher hatte. Die einfachste Lösung ist es das Banning per Route Befehl anstatt iptables zu machen. Ansonsten müsstest Du unter umständen fail2ban code ändern, so dass er nach jedem iptables befehl etwas wartet.

    Configure fail2ban to use route instead of iptables to block connections « FAQforge

    Siehe auch Debian bugreport hier:

    #554162 - fail2ban: sometimes(frequently) fails to load iptable rules with multiple jails - Debian Bug report logs
     
  3. nowayback

    nowayback Well-Known Member

    Moinsen Till,

    danke für die Info... das muss ich wohl irgendwie übersehen haben.

    In der aktuellen "Unstable" Version von fail2ban (0.8.5-2) Debian -- Details of package fail2ban in sid soll das Problem behoben sein.

    Danke und Grüße
    nwb
     

Diese Seite empfehlen