ISPConfig 2 - 2.2.40 zerschossen

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Feanwulf, 29. Dez. 2012.

  1. Feanwulf

    Feanwulf Member

    Hallo,

    ich habe heute noch mal die ISP Installation 2.2.40 über meine vorhandene rüberlaufen lassen, aber er bricht immer mit folgendem fehler ab:

    Code:
    Configuring for Apache, Version 1.3.41
     + Warning: Your 'echo' command is slightly broken.
     + It interprets escape sequences per default. We already
     + tried 'echo -E' but had no real success. If errors occur
     + please set the SEO variable in 'configure' manually to
     + the required 'echo' options, i.e. those which force your
     + 'echo' to not interpret escape sequences per default.
     + using installation path layout: Apache (config.layout)
    Creating Makefile
    Creating Configuration.apaci in src
    Syntax error --- The configuration file is used only to
    define the list of included modules or to set Makefile in src
    options or Configure rules, and I don't see that at all:
    /root/ispconfig/openssl
    [....]
    ./configure:Error: APACI failed
    ERROR: Could not configure Apache
    
    Ich weiss leider nicht wieter - meine Webs laufen nachdem ich im root verzeichnis dann das alte ispconfig verzeichnis zurückgespielt habe - ABER ich habe halt kein webinterface mehr ;)

    Habe an meinem System anscheinend irgendwas zerhauen und sehe nun alt aus - leider fehlt mir die Zeit endlich einen neuen Root Server mit ISPConfig3 aufzusetzen :(
     
  2. Till

    Till Administrator

    Hast Du die libc editiert wie im perfects etup für ispconfig 2 beschrieben bevor Du den ispconfig installer ausgeführt hast? Ohne die libc Änderung lässt sich apache 1.3 auf aktuellen Distributionen nicht mehr kompilieren.
     
  3. Feanwulf

    Feanwulf Member

    meinst du diesen Schritt:

    20 ISPConfig

    The configuration of the server is now finished, and if you wish you can now install ISPConfig on it. Please check out the ISPConfig installation manual: http://www.ispconfig.org/manual_installation.htm
    Before you install ISPConfig, there's one important thing you must do. Open /usr/include/stdio.h and replace getline with parseline in line 651:
    vi /usr/include/stdio.h


    den hatte ich bis gerade nicht gemacht - bin gerade noch mal am Update starten!


    -> Ergebnis: Leider kein besseres - ich lese mir die Anleitung noch mal durch fürs Perfect Setup!

    Nächster Versuch - ich glaube bei mir war "dash" aktiviert entgegen der Anleitung muss es ja BASH sein - mal sehen ob es das dann bringt!
     
    Zuletzt bearbeitet: 29. Dez. 2012
  4. Till

    Till Administrator

    Ja, genau den.
     
  5. Feanwulf

    Feanwulf Member

    ALSO:

    1. Fehler von mir -> DASH aktiviert anstatt BASH
    2. Fehler von mir -> Vorbereitung laut Anleitung Punkt 20 nicht erfüllt

    Fazit -> Läuft wieder

    Meine Datenbank war weg, aber hab ein backup eingespielt und nun scheint auch alles wieder zu funktionieren ;)
     

Diese Seite empfehlen