ISPConfig 2.2.37 / CentOS 5.5 / Postfix etc..

Dieses Thema im Forum "Allgemein" wurde erstellt von Wurstbrot, 18. Okt. 2010.

  1. Wurstbrot

    Wurstbrot New Member

    Moin die Gemeinde,

    Folgendes Szenario System nach dem Perfect Server HowTo aufgebaut soweit eig. auch alles Tiptop.

    So jetzt habe ich gerade mal einen Test-Kunden erstellt funktioniert soweit auch alles bis auf die Emails...

    Emails von dem Konto welches ich erstellt habe kann ich Problemlos versenden - das was nicht funktioniert ist der Empfang...

    Egal ob von GMX Gmail etc. immer wieder folgende Meldung:


    Delivery to the following recipient failed permanently:

    benutzer@domain.com

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 5.7.1 <benutzer@domain.com>: Relay access denied (state 14).

    Keine Ahnung an was das liegen könnte... Einträge in der virtusertable etc. sind vorhanden die local-host-names stimmen soweit auch :/

    Log gibt mir folgende Meldung welche mir aber eigentlich auch ned weiterhilft...

    Code:
    Oct 18 19:18:15 XXX postfix/smtpd[30136]: connect from mail-bw0-f48.google.com[209.85.214.48]
    Oct 18 19:18:15 XXX postfix/smtpd[30136]: NOQUEUE: reject: RCPT from mail-bw0-f48.google.com[209.85.214.48]: 554 5.7.1 <XXX@XXX>: Relay access denied; from=<XXX@gmail.com> to=<XXX@XXX> proto=ESMTP helo=<mail-bw0-f48.google.com>
    Oct 18 19:18:15 XXX postfix/smtpd[30136]: disconnect from mail-bw0-f48.google.com[209.85.214.48]
    
    Wäre genial wenn mir da iwer weiterhelfen könnte - gerne poste ich falls gebraucht auf main.cf etc. pp

    Grüsse
     
    Zuletzt bearbeitet: 18. Okt. 2010
  2. Till

    Till Administrator

    Poste bitte mail den Inhalt der main.cf.

    domain.com ist hoffentlich nicht identisch mit dem myhostname oder mydomain in der main.cf bzw. dem Hostnamen des Servers? Das mag postfix nämlich nicht und stellt dann keine Emails zu.
     
  3. Wurstbrot

    Wurstbrot New Member

    Also hier mal der Teil aus der main.cf - die ganze ist anscheinend ja zu gross - und das ist ja eig. der wichtigste Teil?

    Code:
    # INTERNET HOST AND DOMAIN NAMES
    #
    # The myhostname parameter specifies the internet hostname of this
    # mail system. The default is to use the fully-qualified domain name
    # from gethostname(). $myhostname is used as a default value for many
    # other configuration parameters.
    #
    #myhostname = host.domain.tld
    #myhostname = virtual.domain.tld
    
    # The mydomain parameter specifies the local internet domain name.
    # The default is to use $myhostname minus the first component.
    # $mydomain is used as a default value for many other configuration
    # parameters.
    #
    #mydomain = domain.tld
    
    
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    smtpd_sasl_local_domain = localdomain
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    myhostname = namedesservers
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    
    Dann hier der Auszug aus der local-host-names

    Code:
    
    ###################################
    #
    # ISPConfig local-host-names Configuration File
    #         Version 1.0
    #
    ###################################
    localhost
    namedesservers
    localhost.namedesservers
    localhost.localdomain
    www.domain1.ch
    www.domain2.ch
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    
    
     
    Zuletzt bearbeitet: 18. Okt. 2010
  4. Till

    Till Administrator

    Ich vermute mal Du hast vergessen eine co-domain für domain1.ch und domain2.ch mit leerem Hostnamen Feld in ISPConfig anzuelegen, daher existieren Deine Emailadressen zur Zeit nur als user@www.domain1.ch und nict user@domain1.ch.
     
  5. Wurstbrot

    Wurstbrot New Member

    Morgähn,

    Du bist ja schon früh unterwegs hier ;) - Dein Tipp war genial der Fehler ist jetzt somit mal behoben - die Sache läuft aber trotzdem noch nicht ganz so rund. Jetzt kriege wenn ich versuche eine Mail an benutzer@domain1.ch zu senden die folgenden Logs:

    Code:
    
    Oct 19 13:40:55 servername postfix/cleanup[16862]: 1A0503E3003B: message-id=<BCFA5C20-0365-4D36-889D-3AE999FC8310@gmail.com>
    Oct 19 13:40:55 servername postfix/qmgr[15103]: 1A0503E3003B: from=<benutzer@gmail.com>, size=2249, nrcpt=1 (queue active)
    Oct 19 13:40:55 servername postfix/smtp[16863]: 1A0503E3003B: to=<web5_mail_benutzername@servername.localdomain>, orig_to=<benutzer@domain1.ch>, relay=none, delay=0.1, delays=0.09/0/0/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=servername.localdomain type=MX: Host not found, try again)
    
    
    
    (Host or domain name not found. Name service error for name=servername.localdomain type=MX: Host not found, try again)

    Jetzt versucht er trotzdem mit dem server-namen aufzulösen?
     
  6. Till

    Till Administrator

    Füge:

    servername.localdomain

    am Ende der Datei /etc/postfix/local-host-names hinzu und starte postfix neu.
     

Diese Seite empfehlen