[ISPConfig 2] Upgrade von Lenny auf Squeeze reibungslos?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Lonesome Walker, 9. Feb. 2011.

  1. Lonesome Walker

    Lonesome Walker New Member

    Das Upgrade von Etch auf Lenny war ja nicht soooo reibungslos, weil ein paar Sachen (wie z.B. saslauth) eben anders gebaut waren.

    Gibt es schon jemanden, der eine Testumgebung verhunzt hat, und berichten kann, wo es geklemmt hat?
    Ich würde nur ungern den Server neu installieren und ein Backup einspielen ;)


    Danke
     
  2. sirrus

    sirrus New Member

  3. Till

    Till Administrator

    Lonesome Walker spricht aber von ispconfig 2, das ist eine ganz andere Software als ISPConfig 3.
     
  4. sirrus

    sirrus New Member

    Das ist schon klar - trotzdem kann ein Update der Datenbank durch anderes Verhalten auch Probleme auslösen.

    In dem von mir beschriebenem Fall ist es die Interpretation von NULL oder Leerstrings zwischen MySQL 5.0 (lenny) und MySQL 5.1 (Squeeze)

    Ich dachte auch zuerst an ein saslauth Problem - aber es lag an der DB.

    Grüße,
    Andreas
     
  5. sirrus

    sirrus New Member

    PhpMyAdmin

    PhpMyadmin kann auch ärger machen - bei mir zeigte es nur noch eine leere HTML Seite.

    Lösung:

    Code:
    apt-get --purge remove phpmyadmin
    apt-get install phpmyadmin
     
  6. Lonesome Walker

    Lonesome Walker New Member

    Naja, ich bleib bei meinem ISPConfig 2.
    Das ist, wie wir Debianer immer so schön flachsen, mature.

    Dafür hab ich mir schon so viele Mods gebastelt, an so vielen Settings rumgeschraubt, und außerdem finde ich es 10x flexibler als das verspielte 3er.
    (sorry Till, aber ich bin eher der Fan von straight und funktioniert 10 Jahre; daher auch Debian :D ich hab sogar noch ein paar alte Sarge-Server am Laufen... Kunde will nicht upgraden :eek: )

    Anyway, ich setz gerade nen frischen Lenny auf, ISPConfig2 default drauf, und dann ein dist-upgrade, mal sehen, was es zerbröselt :)
     
  7. undeluxe

    undeluxe New Member

    Soo möchte mich auch mal zu Wort melden...

    Es gibt, jedenfalls bei mir einige kleinere Probleme.
    Habe den Server mit Debian 6 neu aufgesetzt gehabt..

    Zum Beispiel.

    Fail2ban lässt sich nicht restarten, dabei war ich nach dem Englischen Howto (Link wurde hier gepostet) gegangen. Es werden auch keine Log Einträge getätigt, Warum das so ist kann ich nicht sagen.

    Dann tauchen solch Meldung im ispconfig log auf:

    Denke mal das da was in einer php.ini nicht stimmt.

    Dann die alte Geschichte mit amavis da gibt es die Meldung das es ein Update bedarf .. Die Lösung für Lenny brachte keine Hilfe..

    So stehe ich jedenfalls mit Fail2ban und Amavis blöde da, wenn ich das mal so sagen darf !
     
  8. Till

    Till Administrator

    Richtig, der Error Level mit PHP Notices sollte immer deaktiviert sein auf Produktivsystemen.

    Was meinst Du denn mit alter Geschichte bzgl amavis? Bei meinen Servern läuft der überall einwandfrei, und zwar unter Debian 5 wie Debian 6.
     
  9. undeluxe

    undeluxe New Member

  10. Till

    Till Administrator

  11. undeluxe

    undeluxe New Member

    Das hatte ich bereits gelesen !
    Kann man dies nicht irgendwie im ISPConfig ändern, damit er mir nicht sagt das es veraltet ist ?

    Ist dir was mit Fail2ban bekannt (Probleme etc )?
     
  12. Till

    Till Administrator

    Die Meldung ist von Clamav und nicht von ISPConfig. Da müsste man also die ClamAV Entwickler bitten sie zu ändern. Ich finde die Meldung auch absolut irreführend, es müsste heißen "Es ist eine neue Software Version verfügbar. Für die aktuell installierte Version stehen weiterhin neue Virensignaturen zur Verfügung und die installierten Virensignaturen sind aktuell." oder so und nicht outdated und dann noch alles in Großbuchstaben.

    Nein, bisher nicht.
     
  13. blue-matrix

    blue-matrix New Member

    Hier habe ich in Zeile 95 ein @ hinzugefügt:
    PHP:
    @list($key$value) = preg_split('/[\t= ]+/'$line2);
    Bei der Gelegenheit bekam Zeile 107 eine Ergänzung, sie lautet nun:
    PHP:
    if(!empty($append) AND $append == 1$out .= $varName.' '.$varValue."\n";
    Damit sind meine beiden Meldungen bei der Chronausführung verschwunden:
    Code:
    PHP Notice: Undefined offset: 1 in /usr/local/ispconfig/server/cron_daily.php on line 95
    PHP Notice:  Undefined variable: append in /usr/local/ispconfig/server/cron_daily.php on line 107
     

Diese Seite empfehlen