ISPConfig 3.0.1.5 released

Dieses Thema im Forum "Allgemein" wurde erstellt von Till, 12. Okt. 2009.

  1. Till

    Till Administrator

    ISPConfig 3.0.1.5 is available for download. This release is a bugfix release for ISPConfig 3.


    Download
    -----------------------------------------------------

    The software can be downloaded here:

    http://downloads.sourceforge.net/ispconfig/ISPConfig-3.0.1.5.tar.gz?use_mirror=


    Changes:
    --------------------------------------


    - Several bugs have been fixed, see bugtracker:

    http://bugtracker.ispconfig.org/index.php?string=&project=3&due[]=33&status[]=closed&do=index


    For a detailed changelog, please have a look at the SVN history with an SVN client of your choice:

    svn://svn.ispconfig.org/ispconfig3/trunk/


    Known Issues:
    --------------------------------------

    Please take a look at the bugtracker:

    http://bugtracker.ispconfig.org


    BUG Reporting
    --------------------------------------

    Please report bugs to the ISPConfig bugtracking system:

    http://bugtracker.ispconfig.org


    Supported Linux Distributions
    -----------------------------
    - Debian Etch (4.0) - Lenny (5.0)
    - Ubuntu 7.10 - 9.04
    - OpenSuSE 11 - 11.1
    - CentOS 5.2 - 5.3
    - Fedora 9 - 10


    Installation
    --------------------

    The installation instructions for ISPConfig can be found here:

    http://www.ispconfig.org/documentation.htm

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.


    Update
    --------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update.sh

    And select "stable" as update resource. The script will check if an updated version of ISPConfig 3 is available

    and then download the tar.gz and start the setup script.

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions

    below.


    Manual update instructions
    --------------------------

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
  2. Beme

    Beme New Member

    Hallo Till,

    danke für die neue Version!
    Bekomme leider beim Update der Slaves den Fehler "Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 157" im Updatescript, an der Stelle wo ich das MySQL-RootPW eingeben muss.

    Hast Du dafür schon eine Lösung?

    Gruß,
    Benjamin
     
  3. Till

    Till Administrator

    Das ist ein Bug im Installer der nur bei slaves auftritt, ich arbeite da noch dran. Der Fehler tritt auf bevor der Installer etwas verändert hat, es sollte also alles weiter funktionieren bis ich einen Patch dafür habe.
     
  4. Beme

    Beme New Member

    Danke.

    Das Problem an der Sache ist, dass ich erst den Master geupdatet habe und jetzt anscheinend Probleme beim Replizieren auftreten. Habe ein paar Aliasdomains angelegt und diese werden nicht in den vhost-Dateien des Slaves angelegt. Das ISP-Log meldet aber auch keinen Fehler. Naja, hoffe, dass sich das Problem evtl. gibt wenn die Slaves auch auf 3.0.1.5 sind.

    Werde das nächste Mal auf jeden Fall erst bei den Slaves anfangen ;)

    Eine Quick&Dirty-Lösung gibt es für das Problem nicht?

    Gruß,
    Benjamin
     
  5. Till

    Till Administrator

    Doch, die gibt es. Aber es ist wichtig dass Du auf jeden Fall vorher ein Backup der DB auf den slave machst :)

    Danach geht's wie folgt weiter:

    1) Alle Daten (ohne Tabellendefinitionen) auf dem slave exportieren.
    2) Alle Tabellen auf dem slave löschen.
    3) Den ispconfig Datenbank-Dump der im install/sql/ Verzeichnis ist, in die DB laden.
    4) Alle Tabellen in der DB leeren (nicht löschen :) )
    5) Die Daten die Du in 1) Exportiert hast wieder importieren.

    Dann sollte zumindest Das Replikationsproblem weg sein. Später must Du dann noch auf 3.0.1.5 updaten, aber das hat dann erstmal Zeit.
     
  6. Beme

    Beme New Member

    Danke, klingt machbar.

    Die neuen ISPConfig-Dateien aus dem Archiv muss ich dann aber auch noch händisch an die richtige Stelle entpacken? :confused:
     
  7. Till

    Till Administrator

    Nein, das machst Du später wenn der Updater patch da ist indem Du einfach das update laufen lässt.

    Was Du mit meiner obigen Anleitung machst ist einfach das datenbank-Layout an das der Version 3,0,1,5 anpasen, so dass die Replikation wieder geht. Die Programmdateien der 3.0.1.4 laufen mit dem neuen Datenbanklayout.
     
  8. Beme

    Beme New Member

    Okay, hab alles so gemacht.

    Aber die Aliasdomains werden immer noch nicht in die vhost.conf übernommen...

    Mir fällt auch auf: Die alten bereits in 3.0.1.4 angelegten Aliasdomains stehen nur in der DB vom Master, die neuen angelegten Aliasdomains stehen AUCH in der Tabelle "web_domain" des www-Slaves.

    Gruß,
    Benjamin
     
  9. Till

    Till Administrator

    Auf dem slave wird nur das verarbeitet, was auch in der DB des slaves steht. Wenn die Aliasdomains da nicht drin sind, klick mal auf bearbeiten im inetrface und dann auf speichern und schau mal nach, ob sie repliziert werden.

    Wenn die aliase nicht in der Config stehen, dann ist vermutlich ein noch nicht quittierter Fehler im system log. Schau mal in den monitor ob dort ein fehler im system log steht und geh dann dort auf löschen beim fehler in der Liste, um ihn zu quittieren.
     
  10. Beme

    Beme New Member

    Nachdem ich die Hauptdomain aufgerufen habe und auf Speichern geklickt habe, hat er auch alle Aliasdomains übernommen. Jetzt klappt alles.

    Danke :)
     
  11. paolom007

    paolom007 Member

    update von 3.0.13 auf 3.0.15 möglich

    Hallo Till

    ist das Update von 3.0.13 auf die 15 ohne Zwischenschritt möglich?

    Und auch bei der 2er Version wenn ein schritt übersprungen wird?

    vielen Dank.

    Paolo
     
  12. Till

    Till Administrator

    Du kannst direkt updaten. warte aber am besten nochmal ein bis zwei Tage und aktualisiere dann gleich auf 3.0.1.6, da wir heute oder morgen gleich noch ein Update auf 3.0.1.6 rausbringen.
     
  13. paolom007

    paolom007 Member

    Danke

    vielen Dank
     

Diese Seite empfehlen