ISPconfig 3.0.16 Webmail und Webalizer

#1
Schönen Guten Abend,

ich habe folgendes Problem mir dem Webmail und auch mit dem Webalitzer.
Bei meinem einen Server kann ich webmail und Webalizer überhaubt nicht mehr aufrufen und bei dem anderen, sur webalizer ohnen jede abfrage von User und Password aber auch kein Webmail. der Server ist installiert nach dem perfekt setup mit lenny und ich bin mir sicher das es vor dem update auf 3.0.16 funktionirt hat. möglicherweise habe ich auch nur ein verständnisproblem.

Webmail möchte ich wie folgt aufrufen www.mainserver.de/webmail und den webalizer www.meinserver.de/webalizer kann natürlich auch mit den kletzten updates von Debian zusammen hängen.

hat jemand eine Idee wo ich da ansetzen kann und warum ist der Webalizer frei zugänglich un oder wie sollte das eigetlich gehen.

ich habe derzeit leider keinen ansatz wo ich nachschauen kann. vielen Dank für eure Hilfe.

paolo
 

Till

Administrator
#4
In ISPConfig 3 liegen die Webalizer Statistiken unter domain.de/stats und nicht /webalizer

Zum Thema webmail. Das webmail ist nur über den sog. default vhost des apache erreichbar und nicht über die Domains von einer angelegten webseite.
 
#5
Hallo Till,

Ja irgendwie bin ich da schon am rätzeln. wenn ich servername.mainedomain.de/webalizer eingebe kommt ja was(sollte eigentlich nicht ohne Password sein)
Wenn ich aber das mit www.meinedomain.de/stats versuche, verlangt er ein password. Welchs ist das dann?

Das mit dem Webmail ist mir (habe mich da leider zu ungenau ausgedrückt). Ich meinte schon den Servername.isp_Server_domain.de/Webmail und das geht nicht.

Vielen Dank für eure Geduld
 
#6
Hallo Till das mit den Stats Passwor habe ich drade noch gelesen und ich habe es jetzt gesetzt. offen ist bei den stas noch, warum aber die Stats bei dem normalem aufruf sdes ispservers mit /webalizer dahinter kommen.

und natürlich das Webmailproblem.

Danke.

Paolo
 
#7
Bzgl Webmail . Ich mache das bei einigen Domains so das ich einfach Symlinks ln -s gesetzt hab zum Webmail.
Oder du hinterlegst in http://webseite/webmail ne index mit ner simplen Weiterleitung zum eigentlichen Webmail.
So zB:
Code:
<?php
header('Location: $eigentlicherwebmaillink');
?>
Gruß Sven
 
#8
Hallo Sven, vielen Dank für Deinen Hinweis und das ist auch eine coole Lösung. Dies kann ich aber leider erst verwenden wenn ich erst mal das Webmail erreiche. nicht einmal wenn ich IP-Adresse/Webmail angebe kann ich das Webmail erreichen. Daher bion ich ja so ratlos Danke Paolom007
 
#10
installiert ist der Server nach dem Perfekt setup lenny und isp. Webmail liegt per link in /var/www so sollte es auch sein und leider kann ich es nicht aufrufen, er findet es nicht. Das ist das kleine Problem, welches ich nciht verstehe. Vielen Dank für die Hilfe schon mal im vorraus
 
#13
Apache vhost:
Code:
cat /etc/apache2/sites-enabled/000-default
ISpconfig vhost:
Code:
cat /etc/apache2/sites-enabled/ispconfig.vhost
Vorweg wenn dein Webmail unter /var/www liegt suchen wir im Prinzip nur noch nach den Teil der fehlt damit du es auch nutzen kannst. Erster Teil der Suche. Obige Ausgaben.
 
#14
Ok nu wäre es einfach wenn du deinen code folgendermaßen postest damit es auch leserlich wird.
Code:
 [ code ] ausgabe config1[ /code ]
Code:
[ code ]ausgabe config2[ /code ]
Bei dem Code keine Leerzeichen, das hab ich nur gemacht damit das hier sauber gezeigt wird ;)
Und ne bei der zweiten sollte eigentlich kein 000 davor...aber du kannst uns das erleichtern mit einer Ausgabe von ls -l /etc/apache/sites-enabled

Gruß Sven
 
#15
wow... Paolo...

hier laufen ja einige Freaks rum, aber den Code in eine Zeile hämmern... das ist wirklich sehr unübersichtlich..
Teilweise scheinen mir da auch die Sonder- und Steuerzeichen abhanden gekommenn...

guck mal, ob du das nicht in dieser Form hinbekommst:

Code:
debian:~#   cat /etc/apache2/sites-enabled/000-default
<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
Grüße
Laubie

PS: Das ist mal meine 000-default, muss nicht mit deiner übereinstimmen.
 

Werbung

Top