ISPConfig 3.0.5.4 und Rechnungsmodul REV-10

#1
Das Rechnungsmodul REV-10 ist nicht kompatibel mit ISPConfig 3.0.5.4. In der Datei "interface/web/dashboard/dashboard.php" fehlen die individuellen Dashlets aus der Systemkonfiguration. Bei der Installation oder dem Update des Rechnungsmoduls werden diese Einstellungen daher wieder auf die alten Default-Werte zurückgesetzt.

Workaround:

Nach der Installation/Update des Rechnungsmodul erneut ein Update von ISPConfig durchführen und in der Systemkonfiguration eigene Einstellungen eintragen. Oder die Datei "dashboard.php" im Rechnungsmodul selber ändern.
 

Till

Administrator
#2
Es wird eine neue Vesion des Billingmoduls für die 3.0.5.4 final geben, das aktuelle Modul ist nicht für die Dev Version gedacht.
 
#5
BTW Kann die finale Version problemlos per update.php über 3.0.5.4dev kopiert werden? Die Datei werden ja eigentlich nur überschrieben, aber wahrscheinlich sollte die installierte upd_00xx.sql der Dev-Version nicht größer als die der finalen Version sein.
 
#8
Anzahl der anzuzeigenden Positionen pro Seite

Falls das in der neuen Version des Rechnungsmoduls noch nicht behoben sein sollte:

Im Header der Listen fehlt die Auswahl für die Anzahl der anzuzeigenden Positionen pro Seite. Es wird zwar die aktuell eingestellte Auswahl aus ISPConfig übernommen, kann dann aber im Rechnungsmodul nicht mehr geändert werden.
 
#9
Icons werden aus dem Default-Theme genommen

Und noch etwas:

In den Templates vom Rechnungsmodul (interface/web/billing/templates/*) sind sämtliche Icons fest auf das (gar nicht mehr vorhandene) Default-Theme verdrahtet, statt auf das tatsächlich verwendete Theme zu referenzieren.

Gibt es bereits eine tmpl_var die man dafür verwenden könnte?
 

Till

Administrator
#10
Der Name des Themes, der identisch mit dem Ordner des Themes ist, steht in der template variable "theme" zur Verfügung.

Es gibt in der Version 3.0.5.4 weiterhin ein Default Theme, wie unter 3.0.5.3 und den Vorversionen.
 
#11
Hallo,

1)
ich habe das Billingmodule heute gekauft, bin ich von dieser Problematik noch betroffen ?

2) wie kann ich bestehende ( in ISPconfig3.05.4p1 bereits vorhanden) Kunden in das Modul "umziehen/kopieren"

DANKE !
 
Zuletzt bearbeitet:

Till

Administrator
#14
Du kannst von der 1.4er Billing Version auch eine Vorabversion erhalten, wenn Du möchtest. Bei Interesse schreib mir einfach eine Email an info at ispconfig dot org.
 

Werbung