ISPCONFIG 3.1 Loginseite wird nicht angezeigt

Dieses Thema im Forum "Entwicklerforum" wurde erstellt von die-andis, 23. Apr. 2016.

  1. die-andis

    die-andis Member

    Es ist jetzt leider schon zum zweiten mal passiert, das die Loginseite nicht mehr angezeigt wird. (Fehler: Verbindung fehlgeschlagen)

    https://SERVERNAME:8080

    Reboot Server hilft auch nicht. Server selbst ist über Konsole noch einwandfrei erreichbar. Die Testwebseiten nicht mehr.

    System: Debian Jessie (frisch installiert mit ISCPONFIG 3 nach Tutorial, anschließend Update auf 3.1 Beta1), Apache, Server4you Rootserver
     
    Zuletzt bearbeitet: 23. Apr. 2016
  2. die-andis

    die-andis Member

  3. florian030

    florian030 Member

    Steht dazu etwas im error.log von apache?
     
  4. Till

    Till Administrator

    Und check mal Deine Firewall, also ob port 8080 auf ist mit:

    iptables -L

    und checke mit:

    netstat -ntap

    ob der apache auf port 8080 lauscht.
     
  5. die-andis

    die-andis Member

    In der error.log.1 steht

    [ 2016-04-23 13:11:06.7338 12683/7f2f56b6b740 agents/Watchdog/Main.cpp:538 ]: Options: { 'analytics_lo$
    [ 2016-04-23 13:11:06.7366 12686/7f036ff38740 agents/HelperAgent/Main.cpp:650 ]: PassengerHelperAgent $
    [ 2016-04-23 13:11:06.7424 12691/7fd82ae06780 agents/LoggingAgent/Main.cpp:321 ]: PassengerLoggingAgen$
    [ 2016-04-23 13:11:06.7425 12683/7f2f56b6b740 agents/Watchdog/Main.cpp:728 ]: All Phusion Passenger ag$
    AH00016: Configuration Failed
     
  6. Till

    Till Administrator

    Das ist aber ein Ruby Passenger Problem, möglicherweise hast Du da ein Konfigurationsproblem außerhalb von ISPConfig, denn Passenger wird nicht von ISPConfig verwendet. Denn wen apache nicht startet weil irgendwo in der apaceh Konfig außerhalb von ispconfig ein fehler ist, dan ist ispconfig auch nicht mehr erreichbar.
     
  7. die-andis

    die-andis Member

    iptables -L bringt:

    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-postfix-sasl tcp -- anywhere anywhere multiport dports smtp
    fail2ban-dovecot-pop3imap tcp -- anywhere anywhere multiport dports pop3,pop3s,imap2,imaps
    fail2ban-pureftpd tcp -- anywhere anywhere multiport dports ftp
    fail2ban-ssh tcp -- anywhere anywhere multiport dports ssh
    Chain FORWARD (policy ACCEPT)
    target prot opt source destination
    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    Chain fail2ban-dovecot-pop3imap (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere
    Chain fail2ban-postfix-sasl (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere
    Chain fail2ban-pureftpd (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere
    Chain fail2ban-ssh (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere

    netstat -ntap bringt:

    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 12744/named
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 12590/master
    tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 1/init
    tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 12635/dovecot
    tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN 12627/amavisd-new (
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 12590/master
    tcp 0 0 127.0.0.1:10026 0.0.0.0:* LISTEN 12627/amavisd-new (
    tcp 0 0 127.0.0.1:10027 0.0.0.0:* LISTEN 12590/master
    tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 12590/master
    tcp 0 0 127.0.0.1:11211 0.0.0.0:* LISTEN 591/memcached
    tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 12635/dovecot
    tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 1/init
    tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN 12590/master
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 12800/pure-ftpd (SE
    tcp 0 0 85.25.214.187:53 0.0.0.0:* LISTEN 12744/named
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 12744/named
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 592/sshd
    tcp 0 268 85.25.214.187:22 217.248.239.205:57428 VERBUNDEN 4064/0
    tcp 0 0 85.25.214.187:143 217.241.1.250:54304 VERBUNDEN 14765/imap-login
    tcp 0 0 127.0.0.1:32866 127.0.0.1:3306 VERBUNDEN 12733/amavisd-new (
    tcp 0 0 85.25.214.187:143 217.241.1.250:53640 VERBUNDEN 7971/imap-login
    tcp 64 0 127.0.0.1:46789 127.0.0.1:10025 CLOSE_WAIT 12733/amavisd-new (
    tcp6 0 0 :::25 :::* LISTEN 12590/master
    tcp6 0 0 :::993 :::* LISTEN 1/init
    tcp6 0 0 :::995 :::* LISTEN 12635/dovecot
    tcp6 0 0 :::3306 :::* LISTEN 12294/mysqld
    tcp6 0 0 :::587 :::* LISTEN 12590/master
    tcp6 0 0 :::110 :::* LISTEN 12635/dovecot
    tcp6 0 0 :::143 :::* LISTEN 1/init
    tcp6 0 0 :::465 :::* LISTEN 12590/master
    tcp6 0 0 :::21 :::* LISTEN 12800/pure-ftpd (SE
    tcp6 0 0 :::53 :::* LISTEN 12744/named
    tcp6 0 0 :::22 :::* LISTEN 592/sshd
    tcp6 0 0 127.0.0.1:3306 127.0.0.1:32866 VERBUNDEN 12294/mysqld
     
  8. die-andis

    die-andis Member

    Apache lässt sich ohne Probleme per "service apache restart" starten
     
  9. florian030

    florian030 Member

    Wenn sich Apache tatsächlich ohne Probleme starten lässt, dann taucht dazu auch etwas bei netstat auf. Bei Dir steht da aber kein Apache mit dabei.
    Das kannst Du mir service apache2 status überprüfen. Oder auch mit ps -ef|grep apache
     
  10. die-andis

    die-andis Member

    hast recht da steht was.

    maltaxxx:/var/log/ispconfig# service apache2 status
    apache2.service - LSB: Apache2 web server
    Loaded: loaded (/etc/init.d/apache2)
    Active: active (exited) since So 2016-04-24 11:07:51 CEST; 56min ago
    Process: 8640 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
    Process: 12721 ExecReload=/etc/init.d/apache2 reload (code=exited, status=1/FAILURE)
    Process: 8649 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)
    Apr 24 11:07:51 maltaxxx apache2[8649]: Starting web server: apache2AH00548: NameVirtualHost has no effect and will be removed in...conf:67
    Apr 24 11:07:51 maltaxxx apache2[8649]: Action 'start' failed.
    Apr 24 11:07:51 maltaxxx apache2[8649]: The Apache error log may have more information.
    Apr 24 11:07:51 maltaxxx apache2[8649]: .
    Hint: Some lines were ellipsized, use -l to show in full.
     
  11. florian030

    florian030 Member

    Siehe #6 von Till....
     
  12. die-andis

    die-andis Member

    so ich habe gestern genau das gleiche nochmal gemacht und den gleichen Effekt erreicht.
    1. frische Installation von Jessie
    2. Update ISPCONFIG auf 3.1 B1
    3. Installation Lets Encrypt (gemäß https://www.howtoforge.com/tutorial...doveot-and-ispconfig/2/#-install-lets-encrypt)
    4. Anlegen einer Webseite
    5. Aktivieren SSL + Lets Encrypt + Zertifikat erzeugen für die angelegte Webseite

    Anschließend war der Apache wieder nicht erreichbar. Gleiche Meldungen wie oben bereits gepostet
     
  13. robotto7831a

    robotto7831a Member

    Und haste mal ins Apachelog geschaut?
     
  14. florian030

    florian030 Member

    Evtl. auch einfach mal 2. und 3. vertauschen
     
  15. mzips

    mzips Member

    Ich würde auch erst alle System relevanten wie ufe le usw installieren und ganz zum schluss erst ispconfig 3, schau doch mal in den logs von LE
     
  16. die-andis

    die-andis Member

    so nochmal frisch installiert. als vorletztes Lets Encrypt und dann direkt 3.1 B1

    Ergebnis: -> sind die letzten Zeilen des error.log aus /var/log/apache2/

    Sobald ich eine Seite hinzufüge und dort Lets encrypt aktiviere. Startet der Apache nicht mehr
    [ 2016-04-25 18:36:12.9064 22399/7f8cb87ff740 agents/Watchdog/Main.cpp:728 ]: All Phusion Passenger agents started!
    [Mon Apr 25 18:36:12.923745 2016] [:error] [pid 22393] python_init: Python version mismatch, expected '2.7.5+', found '2.7.9'.
    [Mon Apr 25 18:36:12.923790 2016] [:error] [pid 22393] python_init: Python executable found '/usr/bin/python'.
    [Mon Apr 25 18:36:12.923792 2016] [:error] [pid 22393] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Mon Apr 25 18:36:12.923803 2016] [:notice] [pid 22393] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Mon Apr 25 18:36:12.923805 2016] [:notice] [pid 22393] mod_python: using mutex_directory /tmp
    [Mon Apr 25 18:36:12.929095 2016] [ssl:warn] [pid 22393] AH01906: malta1112.startdedicated.de:8080:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Apr 25 18:36:12.929105 2016] [ssl:warn] [pid 22393] AH01909: malta1112.startdedicated.de:8080:0 server certificate does NOT include an ID which matches the server name
    [Mon Apr 25 18:36:12.929128 2016] [ssl:error] [pid 22393] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: O=Internet Widgits Pty Ltd,ST=Some-State,C=AU / issuer: O=Internet Widgits Pty Ltd,ST=Some-State,C=AU / serial: A82AA6D24EBEBAB3 / notbefore: Apr 25 16:32:52 2016 GMT / notafter: Apr 23 16:32:52 2026 GMT]
    [Mon Apr 25 18:36:12.929131 2016] [ssl:error] [pid 22393] AH02567: Unable to configure certificate malta1112.startdedicated.de:8080:0 for stapling
    [Mon Apr 25 18:36:12.931669 2016] [mpm_prefork:notice] [pid 22393] AH00163: Apache/2.4.10 (Debian) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 Phusion_Passenger/4.0.53 mod_python/3.3.1 Python/2.7.9 OpenSSL/1.0.1k configured -- resuming normal operations
    [Mon Apr 25 18:36:12.931683 2016] [core:notice] [pid 22393] AH00094: Command line: '/usr/sbin/apache2'
    [Mon Apr 25 18:36:19.484348 2016] [core:warn] [pid 22393] AH00045: child process 22484 still did not exit, sending a SIGTERM
    [Mon Apr 25 18:36:21.486470 2016] [core:warn] [pid 22393] AH00045: child process 22484 still did not exit, sending a SIGTERM
    [Mon Apr 25 18:36:23.488580 2016] [core:warn] [pid 22393] AH00045: child process 22484 still did not exit, sending a SIGTERM
    [Mon Apr 25 18:36:25.490711 2016] [core:error] [pid 22393] AH00046: child process 22484 still did not exit, sending a SIGKILL
    [Mon Apr 25 18:36:26.491828 2016] [mpm_prefork:notice] [pid 22393] AH00169: caught SIGTERM, shutting down
    [ 2016-04-25 18:36:27.3012 22535/7efef38fa740 agents/Watchdog/Main.cpp:538 ]: Options: { 'analytics_log_user' => 'nobody', 'default_group' => 'nogroup', 'default_python' => 'python', 'default_ruby' => '/usr/bin/ruby', 'default_user' => 'nobody', 'log_level' => '0', 'max_pool_size' => '6', 'passenger_root' => '/usr/lib/ruby/vendor_ruby/phusion_passenger/location$
    [ 2016-04-25 18:36:27.3038 22538/7fe264e8d740 agents/HelperAgent/Main.cpp:650 ]: PassengerHelperAgent online, listening at unix:/tmp/passenger.1.0.22533/generation-0/request
    [ 2016-04-25 18:36:27.3094 22545/7f48d5bd2780 agents/LoggingAgent/Main.cpp:321 ]: PassengerLoggingAgent online, listening at unix:/tmp/passenger.1.0.22533/generation-0/logging
    [ 2016-04-25 18:36:27.3095 22535/7efef38fa740 agents/Watchdog/Main.cpp:728 ]: All Phusion Passenger agents started!
    AH00016: Configuration Failed
    [ 2016-04-25 18:36:34.4692 22605/7fc29f09e740 agents/Watchdog/Main.cpp:538 ]: Options: { 'analytics_log_user' => 'nobody', 'default_group' => 'nogroup', 'default_python' => 'python', 'default_ruby' => '/usr/bin/ruby', 'default_user' => 'nobody', 'log_level' => '0', 'max_pool_size' => '6', 'passenger_root' => '/usr/lib/ruby/vendor_ruby/phusion_passenger/location$
    [ 2016-04-25 18:36:34.4718 22608/7f19c32e7740 agents/HelperAgent/Main.cpp:650 ]: PassengerHelperAgent online, listening at unix:/tmp/passenger.1.0.22603/generation-0/request

    [ 2016-04-25 18:36:34.4773 22616/7f67c7da8780 agents/LoggingAgent/Main.cpp:321 ]: PassengerLoggingAgent online, listening at unix:/tmp/passenger.1.0.22603/generation-0/logging

    [ 2016-04-25 18:36:34.4774 22605/7fc29f09e740 agents/Watchdog/Main.cpp:728 ]: All Phusion Passenger agents started!

    AH00016: Configuration Failed
     
  17. die-andis

    die-andis Member

    ein Restart Apache2 erzeugt immer folgende Fehlermeldungen:

    [ 2016-04-25 19:07:07.5773 11313/7f807bfff740 agents/Watchdog/Main.cpp:538 ]: Options: { 'analytics_log_user' => 'nobody', 'default_group' => 'nogroup', 'default_python' => 'python', 'default_ruby' => '/usr/bin/ruby', 'default_user' => 'nobody', 'log_level' => '0', 'max_pool_size' => '6', 'passenger_root' => '/usr/lib/ruby/vendor_ruby/phusion_passenger/location$
    [ 2016-04-25 19:07:07.5809 11316/7fcd1ad28740 agents/HelperAgent/Main.cpp:650 ]: PassengerHelperAgent online, listening at unix:/tmp/passenger.1.0.11311/generation-0/request
    [ 2016-04-25 19:07:07.5862 11324/7f9c59827780 agents/LoggingAgent/Main.cpp:321 ]: PassengerLoggingAgent online, listening at unix:/tmp/passenger.1.0.11311/generation-0/logging
    [ 2016-04-25 19:07:07.5864 11313/7f807bfff740 agents/Watchdog/Main.cpp:728 ]: All Phusion Passenger agents started!
    AH00016: Configuration Failed

    in Log von Lets Encrypt ist nichts auffälliges zu sehen.
     
  18. robotto7831a

    robotto7831a Member

    Bearbeite doch mal die Error Meldungen im Logfile.
     
  19. Till

    Till Administrator

    Soweit ich sehe ist nichts von den Fehlern von ispconfig sondern alles von Passenger. Du hast den ganzen server komplett formatiert und frisch installiert? Nach welchem Tutorial?
     
  20. die-andis

    die-andis Member

    Guten Morgen,
    der Server wurde jedesmal per Restore auf Debian Jessie "Minimal" Raid1 zurückgesetzt.

    Die Anleitung die ich benutzt habe ist diese:
    https://www.howtoforge.com/tutorial/perfect-server-debian-8-jessie-apache-bind-dovecot-ispconfig-3/
    zusätzlich habe ich auch dieses probiert
    https://www.howtoforge.com/tutorial/ispconfig-install-script-debian/

    Der Fehler kommt immer erst wenn ich Lets Encrypt installiere
    (gemäß: https://www.howtoforge.com/tutorial...doveot-and-ispconfig/2/#-install-lets-encrypt)
    und dann eine Seite mit SSL aktiviere. Habe auch schon probiert erst Lets Encrypt und anschließend IPSCONFIG zu installieren.
     

Diese Seite empfehlen