ISPConfig 3.1b1: Generieren von DKIM Schlüsseln schlägt fehl

#1
Hi,
ich kann plötzlich keine weiteren DKIM Schlüssel generieren. Für eine Domain konnte ich das. Jetzt will ich für eine weitere Domain DKIM Schlüssel generieren und erhalte im Browser die Fehlermeldung:
Request done but NOK
Error:0
Leider finde ich keine Logs dazu. Das System ist gestern frisch installiert und ich habe keinerlei Berechtigungen seperat vorgenommen.
Zum System:
Ubuntu 16.04 LTS
ISPConfig 3.1b1
DKIM Pfad: /var/lib/amavis/dkim
root@schickel:/var/lib/amavis# ll
total 28
drwxr-x--- 7 amavis amavis 4096 Jun 8 10:19 ./
drwxr-xr-x 68 root root 4096 Jun 8 10:18 ../
srwxr-x--- 1 amavis amavis 0 Jun 8 10:19 amavisd.sock=
drwxr-x--- 2 amavis amavis 4096 Jun 8 10:19 db/
drwxr-x--- 2 amavis amavis 4096 Jun 8 08:27 dkim/
root@schickel:/var/lib/amavis/dkim# ll
total 16
drwxr-x--- 2 amavis amavis 4096 Jun 8 08:27 ./
drwxr-x--- 7 amavis amavis 4096 Jun 8 10:19 ../
-rw-r--r-- 1 root root 1706 Jun 8 08:27 example.com.private
-rw-r--r-- 1 root root 451 Jun 8 08:27 example.com.public
 

Till

Administrator
#4
Das ist aber nicht der debug loglevel. Lies mal bitte den kompletten beitrag auf faqforge und nimm alle einstellungen wie dort beschrieben vor.
 
#5
Ich habe es nun auf DEBUG gestellt.
Änderungen am DKIM-Seting löst keinen anderen Log-Eintrag aus als diesen nichtssagenden:

root@schickel:/usr/local/ispconfig/server/temp# /usr/local/ispconfig/server/server.sh
08.06.2016-12:25 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
08.06.2016-12:25 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
08.06.2016-12:25 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

Andere Änderungen (Aktivierung SMAP) werden normal protokolliert:
08.06.2016-12:29 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

08.06.2016-12:29 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
08.06.2016-12:29 - DEBUG - Found 1 changes, starting update process.
08.06.2016-12:29 - DEBUG - Processed datalog_id 110
08.06.2016-12:29 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
 
#6
Die Keys werden im Interface und nicht über das Server-Plgugin erstellt. Wenn Du einen Fehler wie "Request done but NOK" bekommst, dann ist wahscheinlich exec deaktiviert.
 
#7
Blöde Frage: wo exec aktivieren? php.ini oder?
Aber ich habe es dennoch hinbekommen. Auf meiner Workstation habe alle verfügbaren Browser ausprobiert und mit keinem ging's. Dann habe ich mein Tablet genommen und schwupps wurden die Keys generiert. Erklärung dafür nicht vorhanden...
 
#10
javascript ist aktiv und adblocker habe ich auch deaktiviert.

Ich denke, dass es kein Problem im ISPConfig ist. Daheim auf meinem Rechner konnte ich es auch machen, sowie auf allen Mobile Devices (Android/iOSbäääh). Meine Vermutung geht auf den tollen Proxy hier in meinem Büro. Möglicherweise filtert/blockiert der Proxy die Ausführung für das Generieren der Schlüssel.

Trotzdem Danke für die Unterstützung.
 

Werbung