ISPConfig 3 alpha tests

Dieses Thema im Forum "Entwicklerforum" wurde erstellt von planet_fox, 13. Feb. 2008.

  1. planet_fox

    planet_fox Super-Moderator

    Sys. Ubunto 7.10

    Hab ne Mailbox erstelllt, domän erstellt .
    Login auf Squirrelmail geht nicht, da gibts dann folgende error message

    Code:
    [B][COLOR=#cc0000] ERROR: Could not complete request.[/COLOR][/B][COLOR=#cc0000]
    Query: SELECT "INBOX"
    Reason Given: Unable to open this mailbox.[/COLOR]
    Hab über phpmyadmin mal rein geschaut aber finde da nicht mein angelegte domän oder den mail user. unter /home/vmail/ sind die user an gelegt aber hier mal die logfiles.

    mailq

    Code:
    8AB1335EE69     1506 Mon Feb 11 22:29:26  alex@domän.de
    (temporary failure. Command output: sh: /home/vmail/domän.de/tux/.ispconfig_mailsize: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /home/vmail/7ox.de/fox/5244.0.tux.server.lan.)
                                             tux@mydomän.de
    
    mail.log

    Code:
    Feb 13 18:46:05 tux imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 13 18:46:05 tux imapd: LOGIN, user=tux@mydomän.de, ip=[::ffff:127.0.0.1], protocol=IMAP
    Feb 13 18:46:05 tux imapd: DISCONNECTED, user=tux@mydomän.de, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=53, sent=79, time=1
    Feb 13 18:46:05 tux imapd: DISCONNECTED, user=tux@mydomän.de, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=21, sent=57, time=0
    
    mail.info

    Code:
    Feb 13 18:52:10 tux maildrop[6851]: Unable to create a dot-lock at /home/vmail/mydomän.de/tux/6851.0.tux.server.lan.
    Feb 13 18:52:10 tux postfix/pipe[6822]: CF6A135EC4D: to=<tux@mydomän.de>, relay=maildrop, delay=70108, delays=70108/0.29/0/0.05, dsn=4.3.0, status=deferred (temporary failure. Command output: sh: /home/vmail/mydomän/tux/.ispconfig_mailsize: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /home/vmail/mydomän/tux/6851.0.tux.server.lan.  )
    Feb 13 18:52:10 tux maildrop[6857]: Unable to create a dot-lock at /home/vmail/mydomän.de/tux/6857.0.tux.server.lan.
    
    
    
     
    Zuletzt bearbeitet: 13. Feb. 2008
  2. Till

    Till Administrator

    Poste mal bitte die Ausgabe von:

    ls -la /home/vmail/domän.de/tux/
     
  3. planet_fox

    planet_fox Super-Moderator

    Code:
    root@tux:/home/fox# ls -la /home/vmail/domän.de/tux/
    total 8
    drwxr-xr-x 2 root root 4096 2008-02-11 22:19 .
    drwxr-xr-x 4 root root 4096 2008-02-11 22:34 ..
    
     
  4. Till

    Till Administrator

    Hmm, das ist komisch, das Verzeichnis sollte eigentlich dem User vmail gehören. Gibt es den User vmail in /etc/passwd ? Wenn ja, denn mach mal ein

    chown vmail /home/vmail/domän.de/tux/
     
  5. planet_fox

    planet_fox Super-Moderator

    hab ich gemacht


    etc/passwd
    Code:
    vmail:x:5000:5000::/home/vmail:/bin/sh
    
    mailq sagt

    Code:
    (temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox.)
    
    mail.log

    Code:
    Feb 14 23:52:19 tux amavis[5041]: (05041-02) ...n/Plugin/VBounce.pm, Mail/SpamAssassin/Plugin/WLBLEval.pm, NetAddr/IP.pm, NetAddr/IP/Lite.pm, NetAddr/IP/Util.pm, NetAddr/IP/Util_IS.pm, unicore/lib/gc_sc/Word.pl, version.pm, version/vxs.pm
    Feb 14 23:52:19 tux amavis[5041]: (05041-02) exiting process_request
    Feb 14 23:52:19 tux amavis[5041]: (05041-02) post_process_request_hook: timer was not running
    Feb 14 23:52:19 tux amavis[5041]: (05041-02) idle_proc, bye: was busy, 8.7 ms, total idle 10712.237 s, busy 68.812 s
    Feb 14 23:52:19 tux amavis[5041]: (05041-02) load: 1 %, total idle 10712.237 s, busy 68.812 s
    Feb 14 23:52:19 tux maildrop[10647]: Unable to open mailbox.
    Feb 14 23:52:20 tux postfix/pipe[10646]: BBFC135EC87: to=<tux@domän.de>, relay=maildrop, delay=0.24, delays=0.09/0.07/0/0.08, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox. )
    
     
  6. Till

    Till Administrator

    Ok, versuch mal bitte:

    chown -R vmail /home/vmail
     
  7. planet_fox

    planet_fox Super-Moderator

    Gesagt getan, keine änderung in logfiles

    Code:
    root@tux:/home/tux# ls -la /home/vmail/
    total 36
    drwxr-xr-x  4 vmail vmail 4096 2008-02-11 22:19 .
    drwxr-xr-x 13 root  root  4096 2008-02-06 14:52 ..
    drwxr-xr-x  4 vmail root  4096 2008-02-11 22:34 domän.de
    -rw-r--r--  1 vmail vmail  220 2008-01-27 19:07 .bash_logout
    -rw-r--r--  1 vmail vmail 2298 2008-01-27 19:07 .bashrc
    -rw-------  1 vmail vmail 1251 2008-02-12 23:16 .mailfilter
    -rw-r--r--  1 vmail root  1251 2008-02-12 23:16 .mailfilter~
    drwxr-xr-x  2 vmail root  4096 2008-02-11 21:58 mailfilters
    -rw-r--r--  1 vmail vmail  566 2008-01-27 19:07 .profile
    
    Code:
    root@tux:/home/fox# ls -la /home/vmail/domän.de/
    total 16
    drwxr-xr-x 4 vmail root  4096 2008-02-11 22:34 .
    drwxr-xr-x 4 vmail vmail 4096 2008-02-11 22:19 ..
    drwxr-xr-x 2 vmail root  4096 2008-02-15 20:37 tux
    drwxr-xr-x 2 vmail root  4096 2008-02-11 22:34 info
    
     
  8. Till

    Till Administrator

    Ok, ich muss mir mal ein neues Testsystem aufsetzten und mir das ansehen. bei meinem aktuellen geht es, das ist aber auch schon recht betagt und ziemlich viel geändert.

    Ich hatte gerade letztens was am Script, das die Maildirs anlegt verändert. Das wird wohl das Problem verursachen.
     
  9. planet_fox

    planet_fox Super-Moderator

    gut dann lass wir das mal so stehn.Nächster Punkt.

    Wenn ich einen neuen DNS
    namen eingebe kommt

    Code:
    regex error
     
  10. Till

    Till Administrator

    Hast Du am Ende des Domainnamens einen Punkt eingegeben?
     
  11. planet_fox

    planet_fox Super-Moderator

    Das wars, DNS läuft denke ich mal soweit und sehe nun auch die ISP Willkommens Seite wenn dich die
    Domäne eingeb in den Explorer :)[FONT=Helvetica, Arial] Welcome to your website!.


    [/FONT]
     
    Zuletzt bearbeitet: 17. Feb. 2008
  12. Till

    Till Administrator

    Die offizielle DNS Schreibweise von Domains ist immer mit Punkt am Ende, daher auch das Beispiel neben dem Feld im DNS Manager. Bei ISPConfig 2 hatten wir das intern automatisch dazugefügt und den Punkt nicht angezeigt. Da hatten sich aber ein paar Leute beschwert.

    Persönlich finde ich es auch ihne Punkt besser. Ich werde mal sehen, ob ich das in ISPConfig3 noch ändere.
     
  13. planet_fox

    planet_fox Super-Moderator

    Ne lass es so, hab denn punkt neben dran übersehen

    Die ISP Firewall gibts in ISP3 nicht ? beim dns ist auch aufgefallen das ein button mit zurück von vorteil wer. Aber naja das is mehr oder weniger Kosmetik
     
  14. Till

    Till Administrator

    Nein, Firewall gibt es nicht, oder zumindest noch nicht.
     
  15. Till

    Till Administrator

    Es gibt jetzt auch einen neuen Bugtracker für ISPConfig, der auch für die ISPConfig 3 Bugs ist.

    http://bugtracker.ispconfig.org

    Um Da bugs posten zu können, melde Dich bitte an und sende mir dann eine PM mit Deinem Usernamen, damit ich ihm dann die nötige Berechtigung geben kann.
     
  16. Till

    Till Administrator

    Habe gerade das Mailsystem nochmal in meiner TestVM angesehen und hatte keinen Fehler. Ich werde nochmal alles neu aufsetzen, um zu sehen ob ich das Problem reproduzieren kann.
     
  17. planet_fox

    planet_fox Super-Moderator

    ok, kann dir auch mal zugang noch mal geben wennst schauen magst, der bugtracker soll Deutsch oder english gepostet werden ?
     
  18. Till

    Till Administrator

    Habe Dich im Bugtracker jetzt freigeschaltet. Bitte im Bugtracker auf englisch posten.
     
  19. planet_fox

    planet_fox Super-Moderator

    mercy Till schon zeit gehabt für deine neu installation ?
     
  20. Till

    Till Administrator

    Nein. Ich hoffe dass ich Morgen dazu komme.
     

Diese Seite empfehlen