ISPConfig 3 / Apache 403 Error

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von summer-soul, 8. Jan. 2014.

  1. summer-soul

    summer-soul New Member

    Hallo in die Runde,

    Neben einigen Standardiensten habe ich nunmehr u.a. auch ISPconfig3 zur Verwaltung auf meinem vServer installiert.

    Wenn ich nun aber http://62.113.250.214:3128/ eingebe um auf den Login zu gelangen erhalte ich einen Apache 403 Error!

    Ich habe bereits mit anderen Ports getestet, die ebenfalls nicht klappen! Die index.html über http://62.113.250.214 wir jedoch einwandfrei eingezeigt. Das home Verzeichnis ist /var/www in dem auch die index.html liegt.

    Die /etc/apache2/sites-available/ispconfig.vhost sieht wie folgt aus:

    Code:
      Listen 3128
    NameVirtualHost *:3128
    
    <VirtualHost _default_:3128>
      ServerAdmin webmaster@localhost
    
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options -Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
            MaxRequestLen 15728640
      </IfModule>
    
      <IfModule mpm_itk_module>
        DocumentRoot /usr/local/ispconfig/interface/web/
            AssignUserId ispconfig ispconfig
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
      #SSLEngine On
      #SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
      #SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    
    Trotz Studium dieses Wikis: http://wiki.apache.org/httpd/ClientDrConfiguration bekomme ich es leider nicht zum Laufen

    Wo könnte der Fehler liegen?

    Schon einmal vielen Herzlichen Dank und

    beste Grüße
    summer-soul
     
  2. Till

    Till Administrator

    Schau mal ins apache error.log und ins suexec.log. Der vhost von ispconfig ist ok, wird ja genau so auf mehreren hunderttausend servern weltweit verwendet.
     
  3. summer-soul

    summer-soul New Member

    Hey Till,

    danke für Deine Rückmeldung!

    Die letzten Eintraäge aus dem apache Error.log lauten:

    Code:
    [Wed Jan 08 14:34:15 2014] [error] [client 217.91.67.219] client denied by server configuration: /etc/apache2/htdocs
    [Wed Jan 08 14:34:15 2014] [error] [client 217.91.67.219] client denied by server configuration: /etc/apache2/htdocs
    [Wed Jan 08 14:34:15 2014] [error] [client 217.91.67.219] client denied by server configuration: /etc/apache2/htdocs
    [Wed Jan 08 14:34:17 2014] [error] [client 217.91.67.219] client denied by server configuration: /etc/apache2/htdocs
    [Wed Jan 08 14:34:18 2014] [error] [client 217.91.67.219] client denied by server configuration: /etc/apache2/htdocs
    
    Eine suexec.log habe ich gar nicht ?!

    Danke
     
  4. Till

    Till Administrator

    Ok. hast Du irgend was in apache manuell konfiguriert, andere Webseiten oder so? Und bist Du einem der perfect setup tutorials für die Installation gefolgt, so dass auch wirklich alle Systemvoraussetzungen erfüllt sind (alle apacje Module und sonstigen pakete)?
     
  5. summer-soul

    summer-soul New Member

    Hallo Till,

    wow, das geht ja schnell hier :) Super!

    Ja, ich habe für die Zarafa Installation einiges im Apachen geändert, bin dabei nach dieser Anleitung vorgegangen:

    Development Blog | Der Weg zum eigenen Mailserver mit einem abgesicherten Zarafa Server

    ISP Config selbst habe ich nach folgender Anleitung installiert ...

    HowtoForge Linux Tutorials » Der Perfekte Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3)

    Habe hier aber einige Schritte ausgelassen und erst ab Schritt 16 angefangen!
     
  6. summer-soul

    summer-soul New Member

    ... ich habe das Problem soeben behoben!

    Habe noch einige Pakete nachinstalliert und schwups, nun läuft alles!

    Trotzdem herzlichen Dank und

    beste Grüße

    summer-soul
     

Diese Seite empfehlen