ispconfig 3 auf Port 80

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von isp_geek, 2. Mai 2014.

  1. isp_geek

    isp_geek Member

    Hallo Leute,

    vieleicht doch zu Recht nochmal hier mein Problem ispconfig und dem Port 80.

    Ich hab jetzt versucht die ispconfig.vhost auf 80 zu ändern, wie in den im Internet auffinbaren Hinweisen. Leider ohne Erfolg. Wenn ich einen Port ungleich 80 wähle geht es, sonst bekomme ich die Meldung:

    Code:
    /etc/init.d/apache2 restart
    [....] Restarting web server: apache2[Fri May 02 09:27:53 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Fri May 02 09:27:53 2014] [warn] NameVirtualHost *:80 has no VirtualHosts
     ... waiting [Fri May 02 09:27:54 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Fri May 02 09:27:54 2014] [warn] NameVirtualHost *:80 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:80
    . ok
    
    Auf dem Server soll nur das Control Panel laufen und keine anderen Webseiten.

    Jetzt hab ich aber auch schon versucht über eine Webseite und den Apache Direktiven (Proxy) umzuleiten, was auch nicht richtig geht (und nicht meine erste sondern letzte Wahl wäre) - kann das etwa der Fehler sein? Die Seite ist jetzt deaktiviert.

    Ich hoffe ich kann das Problem mit euch zusammen schnell lösen .. VielenDankVorab ks
     
  2. Till

    Till Administrator

    Du scheinst nicht nur den vhost geändert zu haben sondern auch das Listen 8080. Ändere bitte den port nur im vhost. das Listen 8080 wird auskommentiert.
     
  3. isp_geek

    isp_geek Member

    hi till, danke für die schnelle antwort ...

    also ich hatte schon etliches probiert, auch das Listen auszukommentieren. Ich lande dann immer auf der "It Works" - Seite, Fehler weg mehr passiert nicht.

    Vielleicht sollte ich noch erwähnen, dass der gesamte Server unter einer Subddomain läuft, also admin.mydomain.de. Kann ich denn dann den Proxy überhaupt zum umleiten von "admin.mydomain.de:8080" auf "admin.mydomain.de" verwenden?

    lg.ks
     
  4. isp_geek

    isp_geek Member

    gelöst

    und natürlich noch den symlink 000-default aus sites-enabled löschen ..
     

Diese Seite empfehlen