ISPConfig 3 / Debian 6: kein Login mehr möglich

#1
Ich kann mich in ISPConfig 3 mit dem richtigen Passwort nicht mehr einloggen. Habe davor mit openvz rum experimentiert, zu viel RAM aus Versehen gesetzt danach schloß sich Putty vom Hauptsystem konnte mich aber gleich wieder einloggen und Apache neu starten, aber in ISPConfig 3 komm ich nicht mehr rein. Was ist da los? Speicher sind über 450 GB frei, der VPS hatte zum Test 390 GB bekommen.

ERROR

Error
Benutzername oder Passwort falsch.1


Password lost?
 
#2
Habe jetzt festgestellt, wenn ich den Server neu starte geht`s wieder mit dem einloggen. Ich habe keine Idee warum dies so ist. Wenn ich jetzt wieder einen vServer via dem Panel erstelle (512MB Guaranteed, 1024MB Burstable) und versuche diesen zu starten, schließt sich PuTTY nach wie vor, Apache stoppt (und wer weiß welche Dienste noch). Sofort danach kann ich mich in das Hostsystem via SSH wieder einloggen, aber jedesmal wenn ich den VPS starte passiert das und ich muss den Server wie erwähnt halt neu starten damit ich mich wieder in ISPConfig 3 einloggen kann. Server hat 2 GB real RAM.
 
#4
Hi Till, ja habe ich. Die IPs habe ich auch vor dem aufsetzen des Servers alle in die /etc/network/interfaces eingetragen (hoffe dies war auch nötig).
 
#6
Upps, ist es für einen wahrscheinlich reibunglosen Betrieb jetzt ausreichend einfach diese IPs aus der Datei zu entfernen ? Soll man die in ISPConfig 3 aber eintragen, also nicht nur in "vServer" sondern auch in den Reiter "System"?
 

Till

Administrator
#7
#8
Ja. Und dann das netzwerk neu starten.



Die IP nur unter vserver eintragen.
Okay habe die Interfaces komplett auskommentiert, neu gestartet, alle alten vServer gelöscht und jetzt neu angelegt. Unter System -> IP Adressen stehen keine IPs. Leider funktioniert das connecten auf Port 22 via SSH zu den jeweiligen VPS nicht. Gehe ich recht in der Annahme das der Dienst "SSH" bei dem OpenVZ OSTemplate "debian-6.0-amd64-minimal" dabei ist?

Code:
vzlist -a
      CTID      NPROC STATUS    IP_ADDR         HOSTNAME
       101          6 running   214.22.122.83  dsdsdsdsds
       102          7 running   214.22.122.85  rwa.domain.org
 
Zuletzt bearbeitet:

Till

Administrator
#9
Loogge Dich doch einfach mal in die VM ein und sieh nach:

vzctl enter 101

101 durch die ID Deiner VM erstezen.

Nach welcher Anleitung hast Du denn Deinen Server installiert?
 
#10
Diesen Begriff habe ich ewig gegoogelt, habe selbst Eingaben wie vzctl login 101, vzctl ssh 101, vzctl log on 101 usw. gemacht nachdem ich im OpenVZ Wiki warum auch immer das nicht gefunden habe, dachte schon daher es gebe nur SSH zum einloggen... :eek: :D

Installiert nach HowtoForge Linux Tutorials » Installation von OpenVZ + Verwaltung von VMs mit ISPConfig 3 (Debian 6.0)

Jetzt wo ich drin bin, sieht es so aus:

http://www.tiikoni.com/tis/view/?id=62bfa17


Scheint so als ob keine Internetverbindung besteht, verstehe aber nicht warum. SSH scheint installiert zu sein und würde in der Theorie laufen.
 

Anhänge

Zuletzt bearbeitet:
#11
installier doch dann einfach den server ggf. neu? ich haette jetzt auch keinen plan, hatte mal ein aehnliches problem wo aus nicht ganz klaren gruenden die vps kein www hatten.
 
#13
Achso ok, ja ich war auch mal bei der Konkurrenz da das gleiche. Poste ggf. mal die interfaces, funktioniert der Server sonst (andere Dienste wie z.B. TS2)? Denke es handelt sich um eine Kleinigkeit wenn nach dem Tutorial gegangen bist und nicht grob verändert hast, ein Auszug von Logs der VPS kann auch nicht schaden.
 
#14
Hier die /etc/network/interfaces Datei:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
    address 209.38.23.182
    netmask 255.255.255.128
    network 209.38.23.128
    broadcast 209.38.23.255
    gateway 209.38.23.129
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 122.122.92.32 122.122.93.32
    dns-search hiermeinedomain.org

#auto eth0:0
#iface eth0:0 inet static
#    address 209.38.23.183
#    netmask 255.255.255.128
#
#auto eth0:1
#iface eth0:1 inet static
#    address 209.38.23.243
#    netmask 255.255.255.128
#
#auto eth0:2
#iface eth0:2 inet static
#    address 209.38.23.244
#    netmask 255.255.255.128
(IP Adressen anonymisiert)

Bin für jede Hilfe dankbar ;)

Nachtrag:

Hier die /var/log/vzctl.log (hoffe das hilft)

Logfile leider zu lang
 
Zuletzt bearbeitet:
#15
Code:
2012-08-03T07:01:46-0500 vzeventd : Started
2012-08-03T07:01:47-0500 vzctl : Setting CPU units: 1000
2012-08-03T07:01:47-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-03T07:31:30-0500 vzeventd : Started
2012-08-03T07:31:34-0500 vzctl : Setting CPU units: 1000
2012-08-03T07:31:34-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-03T07:57:02-0500 vzctl : CT 101 : Creating container private area (debian-6.0-amd64-minimal)
2012-08-03T07:57:12-0500 vzctl : CT 101 : Performing postcreate actions
2012-08-03T07:57:12-0500 vzctl : CT 101 : Container private area was created
2012-08-03T07:57:12-0500 vzctl : CT 101 : Starting container ...
2012-08-03T07:57:12-0500 vzctl : CT 101 : Container is mounted
2012-08-03T07:57:12-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-03T07:57:12-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-03T07:57:12-0500 vzctl : CT 101 : Container start failed
2012-08-03T07:57:12-0500 vzctl : CT 101 : Container is unmounted
2012-08-03T19:47:05-0500 vzeventd : Started
2012-08-03T19:47:09-0500 vzctl : Setting CPU units: 1000
2012-08-03T19:47:09-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-03T19:47:09-0500 vzctl : CT 101 : Starting container ...
2012-08-03T19:47:09-0500 vzctl : CT 101 : Container is mounted
2012-08-03T19:47:09-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-04T00:47:09+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-03T19:47:09-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-03T19:47:09-0500 vzctl : CT 101 : Container start failed
2012-08-03T19:47:09-0500 vzctl : CT 101 : Container is unmounted
2012-08-03T19:59:04-0500 vzctl : CT 101 : Destroying container private area: /vz/private/101
2012-08-03T19:59:05-0500 vzctl : CT 101 : Container private area was destroyed
2012-08-03T20:08:03-0500 vzctl : CT 101 : Creating container private area (debian-6.0-amd64-minimal)
2012-08-03T20:08:09-0500 vzctl : CT 101 : Performing postcreate actions
2012-08-03T20:08:09-0500 vzctl : CT 101 : Container private area was created
2012-08-03T20:08:09-0500 vzctl : CT 101 : Starting container ...
2012-08-03T20:08:10-0500 vzctl : CT 101 : Container is mounted
2012-08-03T20:08:10-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-04T01:08:10+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-03T20:08:10-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-03T20:08:10-0500 vzctl : CT 101 : Container start failed
2012-08-03T20:08:10-0500 vzctl : CT 101 : Container is unmounted
2012-08-03T20:08:10-0500 vzctl : CT 101 : Starting container ...
2012-08-03T20:08:10-0500 vzctl : CT 101 : Container is mounted
2012-08-03T20:08:10-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-04T01:08:10+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-03T20:08:10-0500 vzctl : CT 101 : Container start in progress...
2012-08-03T20:08:10-0500 vzctl : CT 101 : Container is not running
2012-08-03T20:08:10-0500 vzctl : CT 101 : Password change failed
2012-08-03T20:08:10-0500 vzctl : CT 101 : Unable to stop: container is not running
2012-08-03T20:08:10-0500 vzctl : CT 101 : Unable to stop: container is not running
2012-08-03T20:08:10-0500 vzctl : CT 101 : Container is currently mounted (umount first)
2012-08-03T20:22:25-0500 vzeventd : Started
2012-08-03T20:22:29-0500 vzctl : Setting CPU units: 1000
2012-08-03T20:22:29-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-03T20:22:29-0500 vzctl : CT 101 : Starting container ...
2012-08-03T20:22:29-0500 vzctl : CT 101 : Container is mounted
2012-08-03T20:22:29-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-03T20:22:29-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-03T20:22:29-0500 vzctl : CT 101 : Container start failed
2012-08-03T20:22:29-0500 vzctl : CT 101 : Container is unmounted
2012-08-03T20:35:48-0500 vzeventd : Started
2012-08-03T20:35:51-0500 vzctl : Setting CPU units: 1000
2012-08-03T20:35:51-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-03T20:35:52-0500 vzctl : CT 101 : Starting container ...
2012-08-03T20:35:52-0500 vzctl : CT 101 : Container is mounted
2012-08-03T20:35:52-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-04T01:35:52+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-03T20:35:52-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-03T20:35:52-0500 vzctl : CT 101 : Container start failed
2012-08-03T20:35:52-0500 vzctl : CT 101 : Container is unmounted
2012-08-05T23:41:59-0500 vzeventd : Started
2012-08-05T23:42:03-0500 vzctl : Setting CPU units: 1000
2012-08-05T23:42:03-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-05T23:42:03-0500 vzctl : CT 101 : Starting container ...
2012-08-05T23:42:03-0500 vzctl : CT 101 : Container is mounted
2012-08-05T23:42:03-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-06T04:42:03+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-05T23:42:03-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-05T23:42:03-0500 vzctl : CT 101 : Container start failed
2012-08-05T23:42:03-0500 vzctl : CT 101 : Container is unmounted
2012-08-06T03:38:53-0500 vzeventd : Started
2012-08-06T03:38:58-0500 vzctl : Setting CPU units: 1000
2012-08-06T03:38:58-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-06T03:38:58-0500 vzctl : CT 101 : Starting container ...
2012-08-06T03:38:58-0500 vzctl : CT 101 : Container is mounted
2012-08-06T03:38:58-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-06T08:38:58+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-06T03:38:58-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-06T03:38:58-0500 vzctl : CT 101 : Container start failed
2012-08-06T03:38:58-0500 vzctl : CT 101 : Container is unmounted
2012-08-07T00:09:31-0500 vzeventd : Started
2012-08-07T00:09:34-0500 vzctl : Setting CPU units: 1000
2012-08-07T00:09:34-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-07T00:09:34-0500 vzctl : CT 101 : Starting container ...
2012-08-07T00:09:34-0500 vzctl : CT 101 : Container is mounted
2012-08-07T00:09:34-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-07T05:09:34+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-07T00:09:34-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-07T00:09:34-0500 vzctl : CT 101 : Container start failed
2012-08-07T00:09:34-0500 vzctl : CT 101 : Container is unmounted
2012-08-10T13:21:02-0500 vzeventd : Started
2012-08-10T13:21:06-0500 vzctl : Setting CPU units: 1000
2012-08-10T13:21:06-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-10T13:21:06-0500 vzctl : CT 101 : Starting container ...
2012-08-10T13:21:06-0500 vzctl : CT 101 : Container is mounted
2012-08-10T13:21:06-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-10T18:21:06+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-10T13:21:06-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-10T13:21:06-0500 vzctl : CT 101 : Container start failed
2012-08-10T13:21:06-0500 vzctl : CT 101 : Container is unmounted
2012-08-10T13:51:09-0500 vzctl : CT 101 : Destroying container private area: /vz/private/101
2012-08-10T13:51:10-0500 vzctl : CT 101 : Container private area was destroyed
2012-08-11T05:07:33-0500 vzeventd : Started
2012-08-11T05:07:37-0500 vzctl : Setting CPU units: 1000
2012-08-11T05:07:37-0500 vzctl : WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
2012-08-11T05:34:01-0500 vzctl : CT 101 : Creating container private area (debian-6.0-amd64-minimal)
2012-08-11T05:34:07-0500 vzctl : CT 101 : Performing postcreate actions
2012-08-11T05:34:07-0500 vzctl : CT 101 : Container private area was created
2012-08-11T05:34:07-0500 vzctl : CT 101 : Starting container ...
2012-08-11T05:34:07-0500 vzctl : CT 101 : Container is mounted
2012-08-11T05:34:07-0500 vzctl : CT 101 : Warning: NUMIPTENT 0:0 is less than minimally allowable value, set to 16:16
2012-08-11T10:34:07+0000 vzctl : CT 101 : Unable to fork: Cannot allocate memory
2012-08-11T05:34:07-0500 vzctl : CT 101 : Unable to apply network parameters: container is not running
2012-08-11T05:34:07-0500 vzctl : CT 101 : Container start failed
2012-08-11T05:34:07-0500 vzctl : CT 101 : Container is unmounted
Auszug, musste doppelt posten wegen wegen der maximalen Länge von 10000 Zeichen.
 
#18
Hast Du denn genug Arbeitsspeicher im hostsystem und wieveil MB Ram hast Du dem Guest zugewiesen?
Im Hostsystem sind nur 2 GB Arbeitsspeicher, ich bin davon ausgegangen das es für zwei bis drei VPS ausreichend ist. Habe jetzt alle noch einmal gelöscht, einen neuen mit garantierten 256 MB RAM und 512 MB burstable RAM erstellt. Leider immer noch das gleiche, die Maschine an sich scheint zu laufen nur ohne jegliche Internetverbindung. Prozessor ist ein Intel Xeon X3440 (8M Cache, 2.53 GHz).

Hier die genauen Einstellungen der VPS:



Aber poste wenns geht die network parameters der vps.
Hier die /etc/network/interfaces:



Sieht so aus das es daran liegt das nur local konfiguriert ist, ich habe zwei Broadcom NetXtreme eth0 und eth1 drin. Ich würde jetzt einfach so lange Sachen eintragen bis es funktioniert, aber mit diesem Standardeditor kann ich nicht schnell gut arbeiten deswegen weiß wer was ich hier eintragen muss? 1 zu 1 das vom Hostsystem? Hatte schon VPS aber bis heute nie selbst installiert, es ging einfach.

Danke
 
Zuletzt bearbeitet:

Werbung

Top