[ISPConfig 3] erstellt keine Logs

#1
Bei einigen meiner ISPConfig 3 Installationen werden keine Logs im Ordner /log angelegt, der Ordner ist komplett leer bei allen Webs auf dem Server. Ich installiere alle Server genau gleich.

Woran kann das liegen? Suche schon seit einiger Zeit selber nach einer Lösung, aber nix gefunden bis jetzt...
 

Till

Administrator
#4
Wie hast Du denn nachgesehen, ob die Logs in dem entsprechenden Verzeichnis des webs nicht da sind? Das ist nämlich ein symlink zu dem Verzeichnis unter /var/log/ispconfig/httpd/....... Logge Dich bitte mal als root uer auf der shell ein, ge ins logs Verzeichnis des webs und rufe dann auf:

ls -lah

und poste den Output.
 
#5
Wie hast Du denn nachgesehen, ob die Logs in dem entsprechenden Verzeichnis des webs nicht da sind?
Über FTP.

Logge Dich bitte mal als root uer auf der shell ein, ge ins logs Verzeichnis des webs und rufe dann auf:

ls -lah

und poste den Output.
Komisch über die Konsole sehe ich alle Logs, also ls -lah listet alle komplett auf. Liegt dann wahrscheinlich ja an den FTP Einstellungen, ich weiß aber nicht mehr was ich bei meinen anderen Servern bezüglich FTP anders konfiguriert habe... :(
 
Zuletzt bearbeitet:

Till

Administrator
#6
Das liegt an den Rechten der Logs, die können nicht vom ftp user gelesen werden. Die rechte werden vom apache so gesetzt. Du kannst ein chmod 755 drauf machen, aber apache wird es nach einem reboot zurücksetzen.
 

Till

Administrator
#8
ISPConfig liest die Dateien als root ein und nicht als FTP User, es hat also darauf Zugriff. Du kannst Dir ja einen Cronjob bauen, das die Rechte regelmäßig ändert.
 

Werbung

Top