[ISPConfig 3] .htaccess läuft nicht mehr

#1
Habe das Web + FTP User gelöscht (wollte einfach neu beginnen). Habe jetzt in die .htaccess im root Options +Indexes rein geschrieben und die Rechte auf 644 gelegt. Vorhin ging das...
Weiß wer was da los ist? Läuft irgendwie nicht mehr, bekomme 500 Internal Server Error. Verwende ISPConfig 3 + su_php unter debian 32 bit lenny.

bekomme außerdem seit gestern das Monitor-Kästchen gleich 2 mal zu sehen:
 
Zuletzt bearbeitet:
#3
Danke. In dieser Datei steht:

Code:
[Mon Mar 30 12:35:11 2009] [alert] [client 127.0.0.1] /var/clients/client0/web4/web/.htaccess: Options not allowed here
Davor steht noch:

Code:
[Sun Mar 29 21:31:50 2009] [crit] [client 127.0.0.1] (13)Permission denied: /var/clients/client0/web4/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
Könnte das was mit meinem remoeip Apache Modul zu tun haben? 127.0.0.1 das hat er gesetzt...
 

Till

Administrator
#4
Zum einen ist Die Datei /var/clients/client0/web4/web/.htaccess laut Fehlermeldung nicht vom apache User lesbar und zweitens hat Du immer noch eine options direktive da drin stehen die Du rausnehmen musst.
 
#5
Zum einen ist Die Datei /var/clients/client0/web4/web/.htaccess laut Fehlermeldung nicht vom apache User lesbar und zweitens hat Du immer noch eine options direktive da drin stehen die Du rausnehmen musst.
Stimmt ja Options +Indexes ist ja schon die Vorgabe glaub ich deswegen der Fehler... aber habe keine Ahnung warum Apache die Datei nicht lesen kann, vielleicht eine Idee? Beim anderen Web geht's soweit ichs sehen konnte
 

Till

Administrator
#6
Mach mal ein chmod 755 auf die Datei. Außerdem lösche das Options +Indexes ausder datei und füge es im apache direktiven Feld ein. Sowas wie Options +Indexes hat in einer .htaccess nichts zu suchen, zumindest nicht wenn man den Server nicht so weit aufmachen will dass ale user und Hacker beliebige Dinge darauf ausführen können.
 
#7
Mach mal ein chmod 755 auf die Datei. Außerdem lösche das Options +Indexes ausder datei und füge es im apache direktiven Feld ein. Sowas wie Options +Indexes hat in einer .htaccess nichts zu suchen, zumindest nicht wenn man den Server nicht so weit aufmachen will dass ale user und Hacker beliebige Dinge darauf ausführen können.
Okay thx, scheint zu gehen. Wo kann man sowas nachlesen wie z.B. das man Options +Indexes nicht direkt in eine .htaccess machen soll sondern ins direktiven Feld machen sollte? Finde zu solchen .htaccess-Sachen nur schwer Infos, würde eben gern darüber mehr wissen was man besser lassen sollte.

Erstmal dankeschön :)
 

Werbung

Top