ISPconfig 3 /ispconfig oder ispconfig.domain.de

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von limbotec, 11. Apr. 2013.

  1. limbotec

    limbotec New Member

    Hallo,

    wie der Titel schon sagt suche ich eine Lösung für ISPConfig 3.

    Da in den meisten Firmennetzwerken die Ports 8080 oder 81 gesperrt sind, möchte ich das Webinterface über ispconfig.domain.tld oder über www.domain.tld/ispconfig/ aufrufen können.

    Folgendes hat mir nicht geholfen per mod_proxy:
    oder per httpd.conf

    Mein ISPConfig Verzeichnis liegt in:
    /usr/local/ispconfig/interface/web

    Ich verwende Debian Squeeze (Apache2, PHP5, MySQL) und ISPConfig 3


    Jemand eine Lösung für beide oder eins meiner Probleme? ;)
     
  2. nowayback

    nowayback Well-Known Member

    ungetestet:

    Code:
    <VirtualHost IP:80>
        ServerName ispconfig.example.com
      
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
      
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
      </IfModule>
      
      
      ServerSignature Off
      
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
      SSLEngine On
      SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
      SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
      SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    
      <Directory /var/www/php-fcgi-scripts>
         AllowOverride None
         Order Deny,Allow
         Deny from all
      </Directory>
    
    </VirtualHost>
    
     
  3. limbotec

    limbotec New Member

    Problem noch nicht gelöst

    Das bringt mir die Standard-Apache Seite:
    Der Vorschlag gleicht sehr dem Inhalt meiner folgenden Datei:
    /etc/apache2/sites-enabled/000-ispconfig.vhost
    bis auf das die Ports von 8080 auf 80 geändert wurden
     

Diese Seite empfehlen