ISPConfig 3 remoting - Verzeichnisse werden nicht angelegt

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von thelion, 24. März 2012.

  1. thelion

    thelion New Member

    Hallo Till,

    ich bin kurz vor der Verzweiflung.

    Nachdem das Connect mit soap geklappt hat, dachte ich mir installiere ich das System nochmal ganz neu, da ich ja vorher bereits manuell in die DB geschrieben habe.

    Jetzt habe ich das Problem, dass die Verzeichnisse, für die User die ich über die api anlege, erst angelegt werden, wenn ich über das Webinterface den Emailkaccount aufrufe und neu abspeichere. Auch ohne Änderungen.

    In /var/vmail/mailfilter hingegen werden die User angelegt.

    /var/vmail/domain/username fehlt
    /var/vmail/mailfilters/domain/username wird korrekt angelegt.

    Ich habe schon alles ausprobiert.

    postfix in der mail_user_add.php ist auf y gesetzt.

    IP<->Domainname in der soap config
    32<->64 bit debian
    mit und ohne ssl
    ispconfig neu ohne ssl installiert.
    mail_user_app.php von der console aus aufgerufen
    server.php manuell gestartet -> da kommt nur finished
    remoteuser mit den gleichen daten wie ein kunde angelegt.

    Kannst Du mir vieleicht sagen wo ich da noch ansetzen kann?
    ich habe ja nichts geändert sondern ein ganz neu installiertes debian 6 verwendet wie in der perfekt server mit courier und postfix beschrieben ist.

    Gibt es die Möglichkeit ein Debugging einzuschalten? In der
    /interface/lib/classes/remoting_lib.inc.php habe ich auch versucht durch debug=1; mehr infos zu bekommen ohne Erfolg.

    Ich weiss nicht mehr weiter.

    An den Verzeichnisrechten kann es doch eigentlich nicht liegen da der/die User unter mailfilters ja angelegt werden und wie gesagt beim manuellen Speichern auch angelegt wird.

    Wäre echt nett wenn Du mir weiterhelfen kannst. Ich rödel jetzt seit fast 3 Tagen und Nächten an dem Pröblem und zig Neuinstallationen gemacht.

    Grüße
     
  2. Till

    Till Administrator

    Wie man debugging einschaltet steht in der ispconfig faq. Ansonsten ist es sinnvoll dass du einfach mal den eintrag den du per api in der mail_user tabelle anlegst mit einem eintrag den du über das interface anlegst zu vergleichen und dann die parameter in deinem api entsprechend anzupassen.
     

Diese Seite empfehlen