ispconfig 3 ubuntu 11.10 dovecot statt courier

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von goddi, 27. Apr. 2012.

  1. goddi

    goddi New Member

    Hallo !

    Ich hab aktuelle ipsconfig 3 auf ubuntu 11.10 nach der ubuntu 11.10 Anleitung von howtoforge installiert. Geht ja viel ganz gut. Wollt nun auf meinem ansonsten prima funktionierenden CMS das Kontaktformular ausfüllen. Klappt, aber kommt nix an.
    Nachdem ich meine mail.msg bißchen analysiert habe (connect to private/auth failed) komm ich zum Schluß, daß ich zwar nach der Anleitung postfix und courier installiert habe, postfix aber dovecot erwartet(config). Courier läuft, dovecot nicht. Nun weiß ich nicht recht, was ich tun soll.
    Courier oder dovecot? Und wie dann weiter? Am liebsten das was einfacher ist.
     
  2. Till

    Till Administrator

    Du solltest nicht von courier auf dovecot umstellen sondern stattdessen lieber die Konfiguration in der main.cf anpassen.

    Poste bitte mal die Ausgabe von:

    which dovecot

    und den Inhalt der Postfix main.cf Datei.
     
  3. goddi

    goddi New Member

    Hallo !

    Besser Dovecot nehmen ... ok ... scheint das neuere zu sein.
    Sieht so aus, als ob ich nur dovecot starten, courier stoppen und squirrelmail umstellen müßte ?! :eek:

    Der output von which dovecot ist:

    main.cf ist
     
  4. Till

    Till Administrator

    Ok, das problem ist dass Du dovecot und courier zusammen installiert hast, es darf aber nur eines von beiden installiert sein. Hast Du bereits mailboxen auf dem Server angelegt und genutzt?
     
  5. goddi

    goddi New Member

    Na so was. Hab mir schon überlegt, wie das zustande gekommen sein soll. Hier könnte eine Rolle spielen, daß ich erst mal Ubuntu Server 11.10 mit fast allem installiert habe und erst einen Tag später ispconfig 3 "gefunden" hab und der Anleitung gefolgt bin.

    Der Server ist quasi jungfräulich und da ist keine mailbox genutzt, weil ja nicht funktioniert, denk ich.

    Wär auch denkbar den ganz neu aufzusetzen, genau nach Anleitung. Aber ich denk ich lern mehr zu, wenn ich den jetzt zum Laufen bringe. Auf jeden Fall würde mir das eine Nacht Arbeit sparen. Das CMS war ja auch nicht ohne. (mod_fcgid MaxRequestLen von default 130000 Byte auf 2MB und open_basedir restriction wegen Zugriff auf /tmp ... ich hab das schreibbar für alle gemacht. Ob das sicher ist?)

    Ich find das toll, daß einem hier so schnell seelischer Beistand und KnowHow gewährt wird!
     
  6. Till

    Till Administrator

    Versuch mal bitte folgendes, stoppe alle courier daemons, also courier-authdaemon, courier-pop, courier-pop-ssl,courier-imap und courier-imap-ssl aund dann starte dovecot und versuch Dich einzuloggen. Mit ein wenig Glück wurde bereits alles korrekt vom ISPConfig Installer konfiguriert und es ist jetzt nur der falsche Daemon gestartet.

    Eine Änderung am open_basedir sollte an sich nicht notwendig sein, da dort bereits alle Verzeichnisse drin sind auf die eine Webseite zugreifen können sollte. Jede Seite hat auch ein eigenes temp Verzeichnis was auch in PHP voreingestellt ist, das Globale /tmp solltest Du möglichst nicht nutzen.

    Das mit mod_fcgid MaxRequestLen steht auch im ISPConfig FAQ, ich weiß nicht warum die Debian Entwickler das auf einmal geändert haben, denn mit den Defaults läuft fast keine aktuelles CMS mehr.
     
  7. goddi

    goddi New Member

    Hallo!
    Ich geb hier zu, daß ich nicht der Linux Crack bin. Ich denk, ich deinstalliere courier mit apt-get courier remove oder so ähnlich und installier den dovecot(Taubenschlag) noch mal drüber.
    ?? Mit bißchen Glück .....

    mir war auch nicht so wohl dabei. M... eigentlich sollte wohl jeder virtuelle host sein eigenes temp haben? Das globale /tmp war ja vorher im Besitz von root - und jetzt dürfen quasi alle drauf schreiben (sog. workarround)
    Das war bei mir wohl nicht voreingestellt, weil nicht funktioniert, weiß auch nicht wie die Einstellung sein muß, in PHP.

    Ich glaube, da hab ich den Hinweiß auch gefunden.
    Dieses howtoforge ist schon sehr hilfreich. :)
     
  8. Till

    Till Administrator

    Dovecot nochmal drüber installieren bringt nichts, das würde nur die Installation die ISPConfid´g dafür angelegt hat wieder überschreiben so dass dann nichts geht.

    Versuch mal:

    /etc/init.d/courier-authdaemon stop
    /etc/init.d/courier-pop stop
    /etc/init.d/courier-pop-ssl stop
    /etc/init.d/courier-imap stop
    /etc/init.d/courier-imap-ssl stop

    dann

    /etc/init.d/dovecot start

    und dann versuch mal ob smtp-auth und pop3 oder imap geht.
     
  9. goddi

    goddi New Member

    Hallo!

    Tja hm. Ich hab die prozesse alle gekillt und dovecot gestartet, aber wenn ich das -ps-eal such, ist es nicht da. (die Fehlermeldungen bleiben) Scheint nicht zu starten.

    Ich denke, ich mach das nun so, daß ich courier deinstalliere, und dovecot neu installiere.

    Dann gibt klare Verhältnisse und ich kann zwischendurch mal booten.

    Vielen Dank für die Hilfe, vorab!
    Ich untersuch das jetzt mal näher.
    Da gibt es ja paar threads zum Umstieg von von courier auf dovecot.
     
  10. goddi

    goddi New Member

    Schön guten Morgen! Tja ... wenn dem Esel zu gut geht begibt er sich auf's Eis.



    So, hab nun courier deinstalliert und dovecot war eh schon drauf. Ich hab herausgefunden, daß dovecot nicht startbar war,
    [fail] bein booten
    weil ich beim Rumsuchen wo die pipe auth denn wäre eine Änderung gemacht hatte, die im Internet empfohlen war. Nachdem ich die rausgemacht habe, schmiert dovecot bißchen anders ab und zwar mit

    [ok] beim booten

    selber gefunden: hab unterlassen dovecot-imapd und dovecot-pop3d dovecot-mysql zu installieren.

    Hm ... syslog sieht schon relativ interessant aus.

    selber gefunden: dovecot-sieve mußt ich auch noch installieren.

    Nun ist soweit, daß eigentlich alles ganz nett ausschaut aber mails von www-data nicht intern und mails von z.B squirrel mail nicht nach extern ausgeliefert werden können.

    z.B meint mein provider, daß ich behaubte ich wär er.

    Da sind also zwei verschiedene Sachen
    1.) www-data mag nicht an z.B local.root ausliefern
    2.) mein Provider ziert sich. Hab ja auch keinen "smart-host" eingerichtet. Muß ich wohl !?
     
    Zuletzt bearbeitet: 28. Apr. 2012
  11. Till

    Till Administrator

    Trrag mal bitte in die Datei /etc/mailname ein:

    gottfried-faass.dyndns.org

    und starte dann postfux neu.

    Wenn Du den Server an einer ADSL Leizung oder ähnlichem betreibst musst Du einen Smarthost angeben, das geht in ISPConfig unter System > Serverkonfiguration > Mail
     
  12. goddi

    goddi New Member

    Ist ja eher ein Spielteil zwecks Studium. Also 2000 er DSL.
    Tja ... werd ich dann so machen, mit dem Smarthost.
    Ui ! Das kann man mit ISPConfig einstellen !?

    Danke für die Hilfe, bisher !
     
  13. goddi

    goddi New Member

    Hallo!

    Hab doch noch so ein Anfängerproblem.
    Wenn ich nun eine meiner mailadressen als smarthost eintrage, kommt

    ... wo ich mich doch mit Benutzername und Kennwort einlogge.

    Da überleg ich mir nun, ob ich meinen Server auf eine meiner Domains umbenenne - in hostname und hosts ...
    oder ob ich beim Absender Strato vorflunkern kann, daß ich meine domain wäre. Schließlich bin ich doch ich.

    Kann man wo (elegant) die "Absenderadresse" einstellen?
    (Ich hätt nie versucht den Smarthost in ISPConfig zu konfigurieren, ich hätt nach dem alten Postfixbuch gewühlt)

    :))
     
  14. Till

    Till Administrator

    Die Absenderadresse wird durch den mailclient, also nicht durch ispconfig.
     
  15. goddi

    goddi New Member

    Schön Abend auch!

    klappt natürlich mit etc/mailname.

    Nachdem ich also gottfried-faass.de (eine meiner strato-domains) in /etc/mailname angegeben hatte und www-data@gottfried-faass.de als mailadresse bei Strato eingerichtet habe,
    krieg ich post von der website (Kontaktformular) und von root.

    Soweit, so gut!
     
    Zuletzt bearbeitet: 1. Mai 2012

Diese Seite empfehlen