ISPConfig 3 url verstecken

Dieses Thema im Forum "Tipps - Tricks - Mods" wurde erstellt von ubuntu, 24. Aug. 2010.

  1. ubuntu

    ubuntu New Member

    hiho liebe leute ich hätte da eine frage unszwar geht es darum um url zu "verstecken"
    also das da z.b. nicht www.domain.de/bilder/logo.gif steht sonder das da immer www.domain.de steht.
    ich habe gelsen das man dieses problem mit "frames" umgehen kann. das möchte ich aber nicht.
    ich habe auch gelesen das es mit rewrite klappt.
    habe ich auch probiert.
    wenn ich dann meine domain aurufen wollte bekam ich immer die fehler meldung das die umleitung nie benndet werden kann.
    in der adressleiste stand dann www.domain.de/var/clients/clinte0/web3/ und das x mal...
    jetzt wollte ich euch fragen wie ich das richtig einstellen kann?
    ich habe das rewrite befehl unter "Sites -> domain -> option -> Apach Option" eingegeben.
    ich hatte dieses rewrite befehl verwendet

    RewriteEngine on"
    RewriteRule (.*)\.(php|htm|html|cgi|txt)$ http://www.domain.de
     
  2. Till

    Till Administrator

    Das ist auch richtig. Der Fehler wird in der rewrite rule liegen und nicht bei ispconfig, da ispconfig Deine rewrite Rule ja einfach unverändert in den vhost schreibt.

    Was auf jeden Fall nicht korrekt ist ist das " nach dem on.
     
  3. ubuntu

    ubuntu New Member

    okay habe jetzt das " weg gemacht aber jetzt bekomme ich halt wie beschrieben noch immer die selbe fehler meldung.
     
  4. Till

    Till Administrator

    Und Du bist ganz sicher dass Du keine anderen Rewrite rules im gleichen web verwendest? Poste mal die komplette vhost Datei.
     
  5. ubuntu

    ubuntu New Member

    hiho hoffe das ist das richtige^^

    <VirtualHost *:80>^M
    DocumentRoot /var/www/abc.de/web^M
    ^M
    ServerName abc.de^M
    ServerAlias *.abc.de^M
    ServerAdmin abc@abc.de^M
    ^M
    ErrorLog /var/log/ispconfig/httpd/abc.de/error.log^M
    ^M
    ErrorDocument 400 /error/400.html^M
    ErrorDocument 401 /error/401.html^M
    ErrorDocument 403 /error/403.html^M
    ErrorDocument 404 /error/404.html^M
    ErrorDocument 405 /error/405.html^M
     
    Zuletzt bearbeitet: 25. Aug. 2010
  6. Till

    Till Administrator

    Das ist das template für alle webseiten und nicht die vhost datei. Die vhost datei findest Du im apache Konfigurationsverzeichnis, unter debian ist das z.B. /etc/apache2/sites-enabled/
     
  7. ubuntu

    ubuntu New Member

    wenn ich einfach die ip adresse eingebe satt den domian namen dann klappt es dann sehe ich von apache die seite wo steht "its work"
    aber so bald ich die domian eingebe klappt es nicht
     
  8. Till

    Till Administrator

    Du musst schon die ganze Datei posten, damit ich Dir helfen kann.
     
  9. ubuntu

    ubuntu New Member

    *peinlich*
    sorry

    <Directory /var/www/abc.de>^M
    AllowOverride None^M
    Order Deny,Allow^M
    Deny from all^M
    </Directory>^M
    ^M
    <VirtualHost *:80>^M
    DocumentRoot /var/www/abc.de/web^M
    ^M
    ServerName abc.de^M
    ServerAlias *.abc.de^M
    ServerAdmin abv@abc.de^M
    ^M
    ErrorLog /var/log/ispconfig/httpd/abc.de/error.log^M
    ^M
    ErrorDocument 400 /error/400.html^M
    ErrorDocument 401 /error/401.html^M
    ErrorDocument 403 /error/403.html^M
    ErrorDocument 404 /error/404.html^M
    ErrorDocument 405 /error/405.html^M
    ErrorDocument 500 /error/500.html^M
    ErrorDocument 503 /error/503.html^M
    ^M
    <Directory /var/www/abc.de/web>^M
    Options FollowSymLinks^M
    AllowOverride Indexes AuthConfig Limit FileInfo^M
    Order allow,deny^M
    Allow from all^M
    </Directory>^M
    <Directory /var/www/clients/client0/web4/web>^M
    Options FollowSymLinks^M
    AllowOverride Indexes AuthConfig Limit FileInfo^M
    Order allow,deny^M
    Allow from all^M
    </Directory>^M
    ^M
    # cgi enabled^M
    <Directory /var/www/clients/client0/web4/cgi-bin>^M
    Order allow,deny^M
    Allow from all^M
    </Directory>^M
    ScriptAlias /cgi-bin/ /var/www/clients/client0/web4/cgi-bin/^M
    AddHandler cgi-script .cgi^M
    AddHandler cgi-script .pl^M
    # suexec enabled^M
    SuexecUserGroup web4 client0^M
    # php as fast-cgi enabled^M
    <Directory /var/www/abc.de/web>^M
    AddHandler fcgid-script .php .php3 .php4 .php5^M
    FCGIWrapper /var/www/php-fcgi-scripts/web4/.php-fcgi-starter .php^M
    Options +ExecCGI^M
    AllowOverride all^M
    Order allow,deny^M
    Allow from all^M
    </Directory>^M
    ^M
    RewriteEngine on^M
    RewriteCond %{HTTP_HOST} ^abc.de [NC]^M
    RewriteRule ^/(.*)$ /var/www/clients/client0/web4/$1 [R,L]^M
    ^M
    RewriteEngine on
    RewriteRule (.*)\.(php|htm|html|cgi|txt)$ http://91.121.***.***^M
    </VirtualHost>^M
    ^M
    ^M
    ^M
     
    Zuletzt bearbeitet: 25. Aug. 2010
  10. Till

    Till Administrator

    Du hast da ja bereits eine andere rewrite rule aktiviert. schalte die mal in den web einstellungen aus.
     
  11. ubuntu

    ubuntu New Member

    habs ausgeschaltet aber es kommt noch immer zu einer weiterlungs fehler....
    aber auf google kann ich umleiten^^
     
  12. ubuntu

    ubuntu New Member

    ich habe mal ne bissel rum gesucht
    da schoss mir die frage durch den kopf ob ich mein problem nicht mit .htaccess lösen könnte?
    eig. möchte ich doch nur
    das wenn jmd z.b. www.abc.de/ordner/index.php eingibt erst auf www.abc.de/index.html landet.
     
  13. Till

    Till Administrator

    Das machst Du doch gerade schon. ob du eine rewrite rule in das apache direktiven feld schreibst es in eine .htaccess macht keinen Unterschied in der Funktionsweise.
     
  14. ubuntu

    ubuntu New Member

    hhmm ... ^^
    okay sorry
     
  15. Till

    Till Administrator

    Da muss noch ein Fehler in Deiner rewrite rule sein. Poste doch bitte mal die Seite, wo Du die role her hst. Meines Wissens nach verwiesen solche Rules normalerweise auf eine Datei bzw. eine Verzeichnis und nicht eine URL, denn in Deiner aktuellen Rule sehe ich nicht so wirklich den Sinn.
     
  16. ubuntu

    ubuntu New Member

Diese Seite empfehlen