ISPConfig (Apache 1.3.41) mit ZLIb

#1
Hallo,

laut meiner PHPInfo vom ISPConfig Webinterface, ist kein ZLIb konfiguriert, das bräuchte ich aber, wie kann ich das hinzukompilieren?

Code:
Configure Command  './configure' '--with-apxs=/root/ispconfig/httpd/bin/apxs' '--enable-track-vars' '--enable-sockets' '--enable-mbstring=all' '--with-config-file-path=/root/ispconfig/php' '--enable-ftp' '--prefix=/root/ispconfig/php' '--with-openssl=/root/ispconfig/openssl' '--with-mysql=/usr' '--without-pear'
In der compile Datei stehen zwar die aufrufe, aber anscheinend wird der pfad nicht gesetzt.
 

Till

Administrator
#2
Eigentlich sollte er zlib mit einkompileieren, wenn die zlib development Dateien der Linuxdistribution installiert sind. Wenn er die bei Dir nicht findet, versuch am besten mal wie Du bereits vorgeschlagen hast, den Pfad für zlib in der compile Datei neu zu setzen.

Wenn Du nicht den ganzen installer neu laufen lassen möchtest, sollte es generell auch möglich sein, nur php neu von hand zu kompilieren, solange Du die gleichen Optionen wie im compile script nimmst.

Sicherheitshalber einfach /root/ispconfig vorher sichern und bei einem Kompilierfehler wieder herstellen.
 
#3
Habe das kompilieren mit folgendem Aufruf versucht:

Code:
./configure --with-apxs=/root/ispconfig/httpd/bin/apxs --enable-track-vars --enable-sockets --enable-mbstring=all --with-config-file-path=/root/ispconfig/php --enable-ftp --prefix=/root/ispconfig/php --with-openssl=/root/ispconfig/openssl --with-mysql=/usr --disable-libxml --disable-dom --disable-xml --disable-xmlreader --disable-xmlwriter --disable-simplexml --with-zlib-dir=/usr/lib64 --without-pear
Leider erhalte ich den fehler:

Sorry, I was not able to successfully run APXS. Possible reasons:

1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of /root/ispconfig/httpd/bin/apxs follows
apxs:Error: /root/ispconfig/httpd/bin/httpd not found or not executable
configure: error: Aborting
Anscheinend wird bei DEBIAN kein zlib mit kompiliert - oder ich finde den korrekten aufruf nicht!


Hast du eine Idee?
 

Till

Administrator
#4
Bist Du sicher dass Du die zlib Development libraries installiert hast? Dann sollte es eigentlich ohne Pfadangabe gehen. Ich weiß leider auch nicht den genauen Namen des Paketes, könnte libzzip-dev oder zlibc sein.

Poste bitte mal die Ausgabe von:

ls -la /root/ispconfig/httpd/bin/httpd

Du hast das Ganze doch als toot User gemacht, oder?
 

Werbung

Top