ISPConfig aufruf von Webmail= application/x-httpd-php

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von dakleine1981, 9. Juli 2013.

  1. dakleine1981

    dakleine1981 New Member

    Hallo,

    habe eine Ubuntu Server 12.1 mit ISPConfig 3, auf die Config Oberfläche von ISPConfig komme ich, habe zusätzlich Squirrelmail installiert.
    Rufe ich nun die Seite http://meineIP/webmail auf, bekomme ich ein Fenster mit Datei Speichern oder Ausführen: application/x-httpd-php
    Ich finde diesen Fehler nicht :(

    LG

    David
     
  2. dakleine1981

    dakleine1981 New Member

    Bei phpmyadmin kommt das selbe
     
  3. Till

    Till Administrator

    Schau mal in die perfect setup anleitung ob due squirrelmail exakt so installiert hast wie es dort beschrieben ist.
     
  4. dakleine1981

    dakleine1981 New Member

    ja hab ich
     
  5. Till

    Till Administrator

    Poste mal Deine apache squirrelmail.conf Datei und stell sicher dass apache mod_pho installiert und aktiviert ist wie im perfect setup beschrieben.
     
  6. dakleine1981

    dakleine1981 New Member

    Alias /squirrelmail /usr/share/squirrelmail
    Alias /webmail /usr/share/squirrelmail

    <Directory /usr/share/squirrelmail>
    Options FollowSymLinks
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    php_value include_path .
    php_admin_value upload_tmp_dir /var/lib/squirrelmail/tmp
    php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname
    php_flag register_globals off
    </IfModule>
    <IfModule mod_dir.c>
    DirectoryIndex index.php
    </IfModule>

    # access to configtest is limited by default to prevent information leak
    <Files configtest.php>
    order deny,allow
    deny from all
    allow from 127.0.0.1
    </Files>
    </Directory>

    # users will prefer a simple URL like http://webmail.example.com
    #<VirtualHost 1.2.3.4>
    # DocumentRoot /usr/share/squirrelmail
    # ServerName webmail.example.com
    #</VirtualHost>

    # redirect to https when available (thanks omen@descolada.dartmouth.edu)
    #
    # Note: There are multiple ways to do this, and which one is suitable for
    # your site's configuration depends. Consult the apache documentation if
    # you're unsure, as this example might not work everywhere.
    #
    #<IfModule mod_rewrite.c>
    # <IfModule mod_ssl.c>
    # <Location /squirrelmail>
    # RewriteEngine on
    # RewriteCond %{HTTPS} !^on$ [NC]
    # RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI} [L]
    # </Location>
    # </IfModule>
    #</IfModule>
     
  7. dakleine1981

    dakleine1981 New Member

    a2enmod php5
    Module php5 already enabled
     
  8. dakleine1981

    dakleine1981 New Member

    Also was ich bekomme wenn ich den Apache neu starte:

    [Tue Jul 09 12:30:26 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Tue Jul 09 12:30:26 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    ... waiting [Tue Jul 09 12:30:27 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Tue Jul 09 12:30:27 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    [ OK ]

    Ist das so korrekt?
     
  9. Till

    Till Administrator

    Ja, das ist in Ordnung.
     
  10. Till

    Till Administrator

  11. dakleine1981

    dakleine1981 New Member

    hab das ganze jetzt mal mit Ubuntu 11.1 installiert. Da funktioniert es ohne Probleme
     
  12. F4RR3LL

    F4RR3LL Member

    Releases

    Support ausgelaufen ... keine gute Idee....


    Gruß Sven
     

Diese Seite empfehlen