ISPConfig - Der angegebene MySQL-Server kann nicht erreicht werden!

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von wiseguy, 25. Nov. 2008.

  1. wiseguy

    wiseguy New Member

    Hallo,

    ich habe mein System nach diesem Howto installiert (allerdings ohne die quotas im Dateisystem einzubinden - aber das sollte hier nicht von belang sein).

    Nun hab ich ISPConfig 2 stable installiert:Nach einigen Abfragen komme ich zu der Abfrage
    Code:
    Wie heisst der MySQL-Server?
    ich gebe localhost ein und erhalte dann diesen Fehler:
    Code:
    Der angegebene MySQL-Server kann nicht erreicht werden!
    Obwohl ich aber mit mysql -h localhost -u root -p auf mysql zugreifen kann...

    Im Grunde ist der Fehler hier schonmal beschrieben worden, aber da ist man zu keiner Lösung gelangt.

    Weiß vielleicht mittlerweile hier jemand Rat?
     
  2. wiseguy

    wiseguy New Member

    Ich hab jetzt noch einiges Probiert:
    • in der /etc/mysql/my.cnf die Zeile bind-address = 127.0.0.1 wieder aktiviert -> Leider kein Erfolg
    • statt localhost hab ich 127.0.0.1 angegeben -> Leider kein Erfolg
    • statt localhost den Host bzw. Domainnamen angegeben
      • Ich kann nun mySQL Benutzer angeben (root)
      • Ich kann nun Passwort angeben -> kein Zugriff
    Das ist die Ausgabe:
    Code:
    Wie heisst der MySQL-Server?[B]meinedomain.de[/B]
    OK
    Wie heisst der MySQL-User?[B]root[/B]
    Wie heisst das MySQL-Passwort?
    ERROR 1045 (28000): Access denied for user 'root'@'meinedomain.de' (using password: YES)
    Ihr MySQL-Passwort ist falsch!
    Das Passwort enthält Sonderzeichen, aber deshalb habe ich es auch mal in dieser Form eingegeben: 'passwort'

    Ganz abgesehen davon: Lieber wäre mir für das ISPConfig einen extra Benutzer zu verwenden (und nicht root). Ist das bedenkenlos möglich oder will ISPConfig unbedingt root sein?
     
  3. wiseguy

    wiseguy New Member

    So ich habs jetzt mal auf biegen und brechen durchgeführt. Komme aber jetzt leider nicht auf der Weboberfläche durch den ISPConfig Login.

    Folgendes hab ich gemacht:
    • neuen mySQL User ispconfig angelegt
    • mit GRANT ALL ON *.* TO 'ispconfig'@'localhost'; diesen zum Admin gemacht
    • ispconfig Setup zu ende geführt:
      Code:
      ...
      Wie heisst der MySQL-Server?[B]meinedomain.de[/B]
      OK
      Wie heisst der MySQL-User?[B][COLOR=Blue]ispconfig[/COLOR][/B]
      Wie heisst das MySQL-Passwort?
      OK
      Vergeben Sie einen Namen für die ISPConfig-Datenbank (z.B. db_ispconfig):[B]db_ispconfig[/B]
      Geben Sie die IP-Adresse des ISPConfig-Webs an (z.B. 192.168.0.1):[B]xx.xx.xx.xx[/B]
      OK
      Geben Sie den Host-Namen an (z.B. www):[B]www[/B]
      Geben Sie die Domain an (z.B. xyz.de):[B]meinedomain.de[/B]
      OK
      Bitte wählen Sie aus, über welches Protokoll (http oder https (SSL-Verschlüsselung)) Ihr ISPConfig-System erreichbar sein soll:
      1) HTTPS
      2) HTTP
      Ihre Wahl: [B]1[/B]
      
      Connected successfully to MySQL server
      ERROR 1044 (42000): Access denied for user 'ispconfig'@'%' to database 'db_ispconfig'
      [COLOR=Red]no crontab for root[/COLOR]
      postmap: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
      postmap: warning: inet_protocols: configuring for IPv4 support only
      Neustart einiger Dienste...
      Stopping Postfix Mail Transport Agent: postfixpostfix: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
      postfix: warning: inet_protocols: configuring for IPv4 support only
      .
      Starting Postfix Mail Transport Agent: postfixpostfix: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
      postfix: warning: inet_protocols: configuring for IPv4 support only
      .
      Stopping ftp server: proftpd.
      Starting ftp server: proftpd.
      Starting ISPConfig system...
      /root/ispconfig/httpd/bin/apachectl startssl: httpd started
      
      Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
      No results found!ISPConfig system is now up and running!
      Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert. Falls Sie Quota nachinstalliert haben, fuehren Sie noch die in der Installationsanleitung beschriebenen Schritte durch. Ansonsten ist Ihr System jetzt ohne Reboot einsatzbereit.
      Bitte gehen Sie mit Ihrem Browser auf
      
      https://www.meinedomain.de:81
      
      und loggen sich ein:
      Benutzername: admin
      Passwort: admin
    Wie gesagt, Login geht dann nicht mit Username admin und Passwort admin.
    Ich denke das könnte alles noch an dem mysql Problem hängen.

    Das System, so wie es jetzt ist, muss ich eh nochmal neu installieren (weil ich nicht so ein gefrickeltes System haben möchte und es kein Problem ist, die Schritte die schonmal liefen wieder nachzuholen...)

    Was mich übrigens auch stutzig macht ist folgende Ausgabe bei netstat -tap:
    Code:
    # [B]netstat -tap | grep mysql[/B]
    tcp        0      0 meinedomain.:mysql *:*                     LISTEN     28258/mysqld
    richtig hätte aber diese Ausgabe gezeigt werden müssen:
    Code:
    tcp        0      0 *:mysql                 *:*                     LISTEN     3281/mysqld
     
    Zuletzt bearbeitet: 26. Nov. 2008
  4. Till

    Till Administrator

    1) Das Passwort sollte keine Sonderzeichen enthalten, die auf der Shell interpretiert werden können.
    2) Der mysql User muss der root User sein oder aber identische Rechte wie der root user haben. Du wirst ISPConfig nochmal neu installieren müssen. Zu löschen:

    /etc/init.d/ispconfig_server stop
    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    und dann noch die mysql DB löschen. Es derf keine Datenbank mit dem Namen geben, die Du für ISPConfig verwendest, da der installer sie selbst anlegt.
     
  5. wiseguy

    wiseguy New Member

    Okay, habe ich nicht mit
    Code:
    mysql> [B]GRANT ALL ON *.* TO '[COLOR=Blue]ispconfig[/COLOR]'@'localhost';[/B]
    dem user ispconfig quasi Root-Rechte gegeben?
     
  6. wiseguy

    wiseguy New Member

    Egal, hab also root User genommen...
     
  7. rawe28

    rawe28 New Member

    Ist exakt richtig, was Till gesagt hat. Hatte das Problem auch schon. Der springende Punkt ist, daß man vergißt, die Datenbank auch zu löschen und denn loopt nix.

    Gruß

    Ralph
     

Diese Seite empfehlen