ISPConfig – Error 500 Internal Server Error

Dieses Thema im Forum "Server Administration" wurde erstellt von wasdim, 2. Juni 2016.

  1. wasdim

    wasdim Member

    Hallo Forum und Danke vorab für die Hilfe
    Gemäss dieser Anleitung wurde der Server Installiert:
    The Perfect Server - Ubuntu 14.04 (Apache2, PHP, MySQL, PureFTPD, BIND, Dovecot, ISPConfig 3)
    Nun bekomme ich beim Hochladen über Contao diese Fehlermeldung.
    Ich habe danach gegoogelt und bin auf eine Lösung gestossen.
    Bevor ich was falsch mache möchte ich eure hilfe in anspruch nehmen.
    Error message :
    ERROR 500 - Internal Server Error!
    The following error occurred:
    The requested URL caused an internal server error.
    If you get this message repeatedly please contact the webmaster.
    Um das Problem zu lösen muss in dem Verzeichnis:
    Code:
    etc/apache2/mods-available/fcgid.conf
    
    AddHandler fcgid-script .fcgi
    FcgidConnectTimeout 20
    MaxRequestLen 15728640
    Wenn ich das nun mache kann ich es nicht Speichern.
    Was mache ich Falsch!
     
  2. Till

    Till Administrator

    Stell sicher dass Du die Datei als root editierst.
     
  3. wasdim

    wasdim Member

    Hallo Till Danke für deine Antwort bin als sudo su - angemeldet
     
  4. wasdim

    wasdim Member

    Tja ist ja klar wieso das es nicht geht.
    Das Verzeichnis ist nicht vorhanden.
    Also habe ich was falsch bei der Installation gemacht?
    Wie kann ich das nun machen das ich dieses verzeichnis bekomme und nuzen kann?
     
  5. wasdim

    wasdim Member

    Habe nun was gefunden hoffe ihr könnt mir diese Anleitung bestätigen das die mit meiner Konfiguration geht:
    1. Die sources.list überprüfen:
    Code:
    sudo nano /etc/apt/sources.list
    
    deb http://mirrors.digitalocean.com/ubuntu trusty main
    
    deb http://mirrors.digitalocean.com/ubuntu trusty-updates main
    
    deb http://security.ubuntu.com/ubuntu  trusty-security main
    falls nötig diese änderungen vornehmen:
    Code:
    deb http://mirrors.digitalocean.com/ubuntu trusty main multiverse
    
    deb http://mirrors.digitalocean.com/ubuntu  trusty-updates main multiverse
    
    deb http://security.ubuntu.com/ubuntu  trusty-security main multiverse
    2. Das Packet neu laden:
    Code:
    sudo apt-get update
    3. Das Packet Installieren:
    Code:
    sudo apt-get install libapache2-mod-fastcgi
    Ich bitte um eine kleine kurze bestätigung ob das so richtig ist.
    Danke Forum
     
  6. JeGr

    JeGr Member

    Dann hast du dich schlicht nicht ans Howto gehalten:
    https://www.howtoforge.com/perfect-...hp-mysql-pureftpd-bind-dovecot-ispconfig-3-p3
    Hier ist extra die Konfiguration für die APT Settings definiert. Da du wohl ein Droplet bei DigitalOcean hast, kannst du deren Mirrors ja gern verwenden, aber wenn du außer "main" keine Package Repos aktiv hast, musst du dich nicht wundern, dass nur die Hälfte installiert ist. Einige Pakete werden nicht direkt von Canonical gepflegt (main) sondern von der Community in "universe" oder "multiverse". Ergo solltest du die deb Einträge in der Sources.list ändern in

    "... trusty main restricted universe multiverse"

    und das natürlich in allen 3 Zeilen.
     

Diese Seite empfehlen