ISPConfig Index wird statt Clientwebsite angezeigt

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von iddQQp, 15. Okt. 2011.

  1. iddQQp

    iddQQp New Member

    Hi @ all,

    Problem:

    Die ISPConfig Standardwebiste "It Works" wird statt meiner angelegten Domain angezeigt. Die Domain heißt test.mydomain.de - mydomain.de ist auch angelegt. Habe test.mydomain.de erstmal als Subdomain angelegt --> It works erscheint. Auch als neue Domain kommt --> It works. Jedes mal wird mir die "It Works" Site angezeigt. Die Dateien liegen in /var/www/clients/client[client_id]/web[website_id]/web und werden wie oben beschrieben nicht angezeigt. (Konnte mydomain.de noch nicht testen, da ich erst sichergehen möchte, dass alle funktioniert und dann umziehen.
    test.mydomain.de hat einen A-Record auf den Webserver x.x.x.x.

    Meine Vhost Config:

    Code:
    <Directory /var/www/test.mydomain.de>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost x.x.x.x:80>
          DocumentRoot /var/www/test.mydomain.de/web
      
        ServerName test.mydomain.de
        ServerAdmin webmaster@test.mydomain.de
    
        ErrorLog /var/log/ispconfig/httpd/test.mydomain.de/error.log
    
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
        
        <Directory /var/www/test.mydomain.de/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client2/web19/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
    
        # suexec enabled
        SuexecUserGroup web19 client2
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # php as fast-cgi enabled
        <IfModule mod_fcgid.c>
          
          # SocketPath /tmp/fcgid_sock/
          
          # IdleTimeout n (3600 seconds)
          # An idle fastcgi application will be terminated after IdleTimeout seconds.
          IdleTimeout 3600
          
          # ProcessLifeTime n (7200 seconds)
          # A fastcgi application will be terminated if lifetime expired, even no error is detected.
          ProcessLifeTime 7200
          
          # MaxProcessCount n (1000)
          # The max count of total fastcgi process count.
          # MaxProcessCount 1000
          
          # DefaultMinClassProcessCount n (3)
          # The minimum number of fastcgi application instances for any one fastcgi application.
          # Idle fastcgi will not be killed if their count is less than n
          # Set this to 0, and tweak IdleTimeout
          DefaultMinClassProcessCount 0
          
          # DefaultMaxClassProcessCount n (100)
          # The maximum number of fastcgi application instances allowed to run for
          # particular one fastcgi application.
          DefaultMaxClassProcessCount 100
          
          # IPCConnectTimeout n (3 seconds)
          # The connect timeout to a fastcgi application.
          IPCConnectTimeout 8
          
          # IPCCommTimeout n (20 seconds)
          # The communication timeout to a fastcgi application. Please increase this
          # value if your CGI have a slow initialization or slow respond.
          IPCCommTimeout 360
          
          # BusyTimeout n (300 seconds)
          # A fastcgi application will be terminated if handing a single request
          # longer than busy timeout.
          BusyTimeout 300
          
        </IfModule>
        <Directory /var/www/test.mydomain.de/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web19/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client2/web19/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web19/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web19 client2
        </IfModule>
    
        <IfModule mod_dav_fs.c>
          # DO NOT REMOVE THE COMMENTS!
          # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
          # WEBDAV END
        </IfModule>
    
    
    </VirtualHost>
    
    
    Habe den Apache schon mehrmals durchgestart "/stop" "/start" und auch beobachtet ob nicht irgendwo noch ein Prozess offen ist.

    Des Weiteren laufen bei mir halt noch die Standardvhosts wie default.

    Code:
    <VirtualHost *:80>
        ServerAdmin webmaster@localhost
    
        DocumentRoot /var/www
        <Directory />
            Options FollowSymLinks
            AllowOverride None
        </Directory>
        <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
        </Directory>
    
        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
        </Directory>
    
        ErrorLog ${APACHE_LOG_DIR}/error.log
    
        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn
    
        CustomLog ${APACHE_LOG_DIR}/access.log combined
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
    
     
  2. Till

    Till Administrator

    Die it works seite gehört nicht zu ispconfig sondern es handelt sich um die standardseite der linux distribution. Sie wird dann angezeigt, wenn der apache keine übereinstimmung zwischen hostaneme und ip in seiner konfiguration findet.
     
  3. iddQQp

    iddQQp New Member

    Hi,

    dann werd ich wohl 24 Stunden warten müssen nachdem ich die IP-Adresse auf dem Nameserver geändert habe. Wird dann wohl daran liegen.
     
    Zuletzt bearbeitet: 15. Okt. 2011
  4. iddQQp

    iddQQp New Member

    Hi,

    habe bisher ein bisschen rumprobiert und folgendes fällt mir auf:

    Wenn ich den vHost 'default' deaktiviere funktionierts, bekomme aber ein Fehler: 403 Forbidden

    You don't have permission to access / on this server.


    Wenn ich vHost 'default' aktiviere bekomme ich wieder die Apache Startseite.
    Nun habe ich die IP von 'default' (<VirtualHost *:80>) auf <VirtualHost x.x.x.x:80> gesetzt und bekomme wieder die Fehlermeldung 'You don't have permission to access / on this server.'

    Any ideas so far?
     
  5. Till

    Till Administrator

    Steht der server hinter einem router? Dann musst du für die webseite die interne ip wählen und nicht die externe ip. Die externe ip steht nur im dns record.
     

Diese Seite empfehlen