ISPConfig installiert, funktioniert lokal, aber empfängt keine externen e-Mails

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von wlbi, 5. Okt. 2014.

  1. wlbi

    wlbi New Member

    Hallo,
    Hanbe ISPConfig installiert und eine Domain eingerichtet.
    Wenn ich die e-mail lokal im Terminal versende mit dem mail Befehl, dann kommt die e-Mail auch an. Über Squirrelmail sehe ich die e-Mail dann im Browser.
    Sende ich aber über GMX eine e-Mail an diese Adresse, kommt sie nicht an.
    Muss man da noch zusätzlich was konfigurieren?
    Die MX Einträge im Nameserver sind für die Domain richtig gesetzt.
    Alex
     
    Zuletzt bearbeitet: 5. Okt. 2014
  2. Till

    Till Administrator

    Hast Du irgendwelche Fehler im mail.log des servers oder überhaupt etwas von gmx? Wenn nicht, dann kommt die Email garnicht erst beim Server an, das problem liegt dann also außerhalb.
     
  3. F4RR3LL

    F4RR3LL Member

    Oder Du hast bei Einsatz einer Firewall evtl nicht die passenden Ports auf.
     
  4. wlbi

    wlbi New Member

    In Iptables ist alles offen:

    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination      
    fail2ban-postfix-sasl  tcp  --  anywhere             anywhere             multiport dports smtp
    fail2ban-dovecot-pop3imap  tcp  --  anywhere             anywhere             multiport dports pop3,pop3s,imap2,imaps
    fail2ban-pureftpd  tcp  --  anywhere             anywhere             multiport dports ftp
    fail2ban-ssh  tcp  --  anywhere             anywhere             multiport dports ssh
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination      
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination      
    
    Chain fail2ban-dovecot-pop3imap (1 references)
    target     prot opt source               destination      
    RETURN     all  --  anywhere             anywhere         
    
    Chain fail2ban-postfix-sasl (1 references)
    target     prot opt source               destination      
    RETURN     all  --  anywhere             anywhere         
    
    Chain fail2ban-pureftpd (1 references)
    target     prot opt source               destination      
    RETURN     all  --  anywhere             anywhere         
    
    Chain fail2ban-ssh (1 references)
    target     prot opt source               destination      
    RETURN     all  --  anywhere             anywhere
    Und in den Logdateien sehe ich keinen Eintrag von GMX :(
     
  5. Till

    Till Administrator

    Steht der Server in einem Rechenzentrum?
    Gibt es eine Firewall vor dem Server?
    Zum DNS: bist Du sicher dass der MX Record der Domain auf einen existierenden A-Record zeigt und dieser A-Record wiederum auf die IP Deines Servers?
     
  6. F4RR3LL

    F4RR3LL Member

    Bei gmx wäre auch noch SPF ein Thema. Wobei Du bei fehlerhaftem Mailserver normalerweise in deinem GMX Account Hinweise finden würdest. Das sieht eher so aus als würden die Zustellversuche noch laufen, somit wie Till schon fragte...
    wenn der Server nicht in einem RZ steht wäre der Router der nächste Ansatz bzgl Ports.
     
  7. wlbi

    wlbi New Member

    Um das ganze mal offizieller zu machen.
    Server steht bei server4you
    Der DNS Eintrag zu MX sieht wie folgt aus:
    Code:
    # dig -t mx 1a-w.de
    ; <<>> DiG 9.9.5-3-Ubuntu <<>> -t mx 1a-w.de
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32143
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;1a-w.de.            IN    MX
    
    ;; ANSWER SECTION:
    1a-w.de.        86364    IN    MX    10 mail.1a-w.de.
    Ist also eingetragen.
    wenn ich nach test@... eine e-mail schicke, dann kommt bei GMX oder auch Yahoo keine Fehlermeldung.
    Auch in /var/log/mail.log steht nichts.
    Sende ich die lokal auf dem Server mit dem Befehl:
    mail test@....
    Dann wird die e-mail sofort zugestellt und ist dann auch zu finden in
    /var/spool/vmail/1a-w.de/new/
     
  8. Till

    Till Administrator

    Vielleicht läuft Dein Postfix nur auf localhost. Poste bitte mal die Ausgabe von:

    netstat -tap | grep smtp
     
  9. wlbi

    wlbi New Member

    Die Ausgabe von:
    netstat -tap | grep smtp
    Code:
    tcp     0    0 localhost:smtp     *:*      LISTEN   28242/master
    Ich bin mir nicht sicher, aber so wie es aussieht hat server4you ein massives Problem mit ihrem DNS oder Routing.
    Code:
    $ ping -c1 1a-w.de
    PING 1a-w.de (85.25.119.85) 56(84) bytes of data.
    64 bytes from triton704.dedicatedpanel.com (85.25.119.85): icmp_seq=1 ttl=57 time=29.9 ms
    Mein Server ist aber eigentlich: triton707 NICHT triton704
    Wobei die IP Adresse stimmt, nur die Domain nicht.
    Versuche ich dann diese tritton704 Domain zu pingen, kommt die Rückmeldung wieder von einer anderen Domain und andere IP:
    Code:
    $ ping -c1 triton704.dedicatedpanel.com
    PING triton704.dedicatedpanel.com (62.75.212.215) 56(84) bytes of data.
    64 bytes from dragon827.dedicatedpanel.com (62.75.212.215): icmp_seq=1 ttl=57 time=55.6 ms
    Könnte also auch daran liegen, wobei das bisher von Server4You noch nicht bestätigt ist und ich habe keinen anderen Internetzugang um das zu testen, ob es bei allen Zugängen und Nameservern so ist.
     
    Zuletzt bearbeitet: 6. Okt. 2014
  10. Till

    Till Administrator

    Da haben wir ja das problem, Dein Postfix ist nicht an das externe Interface gebunden. Im Momemnt lauscht er nur auf localhost. Ändere mal inet_interfaces zu:

    inet_interfaces = all

    in der postfix main.cf und starte postfix neu.
     
  11. wlbi

    wlbi New Member

    Ja genau das war das Problem. Jetzt funktioniert das ganze... :rolleyes:
    Und deswegen habe ich dem neuen Server schon x mal mit einem neuen Image erstellt und ISPconfig auf viele verschiedene Arten installiert. Und dann lag das Problem an Postfix.
    Vielen Dank für die Hilfe!
     
    Zuletzt bearbeitet: 7. Okt. 2014

Diese Seite empfehlen