ISPConfig Kundenweise PHP Safe Mode an oder aus?

Dieses Thema im Forum "Allgemein" wurde erstellt von Puiscel, 5. Feb. 2012.

  1. Puiscel

    Puiscel New Member

    hi
    bin relativ neu mit ispconfig. Vorher lief alles über confixx. Bei Confixx konnte man pro kunde unterschiedliche einstellungen wie den PHP safe mode an oder ausmachen und es galt nur für den ausgewählten kunden. Bei ISPConfig erhoffe ich mir eine gleiche funktion, doch diese habe ich noch nicht finden können. Gibt es dort die gleiche Möglichkeit? Also für Kunde xy soll der PHP Safe Mode an sein und für kunde xyz soll er aus sein. Gibt es zum aktivieren des Safe_Mode eine checkbox die man einfach aktivieren kann bei ISPConfig 3.x. Habe gelesen,dass es bei ISPConfig 2.x möglich war.
    hoffe jemand weiß rat

    Edit: Habe nun etwas gefunden
    Apache Direktiven
    Habe für Mod Rewrite zu aktivieren folgendes hineingeschrieben:
    Ist dies soweit richtig nun?
     
    Zuletzt bearbeitet: 5. Feb. 2012
  2. Till

    Till Administrator

    Safemode wird bei aktuellen PHP Versionan sich nicht mehr verwendet, es wurde durch andere Einstellungen wie open_basedir etc. abgelöst.

    Um eine PHP Webseite sicher zu betreiben musst Du erstmal den richtigen PHP Mode verwenden, dies ist normalerweise php-fcgi zusammen mit suexec.Wenn Du dann noch individuelle PHP Einstellungen pro Webseite vornehmen möchtest, dann machst Du das über das php.ini Feld in den Webseiteneinstellungen.

    Macht wenig Sinn für ISPConfig 3, denn diese Einstellung ist standradmäßig so.

    ISPConfig 2 und 3 sind vollkommen unterschiedliche Softwarepakete die nichts als den namen miteinander zu tun haben, wenn Du also etwas zu ISPConfig 2 list, dann trift es sehr wahrscheinlich nicht auf ISPConfig 3 zu.
     
  3. fuXz

    fuXz New Member

    Ich richte das ganze zusammen mit Puiscel auf einem Server ein...

    Wie ist der Standartwert von open_basedir bei ispconfig 3 ?

    Wie genau kann ich die Werte anpassen?

    mod_rewrite ist nicht aufgelistet unter modules bei phpinfo(); und eine htaccess Datei die auf einem anderen Server ohne Probleme funktionierte geht hetzt nicht mehr.

    Auszug htaccess
    Code:
    #Options +FollowSymLinks
    RewriteEngine On
    
    # Module allgemein
    RewriteRule ^Startseite$ index.php
    Weiterhin mit welchem Abschnitt (und wo einfügen apache directives?) wird php safe_mod on/off geschaltet? (gibt ja keine Checkbox mehr soweit ich das gesehen habe)
     
  4. Till

    Till Administrator

    Siehe System > Server Config bzw. Einstellungen der jeweiligen webseite für den individuellen Wert.

    In das open_basedir Feld der Webseite klicken, pfad eingeben, speichern.

    mod_rewrite ist ein apache Modul und kein php Modul. Wenn Du der Installationsanleitung für ISPConfig gefolgt bist, dann ist es aktiv.

    Lies doch bitte nochmal meinen Post oben, da steht drin warum es keine Checkbox gibt und dass man heute keinen safemode mehr verwendet und da steht auch wo Du individuelle Einträge für die php.ini machst.
     
  5. fuXz

    fuXz New Member

  6. Till

    Till Administrator

    Dann führe nochmal jeden Befehl aus schritt 12 aus, um sicherzustellen dass Du mod_rewrite installiert und aktiviert hast.
     
  7. fuXz

    fuXz New Member

    Wie bereits per PM gesagt soweit läuft nun alles bis auf mod_rewrite. Schritt 12 war schon ausgeführt, wurde jedoch nocheinmal ausgeführt. - Keine Besserung.

    Fakten:
    - htaccess geht auf einem anderen Server auf dem neuen mit ISPConfig nicht
    - mod_rewrite wurde wie in Schritt 12 der Anleitunge erklärt installiert
    - Beim aufruf von www.domain.tld/Hello-World (Bsp) kommt statt der verlinkten Seite ein 404 Fehler

    Code:
    Options +FollowSymLinks
    RewriteEngine On
    
    # Module allgemein
    RewriteRule ^Startseite$ index.php
    RewriteRule ^Impressum$ modules.php?name=impressum
    Das ist ein Ausschnitt aus der htaccess Datei
     
  8. Till

    Till Administrator

    Und Du bist sicher, dass die requests auch im richtigen vhost landen, also die Kombination aus IP-Adresse und Domain stimmt und auch auto-subdomain ww an ist etc? Schau mal ins access.log bzw. error.log der Webseite.
     
  9. fuXz

    fuXz New Member

    error.log
    Code:
    [Mon Feb 06 15:52:27 2012] [error] [client 93.221.111.xx] File does not exist: /var/www/domain.de/web/domain.de/domain.de, referer: http://www.domain.de/
    access.log
    Code:
    93.221.111.xx - - [06/Feb/2012:15:53:57 +0100] "GET / HTTP/1.1" 200 3285 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0"
    93.221.111.xx - - [06/Feb/2012:15:54:01 +0100] "GET /Domains HTTP/1.1" 404 852 "http://www.domain.de/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0"
    Redirect Type "L"
    SEO Redirect = "Nicht-www -> www"
    Drer Server hat nur eine IP daher gehe ich mal davon aus das diese stimmt.
     
    Zuletzt bearbeitet: 6. Feb. 2012
  10. Till

    Till Administrator

    Schalte mal den redirect in der Webseite aus, wenn sich Dateien im Web Verzeichnis befinden, dann muss redirect auf "none" stehen, denn mit Redirect L sagst Du ja apache, dass er nach einem anderen Pfad nach index und .htaccess Dateien suchen soll und dass es sich um die letzte auszuführende Regel handelt. Den seo redirect kannst Du an lassen. Mod_rewrite funktioniert einwandfrei, wie Du im access.log siehst. Nur dass Du im Moment rekursiv auf ein Verzeichnis mit dem Namen der Domain umleitest.
     
  11. fuXz

    fuXz New Member

    Vielen Dank es geht nun so
     

Diese Seite empfehlen