ISPConfig Mail Problem authdaemond: failed to connect to mysql server

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von finke77, 28. Mai 2009.

  1. finke77

    finke77 New Member

    Hallo alle zusammen!

    Ich habe einen vServer mit Debian Lenny Image auf dem ISPConfig 3 schon installiert war.
    ISPConfig 3 gefällt mir ganz gut. Ich habe nur jetzt ein Problem mit dem Mailserver. Ich bekomme immer folgenden Fehler:
    Code:
    May 28 18:50:51 vadmin7 authdaemond: failed to connect to mysql server (server=localhost, userid=ispconfig):Access denied for user 'ispconfig'@'localhost' (using password: YES)
    May 28 18:50:51 vadmin7 pop3d: LOGIN FAILED, user=mail@domain.de, ip=[::ffff:217.229.115.27]
    May 28 18:50:51 vadmin7 pop3d: authentication error: Input/output error
    
    und
    Code:
    May 28 19:30:53 vadmin7 imapd: Connection, ip=[::ffff:217.229.115.27]
    May 28 19:30:54 vadmin7 authdaemond: failed to connect to mysql server (server=localhost, userid=ispconfig):Access denied for user 'ispconfig'@'localhost' (using password: YES)
    May 28 19:30:54 vadmin7 imapd: LOGIN FAILED, user=mail@domain.de, ip=[::ffff:217.229.115.27]
    May 28 19:30:54 vadmin7 imapd: authentication error: Input/output error
    
    Dabei ist es egal, ob ich es mit POP3 oder IMAP versuche. An der DB Config für den Benutzer ispconfig habe ich nichts geändert. Ich kann mich auch mit den Daten aus /etc/postfix/sasl/smtpd.conf an die DB über die Shell anmelden.

    Hat jemand eine Idee, warum die Anmeldung an den Mailserver nicht funktioniert? :confused:

    Wenn noch zusätzliche Infos benötigt werden, bitte fragen!

    Vielen Dank im Vorraus,

    Christian
     
  2. Till

    Till Administrator

    Darf ich fragen bei welchem Hoster Du den vserver hast?

    Kannst Du Dich auch so anmelden?

    mysql -h localhost -u ispconfig -p

    und wenn er dann nach dem Passwort fragt das Passwort aus einer der Config Dateien angeben.
     
  3. finke77

    finke77 New Member

    Hallo

    RB Media Group


    Ja, das funktioniert.


    Ich glaube ich habe einen Fehler gefunden:
    In /etc/courier/authmysqlrc war nach MYSQL_PASSWORD das verschlüsselte Password eingegeben. Ich habe das mal auf das unverschlüsselte Password geändert, und es sieht so aus, als ob ich mich mit POP3 und IMAP anmelden kann (Neustart der Dienste
    [FONT=Courier New, Courier, mono]/etc/init.d/courier-authdaemon restart
    /etc/init.d/courier-imap restart
    /etc/init.d/courier-imap-ssl restart
    /etc/init.d/courier-pop restart
    /etc/init.d/courier-pop-ssl restart)
    [/FONT]
    :

    Code:
    May 28 20:15:02 vadmin7 imapd: Connection, ip=[::ffff:127.0.0.1]
    May 28 20:15:02 vadmin7 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    May 28 20:15:02 vadmin7 postfix/smtp[8059]: F26EA4F155: to=<getmail@vadmin7.rb-vserver-s1.de>, orig_to=<getmail>, relay=none, delay=0.46, delays=0.34/0.12/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    May 28 20:15:03 vadmin7 postfix/smtpd[8061]: connect from localhost[127.0.0.1]
    May 28 20:15:03 vadmin7 postfix/smtpd[8061]: lost connection after CONNECT from localhost[127.0.0.1]
    May 28 20:15:03 vadmin7 postfix/smtpd[8061]: disconnect from localhost[127.0.0.1]
    May 28 20:15:09 vadmin7 pop3d: Connection, ip=[::ffff:217.229.115.27]
    May 28 20:15:10 vadmin7 pop3d: LOGIN, user=mail@domain.de, ip=[::ffff:217.229.115.27], port=[36064]
    May 28 20:15:10 vadmin7 pop3d: LOGOUT, user=mail@domain.de, ip=[::ffff:217.229.115.27], port=[36064], top=0, retr=0, rcvd=18, sent=96, time=0
    
    Allerdings scheint jetzt ein anderes Problem aufzutauchen, das vorher nicht da war:

    Code:
    May 28 20:13:28 vadmin7 postfix/error[8010]: C856F4E6DE: to=<getmail@vadmin7.rb-vserver-s1.de>, orig_to=<getmail>, relay=none, delay=168507, delays=168507/0.19/0/0.03, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    May 28 20:13:28 vadmin7 postfix/error[8019]: 0A47A4F12B: to=<getmail@vadmin7.rb-vserver-s1.de>, orig_to=<getmail>, relay=none, delay=8907, delays=8907/0.18/0/0.04, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    
    (wiederholt sich mehrfach)

    Was kann das denn nun wieder sein?

    Und beim SMTP gibt es auch einen Fehler:
    Code:
    May 28 20:20:03 vadmin7 postfix/smtpd[8190]: connect from localhost[127.0.0.1]                               
    May 28 20:20:03 vadmin7 postfix/smtpd[8190]: lost connection after CONNECT from localhost[127.0.0.1]         
    May 28 20:20:03 vadmin7 postfix/smtpd[8190]: disconnect from localhost[127.0.0.1]                            
    May 28 20:21:37 vadmin7 postfix/smtpd[8190]: connect from XXXXXXX.dip.t-dialin.net[217.229.XXX.XXX]         
    May 28 20:21:38 vadmin7 postfix/smtpd[8190]: 11E1D4EFF5: client=XXXXXXX.dip.t-dialin.net[217.229.XXX.XXX]   
    May 28 20:21:38 vadmin7 postfix/cleanup[8182]: 11E1D4EFF5: message-id=<200905282021.37565.mail@domain.de>     
    May 28 20:21:38 vadmin7 postfix/qmgr[17059]: 11E1D4EFF5: from=<mail@domain.de>, size=762, nrcpt=1 (queue active)                                                                                                           
    May 28 20:21:38 vadmin7 postfix/error[8109]: 11E1D4EFF5: to=<mail@domain.de>, relay=none, delay=0.15, delays=0.14/0/0/0.01, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)                                                                                      
    May 28 20:21:38 vadmin7 postfix/smtpd[8190]: disconnect from XXXXXXX.dip.t-dialin.net[217.229.XXX.XXX]
    

    Vielen Dank,

    Christian
     
    Zuletzt bearbeitet: 28. Mai 2009
  4. Till

    Till Administrator

    da hast Du vielleicht was durcheinander gebracht, die Passworte sind alle nicht encrypted in den config files, da sie aber mittels md5 erzeugt werden, sehen sie so aus. das ist also alles ok in den dateiein und due musst Dich mit exakt dem Passwort wie es in der Config Datei steht mit dem User ispconfig in mysql einloggen können. Wenn das nicht geht dann ist das Passwort in mysql falsch und nicht den config dateien und Du musst es in mysql ändern. das ist einfacher als alle Config dateien einzeln zu ändern.
     
  5. finke77

    finke77 New Member

    Hallo,

    Hhhm, das Passwort in /etc/courier/authmysqlrc sah so aus als ob es ein MD5 Passwort ist. Es war auf jeden Fall nicht das MySQL Passwort für den user ispconfig. Mit dem Klartext PW in /etc/courier/authmysqlrc scheine ich mich auch anmelden zu können.

    Gibt es irgendwo eine Übersicht, welche Konfigurationsdateien für ISPConfig 3 genutzt werden (inkl. der Mail Configs) und wo ein verschlüsseltes oder unverschlüsseltes Passwort herein gehört?

    Vielen Dank,

    Christian
     
  6. Till

    Till Administrator

    In alle Config Dateien kommt ein unverschlüsseltes pw, sonst könnte sich der Dienst ja bei der db anmelden. Die Passworte sehen zwar aus wie md5 encrypted, sind dsie aber nicht, das ist klartext.

    Du müsstest je nach Linux Distribution die Folgenden Dateien durchsehen: authmysqlrc, dann die mysql* Dateien in /etc/postfix und die smtp Datei im pam.d Verzeichnis.

    Das wird aber an sich alles richtig durch den ispconfig Installer bei der Installation konfiguriert, vieleicht hat Dein Provider irgend eines der Passworte beim Kopieren der bzw. erzeugen der VM geändert (was ja auch Sinn macht) und dabei nicht alle Dateien mitgeändert?
     
  7. finke77

    finke77 New Member

    Das mag sein, ich habe ISPConfig ja nicht selber installiert/konfiguriert. Momentan komme ich auch nicht an den Server. Ich muss das noch einmal kontrollieren, wenn ich wieder zu Hause bin ...

    Viele Grüße,

    Christian
     
  8. finke77

    finke77 New Member

    Bingo, ein weiterer Fehler. In /etc/pam.d/smtp war nicht das Klartextpassword sondern auch etwas, das wie ein MD5 verschlüsseltes PW aussieht... :(

    Es sieht auch so aus, als ob Amavis nicht installiert ist. Was mir vielleicht lt. Google folgenden Fehler erzeugen könnte:
    Code:
    postfix/error[23954]: 3E0E44F286: to=<getmail@vadmin7.xxxxxxxxxx.de>, orig_to=<getmail>, relay=none, delay=0.31, delays=0.29/0.01/0/0.01, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Es sieht so aus, als ob einiges bei dem Image durcheinandergeraten ist. :rolleyes:

    Ganz prakmatisch gesehen: Ist es jetzt einfacher und schneller den Server umzukonfigurieren und die ganzen Fehler herauszusuchen/beheben, oder geht es schneller eine Neuinstallation mit einem Debian Lenny Minimal Image durchzuführen und dann ISPConfig + benötigte Programme anhand einer Howto wie http://www.howtoforge.de/howto/der-perfekte-server-debian-lenny-debian-50-ispconfig-3/ neu einzurichten? :confused:
    Der Server ist noch nicht in Betrieb, er ist neu und wird gerade erst von mir getestet ...

    Vielen Dank,

    Christian

    P.S.: Gibt es gute Doku im Internet zu Mailserver und allen Komponenten aus diesem Bereich, die ISPConfig mit nutzt/konfiguriert (z.B. Postfix, Courier, AUTH, Amavis etc...)? Hier muss man sich z.T. etwas tiefer einlesen, was nicht unbedingt eine kleine HowTo leistet ...
     
  9. Till

    Till Administrator

    Falsch! Das ist das Klartext Passwort. Wenn Du irgendwo welche hast die anders aussehen, dann sind die nicht von ISPConfig erstellt.

    Am einfachsten deinstallierst Du ispconfig mit dem uninstall.php script und installierst es dann neu.
     
  10. finke77

    finke77 New Member

    Ähm, jetzt bin ich ein wenig verwirrt :confused:
    Ich glaube wir reden da aneinander vorbei...
    Angenommen das Klartextpasswort, mit dem ich auch mit dem MySQL Client an die Datenbank anmelden kann ist
    dtF3GezL (<= das ist natürlich nicht das richtige Password ;) )

    dann stand in /etc/pam.d/smtp und /etc/courier/authmysqlrc nicht dieses Password, sondern etwas wie
    c7b9732b6c62349c863ea8g933d590da

    Und das habe ich in diesen Dateien auf den Text dtF3GezL geändert.
    War das jetzt richtig oder falsch?


    OK, das hört sich einfacher und schneller an als eine komplette Neuinstallation.
    Sollte man die bisher eingerichteten Sachen (wie Datenbanken und PHP Dateien der Webseiten) vor der Neuinstallation löschen?
    Kann man ein Backup der jetzigen Konfiguration machen?

    Vielen Dank!

    Christian
     
  11. Till

    Till Administrator

    Wir reden nicht aneinander vorbei. Das Passwort c7b9732b6c62349c863ea8g933d590da ist das Klartext Passwort, ich hatte doch oben geschrieben dass ispconfig die md5 Funtion zur Erzeugung von Passworten benutzt. Ein Passwort wie dtF3GezL kann nicht von ispconfig sein sondern es wurde manuell in der mysql DB geändert und deshalb geht Dein setup auch nicht.

    Jein, es gibt 2 Möglichkieten.

    a) Du löschst sie vorher, dann kannst Du aber auch nicht mit einem Backup arbeiten oder
    b) Du machst ein Backup der mysql DB und löschst nichts vorher, deinstallierst ISPConfig und installierst es neu und spiels dann die ispconfig mysql datenbank zurück.
     
  12. finke77

    finke77 New Member

    Ahhrg, mein Verständnisproblem. Ich bin die ganze Zeit davon ausgegangen, dass dtF3GezL das von ISPConfig erzeugte Klartextpassword ist, mit dem ich bei der DB ja auch anmelden konnte... :eek:

    Da alles so "verkonfiguriert" ist und ich nicht weiß, wo mein Provider bei dem Image eingegriffen hat, gehe ich glaube besser den Weg mit deinstallieren, löschen, neu installieren, neu konfigurieren.
    Da begebe ich mich heute Nachmittag mal ran...

    Vielen Dank erst einmal soweit!

    Christian
     
  13. finke77

    finke77 New Member

    Hallo,

    so ich habe den Server noch einmal komplett neu installiert:
    Debian Lenny Minimal Image und dann nach folgende HowTo's:
    http://www.howtoforge.de/howto/der-perfekte-server-debian-lenny-debian-50-ispconfig-3/
    http://www.howtoforge.com/forums/showpost.php?p=152426&postcount=4
    Hat alles alles soweit funktioniert, nur ich hatte anschließend beim Mailserver wieder folgende Fehlermeldung:
    Code:
    May 30 15:56:57 vadmin7 postfix/smtp[2755]: 89BBE4A115: to=<mail@domain.de>, relay=none, delay=0.78,delays=0.5/0.28/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Nach ein bischen googlen bestätigte sich die Vermutung, dass Amavis nicht lief.
    Also habe ich neu gestartet und auch versucht eine Mail über Roundcube zu versenden. Dabei gab es im mail.log folgende Fehlermeldung:

    Code:
    May 30 16:02:50 vadmin7 amavis[18829]: starting.  /usr/sbin/amavisd-new at vadmin7.xxxxxxxxxxxx.deamavisd-new-2.6.1 (20080629), Unicode aware, LANG="de_DE@euro"
    May 30 16:02:50 vadmin7 amavis[18829]: Perl version               5.010000
    May 30 16:02:55 vadmin7 amavis[18829]: (!)Net::Server: 2009/05/30-16:02:55 Couldn't fork: [[B]Nicht gen\374gend Hauptspeicher verf\374gbar][/B]\n\n  at line 293 in file /usr/share/perl5/Net/Server.pm
    Naja die Fehlermeldung scheint ja eindeutig zu sein ... :rolleyes::mad:

    Ich habe den Mailfilter in Postfix main.cf ausgeschaltet:
    Code:
    #content_filter = amavis:[127.0.0.1]:10024
    Nach Postfix Neustart scheint es zu funktionieren. Mail ist jedefall angekommen...

    Es scheint als ob ich den Speicherverbrauch für den vServer doch deutlich unterschätzt habe, ich dachte 128 MB RAM + 256 MB SWAP seien für so einen Server ausreichend. Aber es hakt da doch so deutlich, so dass ich jedem davon abraten kann nur 128 MB zu nehmen.

    Wie viel RAM sollte man mindestens haben, 256 MB?
    Hat jemand gute Erfahrungen mit anderen vServern?
    Es gibt ja Angebote im Internet, wie Sand am mehr. Aber kennt jemand gute Provider, die auch noch kostengünstig und zuverlässig sind?
    Ich habe auch noch keine guten seriösen Tests von vServern gefunden. Kennt da jemand welche?
    Ich wollte eigentlich nicht viel Geld dafür ausgeben (nach Möglichkeit <10EUR pro Monat), da neben dem Mailserver nur zwei Websites darauf liegen sollen und diese haben
    a.) nicht die riesige Masse an Besuchern (Hits sind im Schnitt 1000 - 3000 pro Tag) und
    b.) ich verdiene mit denen auch kein Geld bzw. ich habe auch keine Verpflichtungen, es ist nur Hobby

    Ich hoffe ich habe euch nicht mit zu viel Fragen bombadiert. Wäre aber schön, wenn Ihr eure Erfahrungen mit mir teilen und mir ein paar Tipps geben könntet ...

    Viele Grüße,

    Christian
     
  14. Till

    Till Administrator

    Ich nutze iSPConfig 3 nur auf physischen Servern, daher kann ich Dir keine genauen Angaben für vserver machen. Aber 256 sollten es denke ich schon sein. Du kannst natürlich auch versuchen das Ganze etwas zu optimieen indem Du z.B. weniger courier und apache Instanzen startest oder aber wei Du es ja schon gemacht hast den spam Scanner ausschalten (was aber bei Nutzung als Mailserver suboptimal ist).
     

Diese Seite empfehlen