ISPConfig + nginx + Ioncube

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mycrotrend, 20. Jan. 2014.

  1. mycrotrend

    mycrotrend Member

    Heyho,

    ich habe ISPConfig mit nginx installiert und es funktioniert alles problemlos.
    Nun möchte ich noch den Ioncube Loader installieren.

    Ich habe alles soweit gemacht und mir diverse How To`s durchgelesen, aber der Loader will einfach nicht laden.

    Im Wizzard bekomme ich die Fehlermeldung

    Code:
    The following ini files could not be found by the Wizard: /etc/php5/fpm/php.ini,/etc/php5/fpm/conf.d/10-pdo.ini,/etc/php5/fpm/conf.d/20-apc.ini,/etc/php5/fpm/conf.d/20-curl.ini,/etc/php5/fpm/conf.d/20-gd.ini,/etc/php5/fpm/conf.d/20-imap.ini,/etc/php5/fpm/conf.d/20-intl.ini,/etc/php5/fpm/conf.d/20-mcrypt.ini,/etc/php5/fpm/conf.d/20-memcache.ini,/etc/php5/fpm/conf.d/20-memcached.ini,/etc/php5/fpm/conf.d/20-mysql.ini,/etc/php5/fpm/conf.d/20-mysqli.ini,/etc/php5/fpm/conf.d/20-pdo_mysql.ini,/etc/php5/fpm/conf.d/20-pdo_sqlite.ini,/etc/php5/fpm/conf.d/20-pspell.ini,/etc/php5/fpm/conf.d/20-recode.ini,/etc/php5/fpm/conf.d/20-snmp.ini,/etc/php5/fpm/conf.d/20-sqlite3.ini,/etc/php5/fpm/conf.d/20-tidy.ini,/etc/php5/fpm/conf.d/20-xmlrpc.ini,/etc/php5/fpm/conf.d/20-xsl.ini,/etc/php5/fpm/conf.d/imagick.ini,/etc/php5/fpm/conf.d/ming.ini,/etc/php5/fpm/conf.d/ps.ini
    Die Dateien existieren allerdings in diesem Verzeichniss.
    Wenn ich allerdings mit SFTP nach /etc/php/fpm/conf.d/ gehen möchte schmeisst er mich automatisch nach /etc/php/conf.d/ könnte das ein Fehler sein ?

    PHP sagt mir allerdings auch, dass ionCube geladen ist, oder bin ich grad einfach zu doof ? :D

    Code:
     php -v
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
    PHP 5.4.4-14+deb7u7 (cli) (built: Dec 12 2013 08:42:07)
    Copyright (c) 1997-2012 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
        with the ionCube PHP Loader v4.5.2, Copyright (c) 2002-2014, by ionCube Ltd.
    Ich habe die php.ini Datei von /etc/php5/cli/php.ini genommen

    Code:
    php -i | grep php.ini
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
    Configuration File (php.ini) Path => /etc/php5/cli
    Loaded Configuration File => /etc/php5/cli/php.ini
     
  2. Till

    Till Administrator

    unterd ebian gibt es verschiedene php.ini dateien. Du hast oben die php.ini von php-cli getestet, und da ist ioncube bereits erfolgreich geladen. Es kann also gut sein, dass es bei php-fpm auch bereits geht.

    1) starte mal php-fpm und apache neu.
    2) lege eine php datei mit phpinfo) Befehl in eine website die php-fpm verwendet und sieh dir die ausgabe an. wenn da irgendwo ioncube drin steht, dann funktioniert bereits alles.
     
  3. mycrotrend

    mycrotrend Member

    DANKE !

    Ich Pfeife :)

    Der php-fpm restart hatte geholfen, ich hatte nur nginx gerestartet :)
     

Diese Seite empfehlen