ISPConfig umstellen von https auf http

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von TrippleEx, 21. Apr. 2012.

  1. TrippleEx

    TrippleEx New Member

    Hi,

    habe nach dieser Anleitung ISPConfig auf meinem Server augesetzt:
    The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3] | HowtoForge - Linux Howtos and Tutorials

    Habe beim letzten Schritt:
    root@server1:/tmp/ispconfig3_install/install# php -q install.php

    bei der Abfrage ob auch SSL aktiviert werden soll, JA angeklickt.

    Wenn die IP des Servers mit dem entsprechenden Port ohne SSL aufrufen wird, kommt:

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <html><head> <title>400 Bad Request</title> </head><body> <h1>Bad Request</h1> <p>Your browser sent a request that this server could not understand.<br /> Reason: You're speaking plain HTTP to an SSL-enabled server port.<br /> Instead use the HTTPS scheme to access this URL, please.<br /> <blockquote>Hint: <a href="https://server1.pxxxxxt-xxx.de:8080/"><b>https://server1.pxxxxxt-xxx.de:8080/</b></a></blockquote></p> </body></html>

    Was auch nicht funktioniert ist:
    https://server1.pxxxxxt-xxx.de:8080

    https://pxxxxxt-xxx.de:8080 funktioniert jedoch.

    Die TLD ist auf DD24 registriert und ist umgeleitet auf die IP des Servers.

    Als Hostname wurde "server1" vergeben.

    Ist eine einfache Umstellung von https auf http möglich, oder muss das System komplett neu aufgesetzt werden.

    Und warum kann ich ISPConfig nicht über
    https://server1.pxxxxxt-xxx.de:8080
    erreichen, sondern nur über:
    http://pxxxxxt-xxx.de:8080

    Danke.
     
  2. Till

    Till Administrator

    Dein problem hat nichts mit ssl zu tun sondern mit dns. Du musst den hostnamen des servers als dns a record in dem dns server anlegen, welcher die zone deiner domain verwaltet.
     

Diese Seite empfehlen