ISPConfig und CMS Systeme

Dieses Thema im Forum "Allgemein" wurde erstellt von Eagle1, 31. Aug. 2009.

  1. Eagle1

    Eagle1 New Member

    Hi!

    bin auf folgendes Problem gestoßen:

    wenn ich per FTP auf den Webspace gehe und Files rauf kopiere haben die Files die Besitzer/Gruppen ID (z.B. 5007 / 5007) (also client7/web7);
    wenn ich aber über Apache aus einem CMS System (z.B. Joomla) Files auf den Webspace kopiere oder erstelle besitzen diese die Besitzer/Gruppe ID 48/48 also Apache / Apache

    somit kann ich diese Dateien auch nicht mehr löschen, da der User keine Berechtigung für diese Files hat...

    wie birnge ich Apache bei, dass er als für den jeweiligen vhost als derjenige User läuft?
    oder muß ich generell was anderes umstellen? Oder hab ich mein ISP falsch konfiguriert?

    verwendet wird ISPConfig 3.0.1.3 auf Centos 5.3

    hab mittlerweile versucht SUPHP 0.7.1 zum laufen zu bringen.... leider ohne Erfolg.... INTERNAL SERVER ERROR

    so... mit SUPHP 0.7.0 funzts nun.....


    mfg
    Chris
     
    Zuletzt bearbeitet: 31. Aug. 2009
  2. planet_fox

    planet_fox Super-Moderator

    Genau du musst endweder SuPHP oder fastcgi nehmen dann gehts.
     
  3. Eagle1

    Eagle1 New Member

    direktes einstellen von fastCGI brachte nicht den gwünschten Erfolg

    witzig ist nur, dass bei Einstellung von SUPHP das phpinfo dein fCGI zurück gibt....
     
  4. Till

    Till Administrator

    Das mit phpinfo ist normal, da das cgi und fcgi binary identisch sind. phpinfo "weiß" also nicht, ob es im cgi oder fcgi Modus läuft.
     
  5. Eagle1

    Eagle1 New Member

    vom Regen in die Traufe....

    so nach dem SUPHP nun endlich läuft hab ich schon das nächste Problem...


    wenn ich den neuen Webspace mit SUPHP einstelle, dann bekomm ich im Browser (egal ob IE oder FF) immer Cookies Probleme.... stell ich wieder zurück auf Fast-CGI dann sind die Probleme weg.... ist das ein Konfig Problem? Wenn ja, wo muß ich was umstellen?

    weiters hab ich noch was entdeckt:
    ich habe Client A mit Website A und ftpUser aftp ([clientname]ftp) mit PW 1234
    lege ich nen neuen Client an also:
    Client B mit Website B und bftp mit dem selben PW (also 1234)
    und ich gebe in meinem FTP Programm die Daten von User B ein, bekomme ich aber den Webspace von User A angezeigt.

    (A und B sowie das Passwort sind zur vereinfachten Darstellung gekürzt)
    Mittlerweile läuft ISPConfig 3.0.1.3 auf CentOS 5.3 mit PHP 5.2.9

    Greez
    Chris
     
    Zuletzt bearbeitet: 3. Sep. 2009
  6. Till

    Till Administrator

    Mach alle Browser Fenster zu, damit die Session-cookies gelöscht werden.

    Zum FTP. Lösche den FTP User nochmal und achte dann darauf dass Du schon bei der Erstellung des FTP Users die richtige Website auswählst.
     
  7. Eagle1

    Eagle1 New Member

    Hi!

    Danke für den Tip... mußte allerdings den gesamten Kunden incl. Web und FTP User löschen und neu anlegen..... dann funzt es wieder....


    was neues von der "SUPHP-Front"

    hab in der php.ini das Reporting und error Display aufgedreht....

    da bekomm ich dann ein Warning: Warning: session_start() [function.session-start]: open(/var/lib/php/session/sess_vkbg8pgbk4e9hfhpqv3gfh3047, O_RDWR) failed: Permission denied (13)

    ls-all des /var/lib/php Ordners sieht so aus:

    drwxrwx--- 2 root apache 12288 4. Sep. 15:50 session

    somit is klar warum das nicht geht....

    unter suphp läft apache unter web7 client7

    ist es ein risiko diesen Ordner auf 777 zu setzen?

    kann ich irgendwo im ISPConfig definieren, dass ich pro Client verschiedene PHP Einstellungen verwende?
    z.B. irgendwo pro Client ne eigene php.ini definieren, oder einzelne Parameter definieren

    Greez
    Chris
     
  8. planet_fox

    planet_fox Super-Moderator

    Ja du kannst eigene php inis machen über die Apache direktiven, könnte so aussehen dann

    Code:
    suPHP_ConfigPath /var/www/clients/client3/web6/phpini/
     
  9. Eagle1

    Eagle1 New Member

    Danke, werd ich gleich mal probieren!


    Den Eintrag hab ich erstellt
    die php.ini hab ich erstellt und mit dem Parameter gefüttert, der geändert sein soll

    Siehe da... es funktioniert!


    DANKE!

    Greez
    Chris
     
    Zuletzt bearbeitet: 9. Sep. 2009

Diese Seite empfehlen