ISPConfig und Fetchmail

#1
Hallo liebe Gemeinde,

ich habe mir zum Lernen einen internen Server aufgesetzt nach "The Perfect Server Ubuntu 12.04". Nun würde ich gern Fetchmail benutzen und möchte wissen, ob ich Fetchmail noch installieren muss oder ob das mit ISPConfig schon geschen ist, da es den Punkt Fetchmail in der Administration schon gibt. Danke für die Hilfe und viele Grüße

Tom
 

Till

Administrator
#2
Wenn Du nach perfect setup installiert ast dann ist alles notwendige installiert. Die "Fetchmail" Funktion verwendet intern das Program getmail, also nicht mit dem Programm fetchmail verwechseln.
 
#5
Hi Till,

ich habe mal ein Fetchmail auf ISPconfig eingerichtet mit einem Testkonto bei Googlemail. Ebenso ein lokales Testkonto "test@server.example.com". Es passiert nix. Die Mails die ich an die Google Adresse sende kommen bei Google auch an werden aber nicht gefetcht von meinem lokalen Server. Erwähnenswert ist vielleicht noch, das ich die Mails über SquirrelMail abrufe und wenn ich z.B. eine Mail an mich selbst sende mit dem o.g. Testkonto (test@server1.example.com an test@server1.example.com) dann bekomme ich noch diese Fehlermeldung:

Message not sent. Server replied: Authentication required
530 5.7.0 Must issue a STARTTLS command first
Mag das vielleicht damit zusammenhängen?

Viele Grüße

Tom
 

Till

Administrator
#6
Scheint so als ob Du 127.0.0.1 nicht in mynetworks in der postfix main.cf stehen hast oder localhost in /etc/hosts nicht auf 127.0.0.1 verweist.
 
#8
Ich konnte das Problem etwas eingrenzen, das Mailsystem funktioniert einwandfrei nur nicht mit der "Hauseigenen" server1.example.com. Ich habe einfach einmal eine neue Domain angelegt "testdomain.de" und ein Emailkonto test@testdomain.de. Damit kann ich Emails versenden und empfangen so wie es sein soll, auch der Fetch auf diese Adresse funktioniert. Wenn ich allerdings mal eine Email von test@testdomain.de an test100@server1.example.com versende, dann bekomme ich eine Email mit folgendem Text zurück:

This is the mail system at host server1.example.com. I'm sorry to have to inform you that your message could not be delivered to one or more recipients. It's attached below. For further assistance, please send mail to postmaster. If you do so, please include this problem report. You can delete your own text from the attached returned message. The mail system <test100@server1.example.com>: unknown user: "test100"
Den User test100 gibt es aber, zumindest habe ich ihn im System eingerichtet....hat noch jemand eine Idee? Danke und ein zauberhaftes Wochenende...

Tom
 

Till

Administrator
#9
Da liegt möglicherweise ein verständnisproblem vor, die Domain die las hostname des Servers verwendet wird kann nicht als emaildomain verwendet werden. Denn postfi versucht emails and den hostnamen an einen linux user und nicht ein virtuelles postfach zuzustellen. Daher muss der hostname des servers sowie das was in myhostname, mydomain etc. in der postfix main.cf steht keine für den email empfang verwendete domain enthalten.

Beispiel:

ok: server1.deinedomain.de
nicht ok: deinedomain.de

wenn Du deinedomain.de für email verwenden willst.
 

Werbung

Top