ispconfig und typo3

Dieses Thema im Forum "Allgemein" wurde erstellt von donald, 3. Sep. 2009.

  1. donald

    donald New Member

    hallo ich hab da ein paar kleine probleme und zwar wenn ich bei typo3 eine unangechaste seite anschaue kommt immer mal folgendes zuerst ganz viel code im sinne von :

    Code:
    * All rights reserved** This script is part of the TYPO3 project. The TYPO3 project is* free software; you can redistribute it and/or modify* it under the terms of the GNU General Public License as published by* the Free Software Foundation; either version 2 of the License, or* (at your option) any later version.** The GNU General Public License can be found at* http://www.gnu.org/copyleft/gpl.html.** This script is distributed in the hope that it will be useful,* but WITHOUT ANY WARRANTY; without even the implied warranty of* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the* GNU General Public License for more details.** This copyright notice MUST APPEAR in all copies of the script!***************************************************************/require_once(PATH_tslib.'class.tslib_pibase.php');/** * Plugin 'rgtabs' for the 'rgtabs' extension. * * @author Georg Ringer (just2b)  * @package TYPO3 * @subpackage tx_rgtabs */class tx_rgtabs_pi1 extends tslib_pibase { var $prefixId = 'tx_rgtabs_pi1'; // Same as class name var $scriptRelPath = 'pi1/class.tx_rgtabs_pi1.php'; // Path 
    usw...

    und darunter meine webseite. aktualiesiere ich nun meine site im browser ist der code verschwunden und die seite wird normal angezeigt. ist der cache geleert kommt wieder der code.

    das zweite ist ich kann keine .htaccess dateien auf den server laden kommt immer ein fehler in der übertragung. bennene ich die datei um auf _.htaccess klappt es zwar versuche ich aber es dan im ftp program wieder umzubennen kommt ne meldung not allowed usw.

    und das dritte ist mehr so ne frage : welcher php modus muss ich da einstellen? wenn ich fast-cgi (ich dachte mir das macht typo am schnellsten)einstelle und typo3 installiere dann kann ich mich in typo3 nicht einloggen. kommt immer ne falsches passwort meldung.
    dies war übrigens auch bei joomla der fall.

    als mod_php kann ich typo3 nicht ausführen. auf jedenfall die datenbank eingabe bei der installation nicht.

    cgi war kein problem funktioniert alles ausser eben das mit dem code. suphp hatte ich nocht nicht getestet.

    meine dateiberechtigungen sind übrigens alle auf ordner 755 und datei 644 falss es dort auch optimierungmöglichkeiten gibt wäre ich dankbar für jegliche tipps

    mfg
     
  2. Till

    Till Administrator

    Es funktionieren alle PHP modi bei mir einwandfrei mit typo3. Es hängt halt z.B. davon ab, ob Du suexec eingeschaltet hast oder nicht und dann musst Du die rechte entsprechend setzen.

    Das mit dem Seiten Caching sieht mir eher nach einem problem mit typo3 aus und nicht dem Setup im Allgemeinen bzw. Du hast vielleicht nicht die notwendigen .htaccess dateien erstellt oder geändert.

    Zum Hochladen der .htaccess dateien: Bei mir ghet das problemlos, versuch es mal mit einem anderen FTP Client wie fireftp.
     
  3. donald

    donald New Member

    wie hast du den die rechte gesetzt? susexec ist drin. das mit dem caching liegt eben wahrscheinlich daran das die htacce dateie aus dem fileadmin ordner nicht übertragen werden konnte.

    ich habs bisjetzt mit filezila und fireftp versucht. ich lade mir dan mal den fireftp runter
     
  4. donald

    donald New Member

    553 Prohibited file name: .htaccess
    : /web/typo3/fileadmin/_temp_/.htaccess

    dies ist die meldung

    p.s. welche phpmodi ist am empfhelenswertesten?
     
  5. Till

    Till Administrator

    Check mal die pure-ftpd Konfiguration ob dort der Zugriff auf dot files beschränkt ist.

    Für Seiten mit wenig Zugriffen ist suphp oder php-cgi + suexec ok, für Seiten mit vielen Zugriffen nimmst Du am Besten php-fcgi + suexec
     
  6. donald

    donald New Member

    ich kenn mich mit linux eigentlich nicht aus. wie kann ich die pure-ftp datei finden und bearbeiten
     
  7. Till

    Till Administrator

    Welche Linux Distribution setzt Du ein?
     
  8. donald

    donald New Member

    Opnesuse. es ist das perfectServer image von how to forge opensuse+ispconfig 3
     
  9. planet_fox

    planet_fox Super-Moderator

    schau mal unter

    Code:
    ls /etc/pureftp/
    da müssten aber ich bin mir nicht sicher ob das bei suse auch so ist die konfigurationsdateien von pureftp liegen.

    Good Luck ;)
     

Diese Seite empfehlen