ISPConfig Update schlägt fehl...

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von PierreK, 27. Jan. 2016.

  1. PierreK

    PierreK New Member

    Hallo Leute,

    zur Zeit versuche ich ein Update von ISPConfig auf die neuste Version zumachen.
    Ich starte das Script per ispconfig_update.sh
    Dann prüft er das Verzeichnis ...
    Dann kommt:
    --------------------------------------------------------------------------------
    _____ ___________ _____ __ _ ____
    |_ _/ ___| ___ \ / __ \ / _(_) /__ \
    | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
    | | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
    _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
    \___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
    __/ |
    |___/
    --------------------------------------------------------------------------------


    >> Update

    Operating System: Debian 7.0 (Wheezy/Sid) or compatible

    This application will update ISPConfig 3 on your server.

    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:
    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...

    Danach kommt die Promptzeile wieder und das wars.
    Hat jemand einen Tip woran das liegt ?
    EDIT:
    Was wichtiges vergessen ... die installierte ISPConfig version ist 3.0.5.3 und drauf soll die 3.0.5.4p8

    Gruß
    Pierre
     
    Zuletzt bearbeitet: 27. Jan. 2016
  2. Till

    Till Administrator

    Stimmt das mysql root pw in /usr/local/ispconfig/server/lib/mysql_clientdb.conf ?
     
  3. PierreK

    PierreK New Member

    Das sollte stimmen ! Sonst würde doch das ISPConfig auch nicht laufen oder ?

    Gruß
    Pierre
     
  4. florian030

    florian030 Member

    Teilweise. Überwiegend ist das nämlich der user ispconfig. Versuch doch mal, dich bei mysql mit dem Paßwort aus mysql_clientdb.conf anzumelden. Als root einfach mysql -p
     
  5. PierreK

    PierreK New Member

    Damit ich einwandfrei rein ... sehr komisch die Sache :(
     
  6. florian030

    florian030 Member

    Deine Festplatte ist aber nicht zufällig voll?
     
  7. PierreK

    PierreK New Member

  8. Till

    Till Administrator

    Welche PHP Version hast Du installiert und hat sie die mysql_* Funktionen (also die klassische MySQL PHP extension)?
     
  9. PierreK

    PierreK New Member

    ich habe 2 versionen drauf einmal 5.3 und die 5.4.12! Kann ich über das ISPConfig irgendwo direkt sehen was für eine Version er benutzt ?

    Gruß
    Pierre
     
  10. Till

    Till Administrator

    php --version
     
  11. PierreK

    PierreK New Member

    Ok Danke.
    PHP 5.3.22 (cli) (built: Nov 10 2013 12:53:40)
    Copyright (c) 1997-2013 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2013 Zend Technologies
     
  12. Till

    Till Administrator

    Poste mal die Ausgabe von:

    which php
     
  13. PierreK

    PierreK New Member

    /usr/local/bin/php
     
  14. Till

    Till Administrator

    Ok, scheint so als ob Du Dir eine PHP Cli Version ohne mysql support manuell kompiliert hast. Mach mal folgendes:

    mv /usr/local/bin/php /usr/local/bin/php_bak

    und dann starte das ISPConfig Update nochmal.
     
  15. PierreK

    PierreK New Member

    okm probiere ich mal gleich aus
     
  16. PierreK

    PierreK New Member

    ok nun scheint es zu funktionieren ... komisch
     

Diese Seite empfehlen