ISPConfig User

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von BHD84, 1. März 2012.

  1. BHD84

    BHD84 New Member

    Hallo zusammen.

    Ich würde gerne wissen ob ich das nachfolgende Problem ohne eine neuinstallation bereinigen kann.

    Ich habe auf 4 Servern ISPConfig laufen. 3 von denen tauschen sich wunderbar untereinander aus. Einer von den dreien ist auch mein Administrationsserver.

    Von dem 4. Server komme ich nicht mit ISPConfig auf den Administrationsserver. Eine direktverbindung mit telnet auf mysql mit port 3306 ist indess Problemlos möglich.

    Ein Update auf die Version 3.0.4.3 hat da leider nichts geholfen.
    Eine Reconfiguration der Permissions mit einen anderen Slave Server hat auch nix gebracht.

    Nun habe ich noch entdeckt, das der Server, der den Administrationsserver nicht erreichen kann, kein Passwort in der Datenbank von mysql unter user auf dem Administrationsserver hat. Ich gehe stark davon aus, das auch kein Passwort auf dem anderen Server ligt.

    ein update mit php -q update.php ging leider auch nicht.
    Es kommt immer die Fehlermeldung

    So nun meine Frage. Kann ich einfach ein Passwort ins mysql beim Adminserver eintragen und auf dem Slaveserver (wo ich nicht weiß wo ich das Passwort eintragen muss) oder gibt das nur schwierigkeiten?

    PS: ganz vergessen. System CentOS 6.2 und auf dem Adminserver ISPConfig 3.0.4.2
     
  2. Till

    Till Administrator

    Theoretisch ja, praktisch ist sdass Problem dass die Berechtigungen seh komplex sind und falls Du sie nicht setzts, dann ist das System unsicher.

    Den Fehler solltest Du so beheben können:

    1) Sicherstellen dass die /etc/hosts Einträge auf master und allen slaves übereinstimmen und korrekt sind (nurd er fqdn und nicht sowas wie "domain.tld domain".
    2) Testen dass Du Dich als root User (es muss root sein für die Installation und Updates!) vom slave aus mit dem master verbinden kannst.
    3) ISPConfig Update auf dme slave durchführen und sagen dass er die permissions auf dem master server neu konfigurieren soll. Voraussetzung dafür ist dass der slave auf dem amster in der Tabelle server existiert, wenn nicht müsste der Slave neu installiert werden.
     

Diese Seite empfehlen