[ispconfig2] Installation auf einem frischen Debian

#1
[ispconfig2] Installation auf einem frischen Debian 5.0.5 [solved]

Hallo zusammen,

frisches, aktuelles Debian, Installation bis fast zum Schluss fehlerfrei durchgelaufen.

Wermutstropfen:

Bitte wählen Sie aus, über welches Protokoll (http oder https (SSL-Verschlüsselung)) Ihr ISPConfig-System erreichbar sein soll:
1) HTTPS
2) HTTP
Ihre Wahl: 1

cp: Fehlender Zieldatei-Operand hinter ».orig«
»cp --help« gibt weitere Informationen.

Warning: fopen(): Filename cannot be empty in /root/install_ispconfig/install.php on line 91

Warning: fclose(): supplied argument is not a valid stream resource in /root/install_ispconfig/install.php on line 97

Warning: fopen(): Filename cannot be empty in /root/install_ispconfig/install.php on line 1049

Warning: fwrite(): supplied argument is not a valid stream resource in /root/install_ispconfig/install.php on line 1053

Warning: fwrite(): supplied argument is not a valid stream resource in /root/install_ispconfig/install.php on line 1055

Warning: fclose(): supplied argument is not a valid stream resource in /root/install_ispconfig/install.php on line 1056

Warning: fopen(): Filename cannot be empty in /root/install_ispconfig/install.php on line 110

Warning: fwrite(): supplied argument is not a valid stream resource in /root/install_ispconfig/install.php on line 111

Warning: fclose(): supplied argument is not a valid stream resource in /root/install_ispconfig/install.php on line 112
Connected successfully to MySQL server
no crontab for root

Warning: touch(): Unable to create file because No such file or directory in /root/install_ispconfig/install.php on line 1381
postmap: fatal: usage: postmap [-Nfinoprsvw] [-c config_dir] [-d key] [-q key] [map_type:]file...
Neustart einiger Dienste...
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert. Falls Sie Quota nachinstalliert haben, fuehren Sie noch die in der Installationsanleitung beschriebenen Schritte durch. Ansonsten ist Ihr System jetzt ohne Reboot einsatzbereit.
Bitte gehen Sie mit Ihrem Browser auf

https://hier.der-hostname.de:81

und loggen sich ein:
Benutzername: admin
Passwort: **********
Any clues?
Mußte schon die dist.txt anpassen, damit ich überhaupt installieren konnte.
(aktuell seit Juni is es ja schon die 5.0.5 ...)

Bisher NIE Probleme bei der Installation gehabt, nur jetzt... :(
 
Zuletzt bearbeitet:

Till

Administrator
#2
Zur Fehlermeldung: Du musst irgendeinen Parameter bei den Angaben vorher falsch eingetippt haben, z.B. irgendwo ein lerzeichen, wo keines hingehört.

Bzgl. dist.txt, das ist bekannt. Die weitaus einfachere Lösung ist jedoch die Versionsnummer in /etc/debian_version zu ändern.

Bisher NIE Probleme bei der Installation gehabt, nur jetzt... :(
Das war auch bevor Debian sich entschlossen hat, sein Versionsnummern Schema zu ändern.
 
#3
Zur Fehlermeldung: Du musst irgendeinen Parameter bei den Angaben vorher falsch eingetippt haben, z.B. irgendwo ein lerzeichen, wo keines hingehört.
Okay, dann mach ich das nochmal step-by-step... :eek:

Das war auch bevor Debian sich entschlossen hat, sein Versionsnummern Schema zu ändern.
Grml, normalerweise würde ich ja da in die Bresche springen, aber wo Du Recht hast... :D
 
#4
Aaaalso, gibt da paar Ungereimtheiten:

PHP:
  $fp = fopen ($dist_ftp_conf, "w");
Das ist wohl ProFTPd.
Hmpf, Symlink ist angelegt laut Perfect setup.

PHP:
  if(!is_file($dist_mail_virtusertable)) phpcaselog(touch($dist_mail_virtusertable), "create ".$dist_mail_virtusertable, $FILE, __LINE__);
das ist Zeile 1381, da wird die virtusertable gesucht und nicht gefunden;
stimmt, ist echt nicht da...?

Öhm, WTF geht das jetzt nicht? :D
Gibts die Möglichkeit, da was von debugging zu sehen?


Und das SSL-Zertifikat scheint auch putt zu sein, habs nachträglich neu angelegt, Verwaltung neu gestartet, jetzt tut er.
Ist das mit Postfix und ProFTPd schlimm, weil er die Dateien nicht erzeugt, oder macht er das später...?


Tuts jetzt wieder, hab die /etc/debian_version geändert, und nu is gut!
 
Zuletzt bearbeitet:

Werbung

Top