[ISPConfig3] Falsches Gateway und DNS Server nach Bassis Installation

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mattula, 18. Jan. 2012.

  1. mattula

    mattula Member

    ispconfig3 3.0.4.2
    debian squeeze 6.0.3

    Hi,

    ist mir jetzt schon bei ein paar Installationen aufgefallen:

    Unter System / Server / Serverkonfiguration => Server
    steht zwar die richtige IP Adresse, Netzmaske und Hostname drin, aber sonst:
    Code:
    Gateway: 192.168.0.1
    Nameserver: 192.168.0.1,192.168.0.2
    
    Diese Adressen hat mein Server definitiv nie gehabt, von daher gehe ich davon aus, dass die irgendwo aus der ISPconfig Default Installation kommen.

    Klar, solange das Haekchen bei Netzwerkkonfiguration nicht gesetzt ist, macht das nix, aber statt falscher Werte sollte vielleicht lieber nix drin stehen oder halt die (zum Zeitpunkt der ISPConfig-Installation) gueltigen Werte.

    Evtl. war das auch hier http://www.howtoforge.de/forum/27603-post8.html ein Grund fuer das falsche Gateway.

    Gruesse,
    Matthias
     
  2. Till

    Till Administrator

    Diese Werte sind durch den Administrator zu setzen, falls man Netzwerkmanegement verwenden will. ISPConfig setzt die Werte nicht da das Netzwerkmanagement normalerweise nicht durch ISPConfig erfolgt und es per Default auch deaktiviert ist.
     
  3. mattula

    mattula Member

    Trotzdem sehe ich keinen Grund dafuer warum ISPConfig an diesen Stellen teilweise Default Adressen eintraegt und teilweise die Adressen aus dem System uebernimmt. Warum nicht entweder einfach ganz leer lassen oder alles uebernehmen?


    Code:
    root@webtest:/usr/local/ispconfig# grep -r "192.168" *
    interface/web/admin/form/server_config.tform.php:                       'default' => '192.168.0.105',
    interface/web/admin/form/server_config.tform.php:                       'default' => '192.168.0.1',
    interface/web/admin/form/server_config.tform.php:                       'default' => '192.168.0.1,192.168.0.2',
    interface/web/mail/form/spamfilter_config.tform.php:                    'default'       => '192.168.0.105',
    interface/web/mail/form/spamfilter_config.tform.php:                    'default'       => '192.168.0.1',
    interface/web/mail/form/spamfilter_config.tform.php:                    'default'       => '192.168.0.1,192.168.0.2',
    interface/web/client/form/reseller.tform.php:                   'value'         => array('192.168.0.1' => '192.168.0.1', '192.168.0.2' => '192.168.0.2'),
    interface/web/client/form/client.tform.php:                     'value'         => array('192.168.0.1' => '192.168.0.1', '192.168.0.2' => '192.168.0.2'),
    server/conf/bastille-firewall.cfg.master:#IP_MASQ_NETWORK="192.168.0.0/16"                        # example
    
    Gruss,
    Matthias

    P.S:

    Ich will mich nicht darueber streiten. Ich wollte den o.g. Umstand nur erwaehnen, da ich denke, dass sowas durchaus zu Fehlkonfigurationen fuehren kann.
     
  4. Till

    Till Administrator

    Ich hab es mal als todo in den Bugtracker aufgenommen.
     

Diese Seite empfehlen