ISPconfig3 + Ngnix + openvz

Till

Administrator
#2
Du kannst keine Openvz Container auf einem Server (Linux instanz) erzeugen auf dem Du auch webseiten hostest da openvz inkompatibel mit Linux system quota ist. Du müsstest also auf die Größenbeschränkung in Webseiten (quota) verzichten wenn Du gleichzeitig openvz Container laufen lassen möchtest, mit nginx hat das also nichts zu tun. Wenn es vorher bei Dir mit apache ging, dannw ar system quota enteweder nicht installiert oder aktiviert, denn mit ispconfig hat das nichts zu tun.

Normalerweise macht man das anders, es wird openvz auf dem server installiert und die webhosting Instanzen laufen dann innerhalb von openvz containern.
 
#3
Quota habe ich deshalb auch nicht installiert. Mal sehen woran es dann hapert.
Danke erst mal für die Info.

PS: Komisch, per Hand ein "vzctl create 101 --ostemplate debian-6.0-i386-minimal" funktioniert einwandfrei. Nur über ISPconfig bekomme ich eine vz nicht erstellt bzw. gestartet...
 
Zuletzt bearbeitet:

Till

Administrator
#4
Existiert denn das ostemplate dass Du als Basis für die VM genommen hast unter diesem Dateinamen? Und wie Du das Ganze debuggen kannst steht ja in der FAQ.
 
#5
Ja, den Fehler mit dem falschen OsTemplatenamen hatte ich bereits schon, deshalb habe ich gerade darauf genau geachtet. :eek:
Ein

root@server1:/var/lib/vz/template/cache# /usr/local/ispconfig/server/server.sh
ergab nur

PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ps.ini on line 1 in Unknown on line 0
13.09.2012-08:38 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
13.09.2012-08:38 - DEBUG - No Updated records found, starting only the core.
13.09.2012-08:38 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
Hilft das vielleicht?
 

Till

Administrator
#6
Dann hast Du entweder keine neue VM erzeugt nachdem Du das debugging aktiviert hast oder den server.sh cronjob nicht auskommentiert wie in der faq beschrieben.
 
#7
Ach so, ich hatte keine neue VM erzeugt - jetzt aber:

root@server1:/var/lib/vz/template/cache# /usr/local/ispconfig/server/server.sh
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ps.ini on line 1 in Unknown on line 0
13.09.2012-08:50 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
13.09.2012-08:50 - DEBUG - Found 3 changes, starting update process.
sh: repquota: Kommando nicht gefunden.
sh: repquota: Kommando nicht gefunden.
/usr/sbin/vzctl
/usr/sbin/vzctl
/usr/bin/fail2ban-client
/sbin/iptables
/sbin/ip6tables
13.09.2012-08:50 - DEBUG - Processed datalog_id 208
13.09.2012-08:50 - DEBUG - Processed datalog_id 209
13.09.2012-08:50 - DEBUG - Processed datalog_id 210
13.09.2012-08:50 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
Jetzt mehr Infos?
 

Till

Administrator
#8
Es scheint so als ob das openvz Modul nicht aktiv ist. Du hattest openvz auch vor ispconfig installiert wie im openvz ispconfig Tutorial beschrieben? Denn wenn es danach installiert wird ist es nicht nutzbar da das Modul serverseitig nicht aktiv ist.

Poste mal die Ausgabe von:

ls /usr/local/ispconfig/server/mods-enabled/

und

ls /usr/local/ispconfig/server/plugins-enabled/
 
#9
huch... stimmt, ich habe ISPconfig vor openvz installiert.
Den Satz:
Installieren Sie als erstes den OpenVZ kernel und die Werkzeuge direkt aus der Debian Squeeze Repository.
habe ich nicht als essentiell erachtet.

root@server1:/var/lib/vz/template/cache# ls /usr/local/ispconfig/server/mods-enabled/
client_module.inc.php database_module.inc.php mail_module.inc.php remoteaction_core_module.inc.php server_module.inc.php web_module.inc.php
cron_module.inc.php dns_module.inc.php monitor_core_module.inc.php rescue_core_module.inc.php vm_module.inc.php
und

root@server1:/var/lib/vz/template/cache# ls /usr/local/ispconfig/server/plugins-enabled/
apps_vhost_plugin.inc.php firewall_plugin.inc.php mailman_plugin.inc.php nginx_plugin.inc.php shelluser_jailkit_plugin.inc.php
bind_plugin.inc.php ftpuser_base_plugin.inc.php mail_plugin.inc.php postfix_filter_plugin.inc.php software_update_plugin.inc.php
cron_jailkit_plugin.inc.php getmail_plugin.inc.php mysql_clientdb_plugin.inc.php postfix_server_plugin.inc.php
cron_plugin.inc.php maildeliver_plugin.inc.php network_settings_plugin.inc.php shelluser_base_plugin.inc.php
Was mache ich jetzt denn? ISPconfig löschen und neu installieren?
 
Zuletzt bearbeitet:

Werbung