ISPConfig3 + Postfix = 550 5.1.1 (kann keine Mails außerhalb des Servers schicken)

#1
Hallo ISPC Gemeinde !!

Nach 24h ohne Schlaf bin ich physisch am Ende:) Habe nach diesem Tut: The Perfect Server - Debian Wheezy (Apache2, BIND, Dovecot, ISPConfig 3) - Page 3 | HowtoForge - Linux Howtos and Tutorials einen über Jahre super funktionierenden Server, der auch aus der selben Anleitungsquelle heraus aufgebaut wurde, neu eingerichtet. Alles funktionierte wieder auf Anhieb und ohne Probleme, bis auf ein Mailübel:

Ich habe mehrere Domains auf dem Server (domain1.de, domain2.de, ...). Jede eingerichtete Mailadresse empfängt korrekt ihre Mail, aber ich kann keine außerhalb des Servers senden :confused:. Von adresse1@domain2.de zu adresse5@domain1.de ist das kein Problem, nur halt darüber hinaus nicht...

Outlook tut so als ob korrekt gesendet, also mail in "gesendete Objekte" und gut, sie kommt aber nicht an und keine weitere Fehlermeldung !!

Squirrelmail gibt beim Versuch zu senden folgendes aus: Requested action not taken: mailbox unavailable 550 5.1.1 <xxxx@gmx.de>: Recipient address rejected: gmx.de :confused: . Das passiert mit jeder anderen Adresse außerhalb des Servers. mail.log sagt folgendes zu diesem Vorgang:

Code:
Jul 17 12:54:27 chicago012 postfix/smtpd[4444]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman 
Jul 17 12:54:27 chicago012 postfix/smtpd[4444]: connect from localhost[127.0.0.1] 
Jul 17 12:54:28 chicago012 postfix/smtpd[4444]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 <xxxx@gmx.de>: Recipient address rejected: gmx.de; from=<ichselber@domain1.de> to=<xxxx@gmx.de> proto=ESMTP helo=<[217.172.179.12]> 
Jul 17 12:54:28 chicago012 postfix/smtpd[4444]: lost connection after RCPT from localhost[127.0.0.1] 
Jul 17 12:54:28 chicago012 postfix/smtpd[4444]: disconnect from localhost[127.0.0.1]
Das da irgendwas rejected wird, habe ich auch selber schon bemerkt:p Aber kein Hinweis auf das Warum!! Habe schon stundenlang herumprobiert, hier im Forum gelesen und auch in der englischen Version. Irgendwie gibt's einige Leute mit einem ähnlichen Problem, da stand dann aber auch mehr dazu in den logs...

Ich weiß einfach nicht mehr weiter, an was das noch liegen kann. Bei der Installation gab es absolut keinen Fehler, alles lief super und der Rest funktioniert ja auch, nur eben das mit dem Senden von Mails nicht :(

Über sachdienliche Hinweise jeder Art wäre ich sehr dankbar !! :)

P.S.: Bei ISPConfig handels es sich um 3.0.5.2 und alles andere ist auch auf dem neuesten Stand (apt-get update / upgrade) ...
 
Zuletzt bearbeitet:
#3
Das ist ein dedizierter Server bei Server4you... Könnte es evtl. auch an irgendeiner blacklistung liegen?? Ich habe es zum Beispiel bei Barracuda auf die Liste geschafft, der Delistungsrequest ist aber schon raus ...
 
#5
Die Seite kannte ich schon .. stehe momentan nur noch bei lashback drinn. Nachmittag hatte ich noch einen Ehrenplatz bei Berracuda, was ja nicht sooo rühmlich ist ... Habe denen gleich einen Delistrequest geschickt, kann aber zur Zeit immer noch nicht mailen, obwohl ich bei Barracuda & Co. schon wieder raus bin ... Hat so ein Eintrag noch etwas an Nachwirkungen ???
 
#6
Guten morgen liebe Gemeinschaft.

Habe wie mein Vorredner auch Debain Wheezy nach dieser schönen Anleitung installiert. Funktioniert auch alles wunderbar bis auf den schönen E-Mail Verkehr. Benutzer meldet sich an nach ein paar Sekunden wieder ab und das wars. Keine Fehlermeldung nichts auffälliges gefunden.
Ups fast vergessen den blacklisttest hab ich auch schon gemacht . Steh anscheinend niergends drin.

Was brauchts ihr alles um mir weiterzuhelfen?

lg pat


p.S.: Ich schlaf grad noch ein bischen. Wer Rechtschreibfehler findet darf sie behalten. *gg* ;-)
 
#7
Guten Morgen !!

Nachdem alle Blacklistungen nun wieder weg sind, immer noch der selber Status. Ohne besondere Meldung wird meine Mail zurückgewieser... von anderen übrigens auch :-(

Code:
Jul 18 08:12:22 chicago012 postfix/submission/smtpd[23216]: connect from 91-65-51-195-dynip.superkabel.de[xx.xx.xx.xxx] 
Jul 18 08:12:23 chicago012 postfix/submission/smtpd[23216]: NOQUEUE: reject: RCPT from 91-65-51-195-dynip.superkabel.de[xx.xx.xx.xxx]: 550 5.1.1 <xxxxx@gmail.com>: Recipient address rejected: gmail.com; from=<ichselber@umatech.de> to=<xxxxxx@gmail.com> proto=ESMTP helo=<MyselfPC> 
Jul 18 08:12:23 chicago012 dovecot: imap-login: Login: user=<u.matthes@umatech.de>, method=PLAIN, rip=xx.xx.xx.xxx, lip=xxx.xxx.xxx.xx, mpid=25874, session=<fOL0F8PhEgBbQTPD
 

Till

Administrator
#8
@Umatech: Schick mir mal bitte eine mail an dev [at] ispconfig [dot] org, ich will mal sehen ob sie bei mir ankommt und was gggf. bei meinem und Deinem Server im mail.log steht. Ich hab bei mir Greylisting drauf, also nicht wundern wenn es etwas dauert und mein Server die Mail erst beim 2. Auslieferungsversuch annimmt.

@Abigail: Welcher Mailclient? Imap oder Pop3?
 
#10
Danke für die versuchte Hilfe !!! Habe die Mail versendet von u.matthes (at) umatech.de .. Outlook tut wieder als ob er was macht, aber nicht kommt durch:

Code:
Jul 18 09:35:23 chicago012 postfix/submission/smtpd[30319]: NOQUEUE: reject: RCPT from 91-65-51-195-dynip.superkabel.de[91.65.51.195]: 550 5.1.1 <dev (at) ispconfig.org>: Recipient address rejected: ispconfig.org; from=<u.matthes (at) umatech.de> to=<dev (at) @ispconfig.org> proto=ESMTP helo=<MyselfPC>
Jul 18 09:35:23 chicago012 dovecot: imap-login: Login: user=<u.matthes (at) umatech.de>, method=PLAIN, rip=91.65.51.195, lip=217.172.179.12,
Habe jetzt es irgendwie den Fehler, dass eine mail an was_anderes@umatech.de mit einem "[FONT=&quot]Must issue a STARTTLS command first" endet... Habe da schon ettliches ausprobiert:

[/FONT]
Code:
smtp_tls_security_level = may
smtp_sasl_security_options = noanonymous

smtpd_use_tls = yes
smtpd_tls_auth_only = no

smtp_enforce_tls = no
... nur ohne erfolg... bin mit meinem Latein jetzt ziemlich stark am ende :-(
 
#11
So.. ich stelle hier einfach mal noch die beiden wichtigsten Config Files rein. Vielleicht findet ja noch jemand beim rüberscheuen einen Denkfehler von mir...

main.cf
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
# smtpd_tls_auth_only = no
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
# smtp_enforce_tls = no
# smtp_tls_security_level = may
# smtp_sasl_security_options = noanonymous


# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = chicago012.server4you.de
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
myorigin = /etc/mailname
mydestination = chicago012.server4you.de, localhost, localhost.localdomain
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
default_transport = error
relay_transport = error
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains = 
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
inet_protocols = all
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf
smtpd_tls_security_level = may
transport_maps = hash:/var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf permit_tls_all_clientcerts
smtpd_client_message_rate_limit = 100
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = dovecot
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
owner_request_special = no
dovecot_destination_recipient_limit = 1
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0
 
#12
master.cf

Code:
#
# Postfix master process configuration file.  For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
#smtp      inet  n       -       -       -       1       postscreen
#smtpd     pass  -       -       -       -       -       smtpd
#dnsblog   unix  -       -       -       -       0       dnsblog
#tlsproxy  unix  -       -       -       -       0       tlsproxy
submission inet n       -       -       -       -       smtpd
  -o syslog_name=postfix/submission
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
smtps     inet  n       -       -       -       -       smtpd
  -o syslog_name=postfix/smtps
  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#628       inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       -       -       -       smtp
relay     unix  -       -       -       -       -       smtp
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
retry     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
#
# ====================================================================
#
# Recent Cyrus versions can use the existing "lmtp" master.cf entry.
#
# Specify in cyrus.conf:
#   lmtp    cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
#
# Specify in main.cf one or more of the following:
#  mailbox_transport = lmtp:inet:localhost
#  virtual_transport = lmtp:inet:localhost
#
# ====================================================================
#
# Cyrus 2.1.5 (Amos Gouaux)
# Also specify in main.cf: cyrus_destination_recipient_limit=1
#
#cyrus     unix  -       n       n       -       -       pipe
#  user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
#
# ====================================================================
# Old example of delivery via Cyrus.
#
#old-cyrus unix  -       n       n       -       -       pipe
#  flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
#
# ====================================================================
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix    -    n    n    -    2    pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}

dovecot   unix  -       n       n       -       -       pipe
  flags=DROhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${user}@${nexthop}
amavis unix - - - - 2 smtp
        -o smtp_data_done_timeout=1200
        -o smtp_send_xforward_command=yes

127.0.0.1:10025 inet n - - - - smtpd
        -o content_filter=
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o mynetworks=127.0.0.0/8
        -o strict_rfc821_envelopes=yes
        -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
Es scheint jetzt bei dieser konfiguration auch nichts mehr von draussen rein zu kommen !?!? Ich weiß jetzt wirklich nicht mehr weiter :confused:
 

Till

Administrator
#13
Wenn Du Dein email system testen möchtest, dann logge Dich per webmail in ein emailkonto Deines Servers ein und send eeine email an das konto mit dem Du eingeloggt bist. Du solltest dann inerhalb einer Minute die Email im Posteingang sehen. Wenn dass funktioniert, dann ist Dein server richtig konfiguriert und Dein problem liegt an äußeren Umständen wie blacklists, firewalls, dns etc.
 
#14
Das mit dem internmailen funktioniert schon wieder, habe ich gelöst. Hatte auch vorhin noch einmal versucht, eine zweite Mail zu schicken an dev@ ... , aber hat wieder nicht funktioniert. Es kommen jetzt auch wieder mails von aussen ... also wieder der alte zustand: intern und von aussen kein Problem, aber Mails nach draussen negativ :-( Aus den Bannlisten bin ich auch raus, da steht nichts mehr drinn ...
 
#15
Schließe mich Umatech an.
von Innen nach Innen kein Problem sofortige Verbindung und Versenden.
Von innen nach Außen (teilweise Handy keine Meldung) über Squirrelmail ein SMTP 550 Fehler
Von Außen nach Innen sollte es nach syslog gehen.

Was ich noch beobachtet habe Wenn ich am Handy abrufe oder auch versenden will.
Syslog anmeldung erscheint (dann kurz warten) abmeldung, ohne irgendeiner anderen Meldung dazwischen.
 

Till

Administrator
#16
versucht mal euch manuell von der shell eures servers aus mit einem externen mailserver zu verbinden, das geht mit telnet.

z.B.:

telnet mail.ispconfig.org 25

dann müsste der mail prompt meines servers erscheinen. Dann gebt mal ein:

ehlo localhost

und drückt return. beenden kann man den prompt mit dem Befehl: quit
 
#17
Hallo Till!!

Danke erst mal für die angedachte Hilfe... kann ich im moment gut gebrauchen, leide schon an Selbstzweifel :) Folgendes kommt beim telnet raus:

Code:
Connected to mail.ispconfig.org.
Escape character is '^]'.
220 v220.ensignweb.de ESMTP Postfix (Debian/GNU)
ehlo localhost
250-v220.ensignweb.de
250-PIPELINING
250-SIZE
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
Exakt das selbe wie bei mir lokal...
 
Zuletzt bearbeitet:
#18
Ich hatte das mit dem Webmail irgendwie falsch verstanden:-( Ich habe jetzt wirklich mal mit dem bei der Installation gemachten default Werten (Option: "D") vom Webmail an mich selbst gemailt und da gibt es eine: "0 Can't open SMTP stream." Fehlermeldung, die auch bei jeder anderen versuchten Adresse kommt. Nach Sichtung dieser default Werte, genauer die SMTP Parameter, sollten diese aber stimmen. Ansonsten kann ich mit Outlook, Thunderbird & Co. zu anderen, aber internen Mailboxen problemlos mailen, was damit dann an mich selber auch wieder funktioniert.
 
Zuletzt bearbeitet:
#19
Soda hab das Problem jetzt anders gelöst.
Habe momentan Debian 6 mit der Standardinstallation drauf, funktioniert sofort. Vielleicht komm ich in 1 oder 2 Wochen noch mal auf diesen Thread zurück.

Danke
 
#20
Ist für mich leider keine Option, da ich ein Minimalimage zum Selber bauen nur noch in 7 bekomme... muss das jetzt also noch irgendwie auf die Reihe bekommen, habe da leider immer noch keinen Lösungsansatz :-(
 

Werbung

Top