ISPConfig3 SSL

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ranger, 6. Feb. 2010.

  1. ranger

    ranger New Member

    Hallo liebes Entwicklerteam!

    Ich habe zwei (eigentlich drei) Fragen zu SSL mit ISPConfig:
    1. Brauche ich für jedes neue SSL-Zertifikat eine neue IP?
    2. Wie richte ich SSL für Subdomains ein?
    3. Ich habe versucht ein SSL-Zertifikat zu installieren und bin wie unter http://ispc-wiki.org/ispconfig3-anleitung vorgegangen. Ich habe es so verstanden, dass man unter dem reiter SSL bei der entsprechenden Domain die Datein eingibt, die Selectbox auf "speichern" setzt und das ganze Form speichert. danach sollte nach einer kurzen dauer das Feld "SSL- Request" gefüllt sein, welches man seinem SSL-Provider sendet. Aber leider klappte das nicht. Das Feld blieb immer leer. Erst als ich die Selectbox auf "Create Certification" gesetzt habe wurde es generiert, aber dann auch gleich das Zertifikat selber. War mir in dem Moment egal und habe den request an meinen SSL-Provider gesendet. Aber wenn ich das vom Provider gelieferte Zertifkat einsetze liefert der Apache keine Webseiten mehr aus. Erst wenn ich das von ISPConfig generierte SSL-Zertifikat einsetze lädt er die Seiten wieder, allerdings natürlich mit der Bemerkung, dass es kein sicheres Zertifikat ist, weil selbst generiert.
    jetzt die Frage: Was habe ich falsch gemacht, dass das SSL-Request nicht generiert wurde?!

    Danke vorab für jede Anwort!
     
  2. Till

    Till Administrator

    1) Ja, das ist im ssl Protokoll so festgelegt und nicht ispconfig spezifisch.
    2) Erstelle eine website für die subdomain und dann ein ssl Zertifikat.
    3) Dann hast Du vermutlich irgendwelche Angaben gemacht, die openssl nicht verarbeiten konnte. Gib am besten keien Sonderzeichen und Umluate ein und auch keine Satzzeichen.
     
  3. ranger

    ranger New Member

    Punkt 1 und 2 sind jetzt klar!

    Aber Punkt 3 will bei mir einfach nicht gehen:
    habe jetzt zum testen überall "abc" eingetargen, bis auf Land, da habe ich "DE" eingesetzt. Aber nichts tut sich. Woran könnte das liegen?! und was muss ich ggf. ändern.

    Besten Dank für Deine Antwort!
     
  4. Till

    Till Administrator

    Und Du hats Deinn server exakt nach einem der auf ispconfog.de aufgelisteten Tutorials installiert? Wenn nicht, kann es auch einfachs ein dass openssl bei Dir fehlt.
     
  5. ranger

    ranger New Member

    Yep! Hab ihn genau nach der Anleitung installiert.
    Ein "Create Zertification" funktioniert auch, aber eben nicht das "Save Certification" zum generieren des Requests.
    in welchen logs müsste ich denn nachschauen um ggf einen Hinweis zu erhalten?
     
  6. ranger

    ranger New Member

    Noch eine kurze Nachfrage zu Punkt 2:
    Wieso gibt es denn dann überhaupt den Punkt "Subdomain" wenn man diese auch als normale Website anlegen kann mit viel mehr Optionen? Könnt ja schnell bei vielen Domains zu Verwirrung/Chaos fürhen wenn man an verscheidenen Stellen suchen muss.
     
  7. Till

    Till Administrator

    Dann ist ja alles ok und nur ein Missverständnis bei der bedienung. Save generiert ja auch garkein Zertifikat und soll dies auch garnicht! die Aktion Save dient nur dazu, das Zertifikat das Du von der Zertifizierungsstelle zurück erhalten hast, zu speichern.
     
  8. Till

    Till Administrator

    Eine subdomain ist ja auch was ganz anderes. Eine subdomain ist ein "amhängsel" einer bestehenden Website und eben keine eigenständige website. Eine subdomain wird als vhost alias eingerichtet und eben nicht als vhost. Die Trennung von alias und subdomain erfolgte auf vielfachen Wunsch der ISPconfig Benutzer, da sie Ihren Kunden eben subdomains für ein web kostenlos zur Verfügung stellen wollen aber eben nicht zusätzliche Domains. Das machen die meisten größeren Hoster so.
     
  9. ranger

    ranger New Member

    Ah, ok!
    Aber in Eurer Anleitung steht folgendes:

    solltet Ihr ggf mal ändern.
     
  10. ranger

    ranger New Member

    ok, jetzt verstehe ich warum! Macht dann auch Sinn...daran habe ich nicht gedacht, weil bei meinem Projekt die User eh nicht auf ispconfig zugreifen sollen, deshalb hatte ich das mit den Limits nichta uf dem Schirm.
    Danke!
     

Diese Seite empfehlen