ISPconfig3 Subdomain anlegen

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von jogy, 31. März 2009.

  1. jogy

    jogy New Member

    Ich versuche den Punkt Subdomain anlegen zu verstehen:

    1. Feld = Name der Subdomain - Beispiel = sub
    2. Feld = Auswahl des Domainname - Beispiel = domain.de
    3. Feld = Redirect Typ = no redirect / no flag / L / R / L,R
    4. Feld = Redirect Pfad = Pfad absolut oder als Beispiel: http://andere-domain.de erfolgen?

    Wo finde ich hierzu eine Erläuterung was das 3. Feld bedeutet?
    Habe ich das mit dem 4. Feld richtig verstanden?
    Nach Eingabe von sub.domain.de müßte doch eine Weiterleitung zu http://andere-domain.de erfolgen?

    DANKE!
     
  2. Till

    Till Administrator

  3. jogy

    jogy New Member

    Das ist ja alles sehr schön dokumentiert. Allerdings müßte doch ISPconfig eine .htaccess Datei im Subdomainverzeichnis anlegen. Das geschieht bei mir jedoch nicht. Wo finde ich denn den Eintrag, den ich im Webinterface als Redirectpfad angebe?
     
  4. Till

    Till Administrator

    ISPConfig legt keine .htaccess im Subdomainverzeichnis an. das ist ja auch nicht nötig da die Rewrite Rules in der Konfiguration des vhost stehen.
     
  5. jogy

    jogy New Member

    Hallo Till!
    Danke für die Antwort! Ich habe in der domain.vhost nachgesehen. Der Eintrag ist korrekt, der Redirect funktioniert aber nicht mehr. Was mir aufgefallen ist, dass Subdomain Alias-Einträge (ServerAlias) nicht mehr vom System entfernt werden wenn Änderungen im Webinterface vorgenommen worden sind. Wie kann ich mich auf die fehlersuche begeben?
    Besten Dank im Voraus!
     
  6. Till

    Till Administrator

    Stehen denn unbearbeitete Aufträge in der jobqueue?
     
  7. jogy

    jogy New Member

    jobqueue ist leider leer...
     
  8. Till

    Till Administrator

    Naja, das ist ja schonmal gut, denn es bedeutet dass der Job ausgeführt wurde. Wenn der redirect dann auch noch korrekt im vhost steht liegt es nicht an ispconfig. was genau hast Du denn als redirect eingetragen?
     
  9. jogy

    jogy New Member

    Erst einmal vielen Dank für die rasche Antwort!
    Die Einträge der domain.vhost lauten:
    -------snip
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^test.domainname.de [NC]
    RewriteRule ^/(.*)$ http://www.test.de$1 [R]
    -------snip

    und sollen bewirken, dass die Subdomain auf eine externe Domain test.de umgeleitet wird. Denkfehler? Schlauchsteher? Komme leider nicht weiter...
     
  10. Till

    Till Administrator

    Du hast den / am Ende der Umleitungs-URL vergessen.
     
  11. jogy

    jogy New Member

    Ok. / ist jetzt drin - leider ohne Erfolg.

    Allerdings wird ein ping auf die Subdomain mit einem "unknown host" quittiert. Normalerweise sollte doch ein ping auf "domain.de" und ping "sub.domain.de" die selbe Anwort haben, zumindest überhaupt eine Antwort haben, wenn auf eine externe, vorhandene Domain verwiesen wird.
     
  12. jogy

    jogy New Member

    Problem gelöst!

    Oh Herr schmeiss Hirn vom Himmel:

    Ich verliess mich zu sehr auf den DNS-Wizard und war damit verlassen. Klar, wenn man eine Subdomain anlegen möchte, benötigt man auch den entsprechenden DNS Eintrag:

    (Kreisch) Nix für ungut und besten Dank!
     

Diese Seite empfehlen